You are not logged in.

#1 2012-02-07 23:11:42

spiros
Member
Registered: 2012-02-07
Posts: 9

[SOLVED] KDE Oxygen style

Hello,

Today I did an upgrade with pacman -Syu and while everything seemed to go okay now Oxygen is missing from the KDE Style menu.
Other styles like CDE, Cleanlooks, Phase etc. are still there. I think only Oxygen is missing.

I searched to find a solution but I only found this: https://wiki.archlinux.org/index.php/KD … ow_manager and it didn't work.

I'm running KDE 4.8 from about 2 days after it was in the repos and this problem occured today.

Anyone knows what the problem might be?

Last edited by spiros (2012-02-09 02:08:57)

Offline

#2 2012-02-08 08:32:38

nwoki
Member
Registered: 2010-09-14
Posts: 48

Re: [SOLVED] KDE Oxygen style

Got the same issue and neither for me did the solution you post work. Waiting to see if anyone here has a solution to our problem

Offline

#3 2012-02-08 21:56:09

maximolz
Member
From: Reggio Calabria, Italy
Registered: 2012-02-08
Posts: 2

Re: [SOLVED] KDE Oxygen style

Hello,
i had the same issue and i found this simple solution:
It seems that KDE ignores the file '/usr/lib/kde4/plugins/styles/oxygen.so'
By simply copying this file as oxygen2.so it seems to work!
The command i launched is:
'sudo cp /usr/lib/kde4/plugins/styles/oxygen.so /usr/lib/kde4/plugins/styles/oxygen2.so'
and after this i reopened the System Setting menu and Oxygen was present in KDE Style menu!

I am trying to find out the proper solution, but meanwhile this works for me!
I hope this procedure could help you!

Last edited by maximolz (2012-02-08 22:29:16)

Offline

#4 2012-02-09 00:50:45

nwoki
Member
Registered: 2010-09-14
Posts: 48

Re: [SOLVED] KDE Oxygen style

Cool, solved the issue for me. Thanks a lot.

Offline

#5 2012-02-09 02:07:51

spiros
Member
Registered: 2012-02-07
Posts: 9

Re: [SOLVED] KDE Oxygen style

maximolz wrote:

Hello,
i had the same issue and i found this simple solution:
It seems that KDE ignores the file '/usr/lib/kde4/plugins/styles/oxygen.so'
By simply copying this file as oxygen2.so it seems to work!
The command i launched is:
'sudo cp /usr/lib/kde4/plugins/styles/oxygen.so /usr/lib/kde4/plugins/styles/oxygen2.so'
and after this i reopened the System Setting menu and Oxygen was present in KDE Style menu!

I am trying to find out the proper solution, but meanwhile this works for me!
I hope this procedure could help you!

This did it for me also.

Thanks maximolz!

Offline

#6 2012-02-09 08:53:14

maximolz
Member
From: Reggio Calabria, Italy
Registered: 2012-02-08
Posts: 2

Re: [SOLVED] KDE Oxygen style

A simple but efficient solution :-)
Have a nice Oxygen :-)

Offline

#7 2012-02-11 10:19:21

aksdb
Member
Registered: 2007-10-07
Posts: 20

Re: [SOLVED] KDE Oxygen style

Same problem here. Renaming did "solve" it for now, thanks for finding that workaround!
I'm still puzzled what might cause such a strange behavior.

Offline

#8 2012-11-10 16:41:40

ilpianista
Fellow developer
From: Lecce, Italy
Registered: 2007-10-06
Posts: 568
Website

Re: [SOLVED] KDE Oxygen style

this works too:

$ rm ~/.config/Trolltech.conf
$ kbuildsycoca4 --noincremental

Offline

Board footer

Powered by FluxBB