You are not logged in.

#1 2012-11-10 23:13:36

jed833
Member
Registered: 2012-04-30
Posts: 18

[SOLVED]ncmpcpp not showing songs

Ok so i know this has been a problem, and I've tried everything to get this to work.
so to begin with I used Rasi's script to set up MPD, and mpd works.
I have also tried using "u" to update the database.

here is my mpd config:

music_directory  		"/home/jed/Music/"
db_file  			"/home/jed/.mpd/database"
log_file 			"/home/jed/.mpd/log"
pid_file 			"/home/jed/.mpd/pid"
state_file  			"/home/jed/.mpd/state"
playlist_directory  		"/home/jed/.mpd/playlists"
#user 				"jed"
#bind_to_address ""  #uncomment if you want to access mpd from other machines
bind_to_address  "127.0.0.1"
bind_to_address  "/home/jed/.mpd/socket"
#group                                "nogroup"
port                                  "6600"
#log_level                            "default"
gapless_mp3_playback                  "yes"
#restore_paused                       "no"
#save_absolute_paths_in_playlists     "no"
metadata_to_use                       "artist,album,title,track,name,genre,date,composer,performer,disc,albumartist,albumartistsort"
auto_update                           "no"
#auto_update_depth                    "3"
#follow_outside_symlinks              "yes"
#follow_inside_symlinks               "yes"
#zeroconf_enabled                     "yes"
#zeroconf_name                        "Music Player"

#password                             "password@read,add,control,admin"
#default_permissions                  "read,add,control,admin"


###### INPUT PLUGINS #####

input {
        plugin                        "curl"
#       proxy                         "proxy.isp.com:8080"
#       proxy_user                    "user"
#       proxy_password                "password"
}

playlist_plugin {
       name                           "lastfm"
       user                           "USER"
       password                       "PASS"
}


##### DECODER #####

decoder {
       plugin                         "ffmpeg"
       enable                         "no"            #disable, because it crashes mpd, if m3u/pls files are present in music_directory
}


###### OUTPUT PLUGINS #####

#audio_output {
# type                                "alsa"
# name                                "Alsa Output"
# device                              "hw:0,1"  # optional
# format                              "44100:16:2"  # optional
# mixer_type                          "software"  # optional
##  mixer_device                      "default" # optional
# mixer_control                       "front-pcm"   # optional
##  mixer_index                       "0"   # optional
#}


#audio_output {
# type                                "recorder"
# name                                "My recorder"
# encoder                             "vorbis"    # optional, vorbis or lame
# path                                "/var/lib/mpd/recorder/mpd.ogg"
##  quality                           "5.0"     # do not define if bitrate is defined
# bitrate                             "128"     # do not define if quality is defined
# format                              "44100:16:1"
#}


#audio_output {
#  type                                "httpd"
#  name                                "Internet Stream"
#  encoder                             "vorbis"    # optional, vorbis or lame
#  port                                "8000"
#  bind_to_address                     "192.168.1.13"    # optional, IPv4 or IPv6
# quality                              "5.0"     # do not define if bitrate is defined
#  bitrate                             "128"     # do not define if quality is defined
# format                               "44100:16:1"
#  max_clients                         "1"     # optional 0=no limit
#}


#audio_output {
#        type                           "pulse"
#        name                           "Pulseaudio"
##      server                         "127.0.0.1   "          # optional
##      sink                           "remote_server_sink"    # optional
#}


#audio_output_format                    "44100:16:2"
#samplerate_converter                  "Fastest Sinc Interpolator"
replaygain                             "album"
replaygain_preamp                      "6"
#volume_normalization                  "no"
#audio_buffer_size                     "2048"
#buffer_before_play                    "10%"
#connection_timeout                    "60"
#max_connections                       "10"
#max_playlist_length                   "16384"
#max_command_list_size                 "2048"
#max_output_buffer_size                "8192"
#filesystem_charset                    "UTF-8"
#id3v1_encoding                        "ISO-8859-1"


##### SIDPlay decoder ######

#decoder {
# plugin                               "sidplay"
# songlength_database                  "/media/C64Music/DOCUMENTS/Songlengths.txt"
# default_songlength                   "120"
# filter                               "true"
#}

and here is my ncmpcpp config:

##### connection settings #####
#
## set it in order to make tag editor and renaming files work properly
#
#mpd_host = "localhost"
#
#mpd_port = "6600"
#
mpd_music_dir = "/home/jed/Music/"
#
mpd_connection_timeout = "5"
#
mpd_crossfade_time = "5"
#

so any ideas?

Last edited by jed833 (2012-11-11 00:30:53)

Offline

#2 2012-11-10 23:40:37

Rasi
Member
From: Germany
Registered: 2007-08-14
Posts: 1,838
Website

Re: [SOLVED]ncmpcpp not showing songs

run mpd with "mpd --verbose --stdout --no-daemon" to get some actual error messages.


He hoped and prayed that there wasn't an afterlife. Then he realized there was a contradiction involved here and merely hoped that there wasn't an afterlife.

Douglas Adams

Offline

#3 2012-11-10 23:43:04

jed833
Member
Registered: 2012-04-30
Posts: 18

Re: [SOLVED]ncmpcpp not showing songs

Ok well here is what I get as an output:

config: loading file /home/jed/.mpdconf
Failed to bind to '127.0.0.1:6600': Address already in use

Offline

#4 2012-11-10 23:43:49

Rasi
Member
From: Germany
Registered: 2007-08-14
Posts: 1,838
Website

Re: [SOLVED]ncmpcpp not showing songs

of course you should kill all mpd instances before....


He hoped and prayed that there wasn't an afterlife. Then he realized there was a contradiction involved here and merely hoped that there wasn't an afterlife.

Douglas Adams

Offline

#5 2012-11-10 23:50:06

jed833
Member
Registered: 2012-04-30
Posts: 18

Re: [SOLVED]ncmpcpp not showing songs

Right my bad.

So here is my output now:

config: loading file /home/jed/.mpdconf
path: path_set_fs_charset: fs charset is: UTF-8
Failed to load database: Failed to open database file "/home/jed/.mpd/database": No such file or directory
output: No "audio_output" defined in config file
output: Attempt to detect audio output device
output: Attempting to detect a alsa audio device
output: Successfully detected a alsa audio device
daemon: opening pid file
daemon: writing pid file
avahi: Initializing interface
avahi: Client changed to state 2
avahi: Client is RUNNING
avahi: Registering service _mpd._tcp/Music Player
avahi: Service group changed to state 0
avahi: Service group is UNCOMMITED
update: spawned thread for update job id 1
update: starting
state_file: Loading state file /home/jed/.mpd/state
state_file: failed to open /home/jed/.mpd/state: No such file or directory
config: option 'enable' on line 49 was not recognized
update: added /Touch Fluffy Tail.mp3
update: added /Three Days Grace - The Chain (Studio Version).mp3
avahi: Service group changed to state 1
avahi: Service group is REGISTERING
mad: detected LAME version 3.98 ("LAME3.98r")
mad: LAME peak found: 0.000000
mad: LAME track gain found: -10.800000
mad: encoder delay is 576, encoder padding is 1692
update: added /Dead Bite.mp3
update: added /kari kimmel - black lyrics_(360p).mp3
database: removing empty directories from DB
database: sorting DB
database: writing DB
update: finished
client: [0] opened from 127.0.0.1:53655
client: [0] process command "status"
mixer: Failed to read mixer for 'default detected output': no such mixer control: PCM
client: [0] command returned 0
client: [0] process command "idle"
client: [0] command returned 1
client: [0] process command "plchanges "0""
client: [0] command returned 0
client: [0] process command "idle"
client: [0] command returned 1
client: [0] process command "idle"
client: [0] command returned 1
client: [0] process command "list Artist"
client: [0] command returned 0
client: [0] process command "idle"
client: [0] command returned 1
client: [0] process command "list Album Artist "Hollywood Undead""
client: [0] command returned 0
client: [0] process command "list Date Artist "Hollywood Undead" Album """
client: [0] command returned 0
client: [0] process command "find Artist "Hollywood Undead" Album "" Date """
client: [0] command returned 0
client: [0] process command "idle"
client: [0] command returned 1
avahi: Service group changed to state 2
avahi: Service 'Music Player' successfully established.
client: [0] process command "status"
client: [0] command returned 0
client: [0] process command "idle"
client: [0] command returned 1
state_file: Saving state file /home/jed/.mpd/state
avahi: Shutting down interface
client: [0] closed
listen: listen_global_finish called
db_finish took 0.000000 seconds

and now it works, all of my songs are in.

Offline

#6 2012-11-11 00:12:45

Rasi
Member
From: Germany
Registered: 2007-08-14
Posts: 1,838
Website

Re: [SOLVED]ncmpcpp not showing songs

lol... all 2 songs? smile


anyway, mark this thread as solved.... please


He hoped and prayed that there wasn't an afterlife. Then he realized there was a contradiction involved here and merely hoped that there wasn't an afterlife.

Douglas Adams

Offline

#7 2012-11-11 00:31:28

jed833
Member
Registered: 2012-04-30
Posts: 18

Re: [SOLVED]ncmpcpp not showing songs

Lol, well 2 songs to test with anyways. Marked as [SOLVED] thanks!

Offline

Board footer

Powered by FluxBB