You are not logged in.

#1 2012-10-16 23:15:28

kmshanah
Member
Registered: 2012-10-16
Posts: 5

[SOLVED] nfsroot install broken after kernel upgrade 3.5.6 to 3.6.2

It seems my nfsroot installations have broken after the kernel upgrade to 3.6.2.
This is as far as the boot process gets now (hand copied from the screen):

IP-Config: eth0 complete (from 10.48.50.20):
 address: 10.48.50.240     broadcast: 10.48.50.255    netmask: 255.255.255.0
 gateway: 0.0.0.0          dns0     : 0.0.0.0         dns1:    0.0.0.0
 domain : local
 rootserver: 10.48.50.20 rootpath:
 filename  : /var/tftpboot/pxelinux.0
NFS-Mount: 10.48.50.20:/srv/nfs4/kvmhost0-rootfs
Waiting 10 seconds for device /dev/nfs ...
mount: Protocol not supported
:: running cleanup hook [udev]
ERROR: Failed to mount the real root device.
Bailing out, you are on your own. Good luck.

sh: can't access tty; job control turned off
[rootfs /]# 

On the server this is what is logged:

Oct 16 21:10:04 tuon dhcpd: DHCPDISCOVER from 00:21:70:eb:02:25 via san
Oct 16 21:10:04 tuon dhcpd: DHCPOFFER on 10.48.50.240 to 00:21:70:eb:02:25 via san
Oct 16 21:10:04 tuon dhcpd: DHCPREQUEST for 10.48.50.240 (10.48.50.20) from 00:21:70:eb:02:25 via san
Oct 16 21:10:04 tuon dhcpd: DHCPACK on 10.48.50.240 to 00:21:70:eb:02:25 via san
Oct 16 21:10:14 tuon rpc.mountd[1323]: authenticated mount request from 10.48.50.240:684 for /srv/nfs4/kvmhost0-rootfs (/srv/nfs4/kvmhost0-rootfs)
Oct 16 21:10:14 tuon rpc.mountd[1323]: refused unmount request from 10.48.50.240 for /new_root (/): not exported

It looks to me like the client is sending the mount request, the server accepts and then for some reason the client thinks it has failed. I can't even see anything strange in the wireshark traces comparing the working client (3.5.6) to the broken one (3.6.2).

Anyone else using nfsroot successfully with the latest kernel?
Any other ideas?

(by the way - despite my directory names, this is using nfs v3 for the rootfs)

Last edited by kmshanah (2012-10-18 03:18:07)

Offline

#2 2012-10-17 03:45:54

hemant_ng
Member
Registered: 2012-07-28
Posts: 6

Re: [SOLVED] nfsroot install broken after kernel upgrade 3.5.6 to 3.6.2

I am facing similar issue when mounting (ext3) / partition at time of startup on my standalone desktop machine. This is broken since 6/7 Oct.
Kernel is linux-ck-p4 and systemd is used (mixed system)

:: running cleanup hook [udev]
:: [v86d] .........
ERROR: Failed to mount the root device.
Bailing out, you are on your own. Good luck.

sh: can't access tty; job control turned off
[rootfs /]#

Offline

#3 2012-10-17 21:10:26

mikep
Member
Registered: 2004-10-24
Posts: 11

Re: [SOLVED] nfsroot install broken after kernel upgrade 3.5.6 to 3.6.2

Just to confirm that I also have this problem with nfsroot (nfs4 this time) with 3.6.2. Downgrading the kernel does make it go away.

When it is working normally I do seem to get refused unmount messages at shutdown for some reason

refused unmount request from 192.168.1.86 for / (/): not exported

, but the /new_root bit is new and I have no idea where it comes from.

refused unmount request from 192.168.1.86 for /new_root (/): not exported

So I wonder if it asking for the wrong path.

Offline

#4 2012-10-18 01:54:53

kmshanah
Member
Registered: 2012-10-16
Posts: 5

Re: [SOLVED] nfsroot install broken after kernel upgrade 3.5.6 to 3.6.2

mikep wrote:

Just to confirm that I also have this problem with nfsroot (nfs4 this time) with 3.6.2. Downgrading the kernel does make it go away.

When it is working normally I do seem to get refused unmount messages at shutdown for some reason

refused unmount request from 192.168.1.86 for / (/): not exported

, but the /new_root bit is new and I have no idea where it comes from.

refused unmount request from 192.168.1.86 for /new_root (/): not exported

So I wonder if it asking for the wrong path.

That unmount issue will be solved by FS#32021.

Unfortunately, that doesn't help with mounting in the first place with 3.6.2 sad

Offline

#5 2012-10-18 02:00:38

kmshanah
Member
Registered: 2012-10-16
Posts: 5

Re: [SOLVED] nfsroot install broken after kernel upgrade 3.5.6 to 3.6.2

Ah - Found it!

In 3.6.2 nfsv3 was split into a separate module, which needs to be added to the initcpio.

Edit /etc/mkinitcpio.conf and add nfsv3 to the MODULES list.

(and regenerate your image, of course - e.g.: mkinitcpio -p linux)

Last edited by kmshanah (2012-10-18 02:17:59)

Offline

#6 2012-11-11 00:11:17

nomorewindows
Member
Registered: 2010-04-03
Posts: 3,003

Re: [SOLVED] nfsroot install broken after kernel upgrade 3.5.6 to 3.6.2

kmshanah wrote:

Ah - Found it!

In 3.6.2 nfsv3 was split into a separate module, which needs to be added to the initcpio.

Edit /etc/mkinitcpio.conf and add nfsv3 to the MODULES list.

(and regenerate your image, of course - e.g.: mkinitcpio -p linux)

Thanks, I needed that!


I may have to CONSOLE you about your usage of ridiculously easy graphical interfaces...
Look ma, no mouse.

Offline

#7 2012-11-11 01:27:42

falconindy
Developer
From: New York, USA
Registered: 2009-10-22
Posts: 4,094
Website

Re: [SOLVED] nfsroot install broken after kernel upgrade 3.5.6 to 3.6.2

This is the sort of thing that should be reported on the bug tracker...

Offline

Board footer

Powered by FluxBB