You are not logged in.

#26 2012-11-11 01:35:56

wilberfan
Member
From: So. Cal
Registered: 2010-12-18
Posts: 236

Re: Systemd poweroff not working [SOLVED]

Dren wrote:

And unfortunately the debug console on F9 stops working by the time I actually need to use it.

Ditto.  The one time I F9'd into the debug console, my keyboard was unresponsive...

And that watchdog thing is interesting.  If you go back and look at my post (#17, above) you can see a message about watchdog right after the final green "OK" in my screenshot...

For us noobs, what's the best way to disable watchdog?

And thanks for taking the "[SOLVED]" off of this topic!  ;-)


Hey, be nice...I'm new at this!

Offline

#27 2012-11-11 02:00:11

Dren
Member
From: Canada
Registered: 2010-12-14
Posts: 27

Re: Systemd poweroff not working [SOLVED]

That's strange, I never got errors about nmi_watchdog myself. It was only when I looked at my kernel parameters that I thought it might be the problem.

I disabled nmi_watchdog by passing nmi_watchdog=0 in the kernel parameters... but that's what broke it in the first place. Maybe you could try nmi_watchdog=1? And, are you using the vanilla kernel? For me, it only caused problems with the 3.7 kernel.

Offline

#28 2012-11-11 05:25:23

wilberfan
Member
From: So. Cal
Registered: 2010-12-18
Posts: 236

Re: Systemd poweroff not working [SOLVED]

Well, neither nmi_watchdog=0 or nmi_watchdog=1 made a lick of difference here.  I'm on kernel 3.6.6-1-ARCH #1 SMP PREEMPT


Hey, be nice...I'm new at this!

Offline

#29 2012-11-11 12:46:20

paranoos
Member
From: thornhill.on.ca
Registered: 2004-07-22
Posts: 442

Re: Systemd poweroff not working [SOLVED]

Apparently the halt command is the issue for me. Running "shutdown -P now" instead works as expected, while "halt" says it's ready to shut down the system but never actually does.

Offline

#30 2012-11-11 12:49:28

65kid
Member
From: Germany
Registered: 2011-01-26
Posts: 663

Re: Systemd poweroff not working [SOLVED]

paranoos wrote:

Apparently the halt command is the issue for me. Running "shutdown -P now" instead works as expected, while "halt" says it's ready to shut down the system but never actually does.

thats intended. "halt" does exactly what it's supposed to do - halt the system. The only reason that I can think of why you might use this is to debug the shutdown process.
If you want the machine to power off, use poweroff (duh!).

Offline

#31 2012-11-11 13:24:13

paranoos
Member
From: thornhill.on.ca
Registered: 2004-07-22
Posts: 442

Re: Systemd poweroff not working [SOLVED]

oh ok! well, halt always worked for me with initscripts to shut down. this problem came up only after switching to systemd (since systemd-sysvcompat contains its own versions of the halt/shutdown/etc... binaries)

hopefully this is of some help to other users

Offline

#32 2012-11-11 18:43:04

Dren
Member
From: Canada
Registered: 2010-12-14
Posts: 27

Re: Systemd poweroff not working [SOLVED]

Yes, halt used to shut down the system entirely - at least for me. I'm not sure what the distinction was between it and poweroff before systemd came along.

That nmi_watchdog thing was a bit of a longshot, since it was my own tinkering that caused it to be a problem for me. What surprises me is that you have the same issue on 2 computers... well, aside from making sure you're not using halt rather than poweroff (particularly when abstracted through guis), I don't have any other suggestions. I hope you get it fixed.

Offline

#33 2012-11-11 18:45:43

wilberfan
Member
From: So. Cal
Registered: 2010-12-18
Posts: 236

Re: Systemd poweroff not working [SOLVED]

Dren wrote:

. What surprises me is that you have the same issue on 2 computers....

In my case it's the same box--two different arch partitions--so the hardware is identical...


Hey, be nice...I'm new at this!

Offline

#34 2012-11-13 17:20:42

fdservices
Member
From: France
Registered: 2012-02-06
Posts: 318

Re: Systemd poweroff not working [SOLVED]

It really seems that systemd is not fit for purpose. My main PC has stopped shutting down again. I will let you know why when I have fixed it.

Andrew

Offline

#35 2012-12-09 18:16:09

fdservices
Member
From: France
Registered: 2012-02-06
Posts: 318

Re: Systemd poweroff not working [SOLVED]

I have seen two updates of systemd so far, and it seems to be working better for me know. The problems seem to be around kde, its shutdown and reboot commands and the systemd-sysvcompat package. I am going to uninstall the latter from the PC and see if it still works OK. (It is not installed on the laptop which works much better)

Andrew

Offline

#36 2012-12-09 18:43:00

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 4,794

Re: Systemd poweroff not working [SOLVED]

Uninstalling systemd-sysvcompat is a very bad idea if you don't have sysvinit installed.

Last edited by Scimmia (2012-12-09 18:44:02)

Offline

#37 2012-12-09 20:06:08

wilberfan
Member
From: So. Cal
Registered: 2010-12-18
Posts: 236

Re: Systemd poweroff not working [SOLVED]

fdservices wrote:

I have seen two updates of systemd so far, and it seems to be working better for me know. The problems seem to be around kde, its shutdown and reboot commands and the systemd-sysvcompat package.

I, too, have seen a couple of systemd updates--and the only thing that's changed is the output messages before it hangs.  I'm using XFCE, so it certainly doesn't involve any KDE issues for me.  :-(


Hey, be nice...I'm new at this!

Offline

#38 2012-12-10 17:25:57

fdservices
Member
From: France
Registered: 2012-02-06
Posts: 318

Re: Systemd poweroff not working [SOLVED]

I rather think that the problem with systemd is that not all software expects to find it. So it is necessary to either check the settings of your software or install systemd-sysvcompat, which installs links between the traditional halt, reboot, poweroff, shutdown etc. commands and systemd. Which is the reason why, for most users, this would be obligatory.

For example KDE as standard uses the poweroff command "/sbin/shutdown -h -P now". I changed this to "/usr/bin/systemctl poweroff" and it works fine.

I do not have systemd-sysvcompat, sysvinit, sysvinit-tools of initscripts installed.

I may of course be wrong, but I will keep this thread updated with anything that I find out.

Andrew

Offline

#39 2013-02-14 15:48:57

fdservices
Member
From: France
Registered: 2012-02-06
Posts: 318

Re: Systemd poweroff not working [SOLVED]

After several updates to systemd and cronie it all seems to be working satisfactorily, so I am marking this thread solved.

Offline

#40 2014-10-22 14:04:13

tarasian666
Member
Registered: 2014-06-05
Posts: 4

Re: Systemd poweroff not working [SOLVED]

I have the same problem on my laptop, on desktop pc, with same arch version, poweroff works fine.
But if system is wokred only few minutes poweroff works fine.

Offline

#41 2014-10-22 22:35:50

rumpelsepp
Member
From: Bavaria
Registered: 2012-11-13
Posts: 104
Website

Re: Systemd poweroff not working [SOLVED]

tarasian666 wrote:

I have the same problem on my laptop, on desktop pc, with same arch version, poweroff works fine.
But if system is wokred only few minutes poweroff works fine.

https://wiki.archlinux.org/index.php/Fo … Bumping.22


Every time I see some piece of medical research saying that caffeine is good for you, I high-five myself. Because I'm going to live forever. -- Torvalds, Linus (2010-08-03).

Offline

#42 2014-10-23 07:02:34

tarasian666
Member
Registered: 2014-06-05
Posts: 4

Re: Systemd poweroff not working [SOLVED]

rumpelsepp wrote:
tarasian666 wrote:

I have the same problem on my laptop, on desktop pc, with same arch version, poweroff works fine.
But if system is wokred only few minutes poweroff works fine.

https://wiki.archlinux.org/index.php/Fo … Bumping.22

And what i should do when old bug appears again? Starting new thread with same issue will also break rules...

Offline

Board footer

Powered by FluxBB