You are not logged in.

#1 2012-11-12 02:46:44

warm
Member
Registered: 2009-06-23
Posts: 42

eToken problem

I use eToken 64k pro every day. I have read last news about end of initscripts support and desided to migrate all my desktops and servers to systemd. I started migration from my netbook ASUS X101CH and found that after successful migration my etoken began to work very unstable.

The problem is in openct. It works only fo a first time after starting openct service (it has no systemd service file, I start it by old way from /etc/rc.d/openct start). Then after removig eToken and plugging it back again openct can not see device. Actually device becomes visible for about 10 seconds and then ifdhandler (program from openct) died with no log or any other messages.

After restarting openct service it works again but to the first removing eToken only. Then all hapens again.

So ... can someone to confirm this issue ?

Is any other way to use eToken with open source driver ?

openct seems dead project for now and pcsclite does support of eToken only by openct -- I did not find other drivers for eToken.

Offline

#2 2014-06-14 10:43:31

colorprint
Member
Registered: 2014-06-13
Posts: 18

Re: eToken problem

I have the same problem with eToken 64k pro and openct sad
Can't start openct at all...

Offline

#3 2014-06-14 12:07:37

colorprint
Member
Registered: 2014-06-13
Posts: 18

Re: eToken problem

I have get systemd openct init file from openct rpm for RedHat linux,
and /usr/lib/pcsc/drivers/openct-ifd.bundle/  folder frokm debian (ubuntu) openct deb package (but replaced openct-ifd.so with /usr/lib/openct-ifd.so already installed with AUR).
Everything works now except one thing - after removing and inserting back the USB key - I always need to restart openct and pcscd (in this order) to get it working.

Offline

#4 2015-11-26 17:10:05

mxlbzn
Member
Registered: 2015-11-26
Posts: 2
Website

Re: eToken problem

This thread seems to be in deep sleep.. let me just silently note that my Aladdin/SafeNet eToken Pro 64k is working relatively well with openct.
After inserting the token, I do

$ sudo openct-control init

Btw,  I am using OpenSC PKCS15, not the proprietary Aladdin/Safenet eToken PKCS11 driver.
However, the token does not work with original opensc package, which is built with pcsc.
I have created opensc-openct AUR package.

Offline

Board footer

Powered by FluxBB