You are not logged in.

#1 2012-11-12 15:40:27

neok
Member
From: Cyprus
Registered: 2003-12-14
Posts: 190
Website

New install, systemd not started at boot (?)

Hi,

I have made a fresh install of Arch using the latest install media. It seems though that systemd is either not started at boot time or more likely it fails to complete its job for some reason. Symptoms are that the console font specified in /etc/vconsole.conf does not take effect and I don't see the various messages that (I think) systemd would print as it brings up the system.

I have tried in vain to find out what is wrong so please help. Apologies if I missed something in the available documentation.

My thanks in advance


Regards

Neoklis ... Ham Radio Call: 5B4AZ

Offline

#2 2012-11-12 15:42:18

nomorewindows
Member
Registered: 2010-04-03
Posts: 3,010

Re: New install, systemd not started at boot (?)

Do you have init=/bin/systemd in your boot loader configuration?


I may have to CONSOLE you about your usage of ridiculously easy graphical interfaces...
Look ma, no mouse.

Offline

#3 2012-11-12 15:46:16

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 14,024
Website

Re: New install, systemd not started at boot (?)

Eh .... you've said what you don't see, but what DO you see?

If you are able to login at all rather than being dumped to the recovery shell, then your init system is most certainly running.


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

#4 2012-11-12 15:48:43

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: New install, systemd not started at boot (?)

neok wrote:

I have made a fresh install of Arch using the latest install media.

New installations use systemd by default.  Systemd is the init system, so if your computer is running, it had to have started with some kind of init system.  Unless you intentionally installed the initscripts package, and removed the systemd-sysvcompat package, you are indeed running systemd.

Do you have the "quiet" parameter in your kernel command line?  That does something really mysterious... it supresses output and makes it... quiet

I fail to understand how your console font has anything to do with whether or not systemd is running.  But if you are still unsure, dump the contents of /proc/1/comm and if it says "systemd" then guess what... you are running... systemd!

Offline

#5 2012-11-12 16:16:08

Lord Bo
Member
Registered: 2012-11-11
Posts: 151

Re: New install, systemd not started at boot (?)

What does

 journalctl  | grep vconsole-setup 

tell you?

Last edited by Lord Bo (2012-11-12 16:16:32)

Offline

#6 2012-11-12 16:22:34

65kid
Member
From: Germany
Registered: 2011-01-26
Posts: 663

Re: New install, systemd not started at boot (?)

regarding the console font: https://bbs.archlinux.org/viewtopic.php … 5#p1184955
systemd doesn't print any messages besides fsck output because printing those messages can actually slow down boot. If you really want to see them remove the "quiet" parameter from your boot parameters.

Offline

#7 2012-11-12 18:08:29

rvc
Member
From: India
Registered: 2012-09-09
Posts: 42
Website

Re: New install, systemd not started at boot (?)

neok wrote:

Hi,

I have made a fresh install of Arch using the latest install media. It seems though that systemd is either not started at boot time or more likely it fails to complete its job for some reason......

try following this thread too.... this is also a thread dealing with systemd and its install errors... i could resolve my issue from this thread...

https://bbs.archlinux.org/viewtopic.php?id=151914


Associated with
VEDGOO.COM
For Wallpapers, Articles, Blogs, Media and much more...
To Browse Arch Specific Wallpapers, feel free to follow this LINK

Offline

#8 2012-11-12 20:31:15

neok
Member
From: Cyprus
Registered: 2003-12-14
Posts: 190
Website

Re: New install, systemd not started at boot (?)

OK, thanks for the tips! Here is what I have now:

The console font problem was indeed the need to put my video driver (nouveau) in the MODULES array of /etc/mkinitcpio.conf and regenerate the initrd image. Console fonts are now what I want (iso01-12x22, I need big font).

This, together with the lack of messages due to the "quiet" parameter, and what I got after boot, was what confused me for a while:

Arch Linux 3.6.6-1-ARCH (tty1)

5b4az login: [    4.659055] sd 10:0:0:0: [sdc] No Caching mode page present
[    4.659068] sd 10:0:0:0: [sdc] Assuming drive cache: write through
[    4.659569] sd 9:0:0:0: [sdd] No Caching mode page present
[    4.659580] sd 9:0:0:0: [sdd] Assuming drive cache: write through
[    4.661045] sd 10:0:0:0: [sdc] No Caching mode page present
[    4.661056] sd 10:0:0:0: [sdc] Assuming drive cache: write through
[    4.661556] sd 9:0:0:0: [sdd] No Caching mode page present
[    4.661567] sd 9:0:0:0: [sdd] Assuming drive cache: write through
[    5.029070] sd 9:0:0:0: [sdd] No Caching mode page present
[    5.029080] sd 9:0:0:0: [sdd] Assuming drive cache: write through
[    5.051815] sd 10:0:0:0: [sdc] No Caching mode page present
[    5.051828] sd 10:0:0:0: [sdc] Assuming drive cache: write through

Note the the login prompt is before the messages regarding the hard disk detection. Originally I thought the login prompt target was not reached, but login works, if somewhat chopped up in appearance. I guess this may be due to heavy paralleling. And by the way, removing the quiet parameter resulted in messages printed from systemd, but it was all over so fast I could'nt read anything. Very impressive!

/proc/1/comm also shows:

systemd-vconsole-setup.service       loaded active exited        Setup Virtual Console

confirming that systemd is running. Rather silly of me to think there was a problem with it....


Regards

Neoklis ... Ham Radio Call: 5B4AZ

Offline

Board footer

Powered by FluxBB