You are not logged in.

#1 2012-11-12 01:14:55

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,661

[Coming soon..] Get systemd/journalctl etc. to respect locale settings

Is it possible to persuade systemd/systemctl/journalctl to respect locale settings?

As my locale is not well supported, I do not expect miracles but it would be nice if systemd would respect it insofar as the rest of the system does. At a minimum, I should be getting dates in the correct locale.

$ locale
LANG=cy_GB.UTF-8
LC_CTYPE="cy_GB.UTF-8"
LC_NUMERIC="cy_GB.UTF-8"
LC_TIME="cy_GB.UTF-8"
LC_COLLATE=C
LC_MONETARY="cy_GB.UTF-8"
LC_MESSAGES="cy_GB.UTF-8"
LC_PAPER="cy_GB.UTF-8"
LC_NAME="cy_GB.UTF-8"
LC_ADDRESS="cy_GB.UTF-8"
LC_TELEPHONE="cy_GB.UTF-8"
LC_MEASUREMENT="cy_GB.UTF-8"
LC_IDENTIFICATION="cy_GB.UTF-8"
LC_ALL=

$ cat /etc/locale.conf
LANG=cy_GB.UTF-8
LANGUAGE=cy_GB:cy:en_GB:en
LC_COLLATE=C

$ ls -l /
total 104
drwxr-xr-x    2 root root  4096 Tach 10 18:41 bin/
drwxr-xr-x    7 root root  4096 Tach 11 00:50 boot/
drwxr-xr-x    6 root root  4096 Maw  18  2012 boot.bkup/
-rw-------    1 root root 25390 Tach 11 03:31 dead.letter
drwxr-xr-x   19 root root  3300 Tach 11 16:19 dev/
drwxr-xr-x  126 root root 12288 Tach 11 19:25 etc/
drwxr-xr-x    7 root root  4096 Tach  7 21:14 home/
lrwxrwxrwx    1 root root     7 Hyd  24 22:37 lib -> usr/lib/
lrwxrwxrwx    1 root root     7 Hyd  24 22:37 lib64 -> usr/lib/
drwx------    2 root root 16384 Tach  9 16:24 lost+found/
drwxr-x---+   2 root root  4096 Tach 11 16:18 media/
drwxr-x---+   8 root root  4096 Tach 11 01:24 mnt/
drwxr-xr-x    7 root root  4096 Tach 10 20:34 opt/
dr-xr-xr-x  222 root root     0 Tach 11 03:30 proc/
drwxr-x---   19 root root  4096 Tach 11 20:13 root/
drwxr-xr-x   29 root root   800 Tach 12 01:01 run/
drwxr-xr-x    2 root root  4096 Tach 10 18:42 sbin/
drwxr-xr-x    4 root root  4096 Hyd  23 15:30 srv/
dr-xr-xr-x   13 root root     0 Tach 11 03:30 sys/
drwxrwxrwt   21 root root   480 Tach 12 01:11 tmp/
drwxr-xr-x   11 root root  4096 Ebr  28  2012 usr/
drwxr-xr-x   16 root root  4096 Tach  7 21:44 var/

$ date
Llu 12 Tach 01:12:32 GMT 2012

But all output from journalctl, systemctl etc. uses English and only English.

(It is also aggravating that KDE insists on English but that is really a further layer.)

Last edited by cfr (2012-11-12 22:24:15)


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#2 2012-11-12 02:19:41

falconindy
Developer
From: New York, USA
Registered: 2009-10-22
Posts: 4,092
Website

Re: [Coming soon..] Get systemd/journalctl etc. to respect locale settings

Needs to be fixed in systemd. Probably reasonable to expect this next release.

Offline

#3 2012-11-12 19:19:19

falconindy
Developer
From: New York, USA
Registered: 2009-10-22
Posts: 4,092
Website

Re: [Coming soon..] Get systemd/journalctl etc. to respect locale settings

Offline

#4 2012-11-12 22:23:07

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,661

Re: [Coming soon..] Get systemd/journalctl etc. to respect locale settings

That's great - thanks so much. I will stop thinking I've configured something wrongly and look forward to the next release!

(Always assuming I still have a laptop to run Arch on, of course...)


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

Board footer

Powered by FluxBB