You are not logged in.

#1 2005-10-15 18:20:02

lilsirecho
Veteran
Registered: 2003-10-24
Posts: 5,000

Mplayer or kmplayer won't play videos (solved)

Mplayer hangs after video select and cannot be exited in Kde.

Kernel 2.6.13.4-1.

Must reboot to eliminate mplayer from kde display.

Kmplayer does not play video either but can be deselected.

Videos OK in kaboodle and noatun displays.

Error message during shutdown..... for mplayer says....error in a02 init....


Sign of the times: Navajo blanket..made in China
Hard work does not kill people but why risk it: Charlie Mccarthy
A man is not complete until he is married..then..he is finished.
When ALL is lost, what can be found? Even bytes get lonely for a little bit!     X-ray confirms Iam spineless!

Online

#2 2005-10-15 20:09:12

Gullible Jones
Member
Registered: 2004-12-29
Posts: 4,863

Re: Mplayer or kmplayer won't play videos (solved)

Try Kaffeine.

Offline

#3 2005-10-15 20:33:22

lilsirecho
Veteran
Registered: 2003-10-24
Posts: 5,000

Re: Mplayer or kmplayer won't play videos (solved)

Tried kaffeine...wouldn't download..


Sign of the times: Navajo blanket..made in China
Hard work does not kill people but why risk it: Charlie Mccarthy
A man is not complete until he is married..then..he is finished.
When ALL is lost, what can be found? Even bytes get lonely for a little bit!     X-ray confirms Iam spineless!

Online

#4 2005-10-15 20:43:49

Gullible Jones
Member
Registered: 2004-12-29
Posts: 4,863

Re: Mplayer or kmplayer won't play videos (solved)

Did you get a "connection reset by peer" message? If that's the problem, remove /tmp/pacman.lck and try again.

Offline

#5 2005-10-15 21:19:44

lilsirecho
Veteran
Registered: 2003-10-24
Posts: 5,000

Re: Mplayer or kmplayer won't play videos (solved)

No....

Want mplayer anyhow!!!!


Sign of the times: Navajo blanket..made in China
Hard work does not kill people but why risk it: Charlie Mccarthy
A man is not complete until he is married..then..he is finished.
When ALL is lost, what can be found? Even bytes get lonely for a little bit!     X-ray confirms Iam spineless!

Online

#6 2005-10-15 21:35:34

Gullible Jones
Member
Registered: 2004-12-29
Posts: 4,863

Re: Mplayer or kmplayer won't play videos (solved)

Uhh, lessee... what sound output are you using for MPlayer? How about for KDE?

Offline

#7 2005-10-15 21:39:55

T-Dawg
Forum Fellow
From: Wilmington, NC
Registered: 2005-01-29
Posts: 2,734

Re: Mplayer or kmplayer won't play videos (solved)

Do you have another media player open along side mplayer like kaffeine? It's given me problems like that until I closed the other app.

Offline

#8 2005-10-15 23:53:35

lilsirecho
Veteran
Registered: 2003-10-24
Posts: 5,000

Re: Mplayer or kmplayer won't play videos (solved)

Kde sound is usb-audio   ...pcm... and works fine in ksCD, atun, kaboodle, and Kde sounds.  Kde mixer has both cmipci and usb options.  I desire usb option. 

I have no other media player open when I try kmplayer or mplayer.

All other media pkgs play correctly and can be closed  They play video with sound and the sound is via usb.


Sign of the times: Navajo blanket..made in China
Hard work does not kill people but why risk it: Charlie Mccarthy
A man is not complete until he is married..then..he is finished.
When ALL is lost, what can be found? Even bytes get lonely for a little bit!     X-ray confirms Iam spineless!

Online

#9 2005-10-16 00:00:57

lilsirecho
Veteran
Registered: 2003-10-24
Posts: 5,000

Re: Mplayer or kmplayer won't play videos (solved)

Result when enter ...pacman -Sy kaffeine
----------------------------------------------------------------------------------------------------------------------------------------
root@n6re ~]# pacman -Sy kaffeine
:: Synchronizing package databases...
:: current is up to date
:: extra is up to date

Targets: kaffeine-0.7.1-3

Total Package Size:   2.1 MB

Proceed with upgrade? [Y/n] y

checking package integrity... done.
loading package data... done.
checking for file conflicts...
error: the following file conflicts were found:
  kaffeine: /opt/kde/share/mimelnk/application/x-mplayer2.desktop: exists in filesystem


errors occurred, no packages were upgraded.

[root@n6re ~]#
Do not appreciate the need to force the install....

Can I do some other thingy?


Sign of the times: Navajo blanket..made in China
Hard work does not kill people but why risk it: Charlie Mccarthy
A man is not complete until he is married..then..he is finished.
When ALL is lost, what can be found? Even bytes get lonely for a little bit!     X-ray confirms Iam spineless!

Online

#10 2005-10-16 00:48:32

lilsirecho
Veteran
Registered: 2003-10-24
Posts: 5,000

Re: Mplayer or kmplayer won't play videos (solved)

Tried ...pacman -Syf kaffeine...Loaded OK.

Problem still persists.  Mplayer hangs as before and cannot close...have to reboot.

kmplayer loads the selected file but does not play.  It closes when x'ed out.


Sign of the times: Navajo blanket..made in China
Hard work does not kill people but why risk it: Charlie Mccarthy
A man is not complete until he is married..then..he is finished.
When ALL is lost, what can be found? Even bytes get lonely for a little bit!     X-ray confirms Iam spineless!

Online

#11 2005-10-16 00:57:16

Gullible Jones
Member
Registered: 2004-12-29
Posts: 4,863

Re: Mplayer or kmplayer won't play videos (solved)

Just get rid of mplayer and use Kaffeine, then. Xine and MPlayer are about equal as of now.

Offline

#12 2005-10-16 01:43:51

lilsirecho
Veteran
Registered: 2003-10-24
Posts: 5,000

Re: Mplayer or kmplayer won't play videos (solved)

Everything plays except kmplayer when mplayer is deleted.  Kaffeine plays, atun plays, and kaboodle plays.

I want mplayer to play in either mplayer or kmplayer as it always has in the past!!!


Sign of the times: Navajo blanket..made in China
Hard work does not kill people but why risk it: Charlie Mccarthy
A man is not complete until he is married..then..he is finished.
When ALL is lost, what can be found? Even bytes get lonely for a little bit!     X-ray confirms Iam spineless!

Online

#13 2005-10-18 23:52:46

lilsirecho
Veteran
Registered: 2003-10-24
Posts: 5,000

Re: Mplayer or kmplayer won't play videos (solved)

Additional info:

/Proc/cpuinfo appears below;
==============================================================
processor       : 0
vendor_id       : AuthenticAMD
cpu family      : 6
model           : 6
model name      : AMD Athlon(TM) XP 1900+
stepping        : 2
cpu MHz         : 1599.898
cache size      : 256 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov$
bogomips        : 3202.77
    As I understand the situation, runtime detection is built in to the mplayer pkg to permit all types of processors to respond to the options that are available for mplayer.

It seems that my system can no longer perform under those runtime arrangements.

Perhaps a later version?   mplayer-1.0pre7-1.pkg.tar.gz is the version downloaded from arch via pacman.


Sign of the times: Navajo blanket..made in China
Hard work does not kill people but why risk it: Charlie Mccarthy
A man is not complete until he is married..then..he is finished.
When ALL is lost, what can be found? Even bytes get lonely for a little bit!     X-ray confirms Iam spineless!

Online

#14 2005-10-19 18:57:16

mattux
Member
Registered: 2004-04-22
Posts: 81

Re: Mplayer or kmplayer won't play videos (solved)

try to start mplayer (in console)

User@kde-konsole # mplayer -vo none -ao none

in this case it should not hang if it you should try to compile mplayer yourself with the gcc 4 patches from lfs http://www.linuxfromscratch.org/blfs/do … c4-1.patch
then

User@kde-konsole # mplayer -vo none -ao oss YOURVIDEO.avi

if this fails its the audio driver (try arts,alsa or what else)
then try

User@kde-konsole # mplayer -vo x11 -ao oss YOURVIDEO.avi

if this fails try something else for x11 (like sdl,gl,gl2,xv or what ever)

hope this help to solve your problems

mattux

Offline

#15 2005-10-20 06:16:32

lilsirecho
Veteran
Registered: 2003-10-24
Posts: 5,000

Re: Mplayer or kmplayer won't play videos (solved)

Thanks for reply...

Googling sez that GCC has changed and that mplayer no longer will play due to dropping of divx4linux and using runtime cpu detection.

Anyhow, I tried the exercises you described and found that the following gave a full screen video display (with artifacts) but no audio.  It also did not shutdown normally. 

    mplayer -vo vesa -ao oss (selected video)...

I have tried several audio options to no avail.

The action obtained is in no way correct for mplayer.

Perhaps an upgrade at a later time will be the solution.


Sign of the times: Navajo blanket..made in China
Hard work does not kill people but why risk it: Charlie Mccarthy
A man is not complete until he is married..then..he is finished.
When ALL is lost, what can be found? Even bytes get lonely for a little bit!     X-ray confirms Iam spineless!

Online

#16 2005-11-23 05:44:08

lilsirecho
Veteran
Registered: 2003-10-24
Posts: 5,000

Re: Mplayer or kmplayer won't play videos (solved)

Mplayer problem solved with hwdetect and initscripts -10 install.


Sign of the times: Navajo blanket..made in China
Hard work does not kill people but why risk it: Charlie Mccarthy
A man is not complete until he is married..then..he is finished.
When ALL is lost, what can be found? Even bytes get lonely for a little bit!     X-ray confirms Iam spineless!

Online

Board footer

Powered by FluxBB