You are not logged in.

#1 2012-11-12 07:07:35

chu887
Member
Registered: 2012-08-25
Posts: 23

A startup message!

my new installed Arch-20121101, after boot from grub2 & before the tty1 shows,
a message jumped out the first line:"/dev/sda3:clean,39896/1969920 files, 429450/7864320 blocks"
my arch was installed in /dev/sda3 , i used "fsck" to check disk problem, but  no eroor found.

so what about your machines ?  how to hidden it ...

Offline

#2 2012-11-12 08:02:29

DSpider
Member
From: Romania
Registered: 2009-08-23
Posts: 2,273

Re: A startup message!


"How to Succeed with Linux"

I have made a personal commitment not to reply in topics that start with a lowercase letter. Proper grammar and punctuation is a sign of respect, and if you do not show any, you will NOT receive any help (at least not from me).

Offline

#3 2012-11-12 08:10:09

chord
Member
Registered: 2012-11-07
Posts: 121

Re: A startup message!

chu887 wrote:

so what about your machines ?  how to hidden it ...

append "console=ttyS0" to kernel boot options

Offline

#4 2012-11-12 18:50:19

teateawhy
Member
From: GER
Registered: 2012-03-05
Posts: 1,045
Website

Re: A startup message!

https://wiki.archlinux.org/index.php/Fsck#fstab_options wrote:

Changing check frequency
By default, fsck checks a filesystem every 30 boots

The information on the wiki is outdated. With systemd the fsck checks a filesystem on every boot.

https://wiki.archlinux.org/index.php/Systemd wrote:

Filesystem mounts
The default setup will automatically fsck and mount filesystems before starting services ...

The default configuration of systemd makes sense in my opinion, and there is no reason to hide the output. If your filesystem is broken you want to know that!

You can speed up the fsck whith this option:

archwiki wrote:

If you have a large /home partition, it might be better to allow services that do not depend on /home to start while /home is being fsck'ed. This can be achieved by adding the following options to the /etc/fstab entry of your /home partition .

noauto,x-systemd.automount

Offline

#5 2012-11-12 20:44:44

DSpider
Member
From: Romania
Registered: 2009-08-23
Posts: 2,273

Re: A startup message!

teateawhy wrote:

The information on the wiki is outdated. With systemd the fsck checks a filesystem on every boot.

I don't know about your system, but it doesn't do that on mine. I'd go crazy if it checked 1.5 TiB on every boot.


https://wiki.archlinux.org/index.php/Sy … tem_mounts

^ Wut?


"How to Succeed with Linux"

I have made a personal commitment not to reply in topics that start with a lowercase letter. Proper grammar and punctuation is a sign of respect, and if you do not show any, you will NOT receive any help (at least not from me).

Offline

#6 2012-11-12 21:46:15

teateawhy
Member
From: GER
Registered: 2012-03-05
Posts: 1,045
Website

Re: A startup message!

DSpider wrote:
teateawhy wrote:

The information on the wiki is outdated. With systemd the fsck checks a filesystem on every boot.

I don't know about your system, but it doesn't do that on mine. I'd go crazy if it checked 1.5 TiB on every boot.


https://wiki.archlinux.org/index.php/Sy … tem_mounts

^ Wut?

I'd go crazy, too. At least on my system fsck is in compliance with the wiki and various other sources, and it checks the root filesystem's partition on every boot. It does'nt bother me because i have a partition of 20gb on an ssd, so it does not take more than 1-3 seconds.
Maybe your root partition is smaller than the 1.5 TiB and only the smaller partition is checked?
Or systemd decides wheter to fsck or not using an intrinsic decision?
Or you can configure its behaviour?

Offline

#7 2012-11-13 03:22:07

chu887
Member
Registered: 2012-08-25
Posts: 23

Re: A startup message!

Thank you for all your replies. It seems that teateawhy is right because I ever tried to modify the /etc/fstab, but no matter what the last field is(0 , 1, 2 ...) the disk check does and the message  "/dev/sda3:clean,..." shows.
The messages before loading the kernel should be made by hardware self test.In fact, some other messages  following this message about wireless card shows before I installed the wireless driver.

Offline

#8 2012-11-13 03:32:17

chu887
Member
Registered: 2012-08-25
Posts: 23

Re: A startup message!

chord wrote:
chu887 wrote:

so what about your machines ?  how to hidden it ...

append "console=ttyS0" to kernel boot options

This method works, thanks for your reply. But now I think there's no reason for hiddening it,let it go.

Offline

#9 2012-11-13 03:53:32

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: A startup message!

chu887 wrote:

The messages before loading the kernel should be made by hardware self test.In fact, some other messages  following this message about wireless card shows before I installed the wireless driver.

I don't understand this comment here.  When you have gotten to the point of ".../dev/sda1: clean..." the kernel and the initramfs have already loaded.  How else do you think that it is running a fsck?

Offline

#10 2012-11-13 05:44:28

chu887
Member
Registered: 2012-08-25
Posts: 23

Re: A startup message!

WonderWoofy wrote:
chu887 wrote:

The messages before loading the kernel should be made by hardware self test.In fact, some other messages  following this message about wireless card shows before I installed the wireless driver.

I don't understand this comment here.  When you have gotten to the point of ".../dev/sda1: clean..." the kernel and the initramfs have already loaded.  How else do you think that it is running a fsck?

The message "/dev/sda3:clean,..." shows after message 'Loading Kernel 3.6 ...' ,'Loading initial ramdisk ...' & before it finishing startup. Perhaps I made a mistake, to change the 'loading' to 'booting' is better:"The messages before booting the kernel should made by hardware test..."

Offline

#11 2012-11-13 06:39:08

karol
Archivist
Registered: 2009-05-06
Posts: 25,427

Re: A startup message!

chu887 wrote:

Thank you for all your replies. It seems that teateawhy is right because I ever tried to modify the /etc/fstab, but no matter what the last field is(0 , 1, 2 ...) the disk check does and the message  "/dev/sda3:clean,..." shows.

This message appears on non-systemd systems too

$ cat /proc/1/comm
init

Tue Nov 13 07:06:25 2012: :: Checking filesystems    [BUSY] /dev/sda1: clean, 46/26208 files, 24492/104420 blocks
Tue Nov 13 07:06:25 2012: /dev/sda4: clean, 29638/1941504 files, 5623423/7755378 blocks

and it's not the fsck you don't want to run on a big partition (this one will run in 2 mounts)

Sun Oct 14 12:56:25 2012: :: Checking filesystems    [BUSY] /dev/sda1: clean, 46/26208 files, 24458/104420 blocks (check in 2 mounts)
Sun Oct 14 12:56:25 2012: /dev/sda4: clean, 46586/1941504 files, 6637244/7755378 blocks

Yes, systemd disregards the sixth column in fstab.

Offline

#12 2012-11-13 08:42:25

DSpider
Member
From: Romania
Registered: 2009-08-23
Posts: 2,273

Re: A startup message!

teateawhy wrote:

It does'nt bother me because i have a partition of 20gb on an ssd, so it does not take more than 1-3 seconds.

That's not checking. 1-3 seconds for 20 GB must mean you have a pretty damn fast SSD, homie!


I think that's the systemd journal.

Last edited by DSpider (2012-11-13 08:43:07)


"How to Succeed with Linux"

I have made a personal commitment not to reply in topics that start with a lowercase letter. Proper grammar and punctuation is a sign of respect, and if you do not show any, you will NOT receive any help (at least not from me).

Offline

#13 2012-11-13 11:09:47

falconindy
Developer
From: New York, USA
Registered: 2009-10-22
Posts: 4,092
Website

Re: A startup message!

karol wrote:

Yes, systemd disregards the sixth column in fstab.

No, it really doesn't.

The fstab unit generator reads the value from /etc/fstab, and it adds dependencies (or doesn't) depending on the value.

And here's a volume on a VM that's been marked as a 0 passno for quite some time:

$ tune2fs -l /dev/vdc1 | grep -E '(Last mount\b)|checked|(volume name)'
Filesystem volume name:   foobar
Last mount time:          Tue Nov 13 06:05:35 2012
Last checked:             Mon Aug 20 11:17:50 2012

When I flip that to a '1', I see the expected output on bootup:

systemd-fsck[218]: foobar: clean, 16/327680 files, 55907/1310459 blocks

There's a difference between running fsck at every bootup (which initscripts does as well), and forcibly checking the disk for consistency at every bootup. Running fsck at every bootup is a good thing. Forcing a consistency check at every bootup is a waste of time.

Last edited by falconindy (2012-11-13 11:14:25)

Offline

#14 2012-11-13 16:23:22

teateawhy
Member
From: GER
Registered: 2012-03-05
Posts: 1,045
Website

Re: A startup message!

Thanks for explaining the difference between running fsck and a fsck consistency check.

Offline

#15 2012-11-14 06:26:51

karol
Archivist
Registered: 2009-05-06
Posts: 25,427

Re: A startup message!

falconindy wrote:
karol wrote:

Yes, systemd disregards the sixth column in fstab.

No, it really doesn't.

I have only one big partition so maybe that's why it doesn't matter if I set it to '0' or leave at '2' (or should I change it to '1'?)

Offline

#16 2012-11-14 06:30:51

DSpider
Member
From: Romania
Registered: 2009-08-23
Posts: 2,273

Re: A startup message!


"How to Succeed with Linux"

I have made a personal commitment not to reply in topics that start with a lowercase letter. Proper grammar and punctuation is a sign of respect, and if you do not show any, you will NOT receive any help (at least not from me).

Offline

#17 2012-11-14 06:38:38

karol
Archivist
Registered: 2009-05-06
Posts: 25,427

Re: A startup message!

Yes, I've read it, but I don't recall setting my '/' to '0 2', so this was done by genfstab, right?

$ cat /etc/fstab
# 
# /etc/fstab: static file system information
#
# <file system> <dir>   <type>  <options>       <dump>  <pass>
tmpfs           /tmp    tmpfs   nodev,nosuid    0       0
# UUID=b4202bdb-4ab5-4471-a667-0f9d78f8c0be
/dev/sda1               /               ext4            rw,relatime,data=ordered        0 2

Offline

#18 2012-11-14 06:57:35

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: A startup message!

Yes, genfstab does that.  But on my multi partition setup, it gave everything a "0 2".

Offline

#19 2012-11-14 08:05:48

karol
Archivist
Registered: 2009-05-06
Posts: 25,427

Re: A startup message!

WonderWoofy wrote:

Yes, genfstab does that.  But on my multi partition setup, it gave everything a "0 2".

Define 'everything' - /tmp too?
I have only this one partition, so this is everything I've got :-)

Should I file a bug report or should we add a note to the installation guide that /etc/fstab needs to be edited after being generated by genfstab?

Offline

#20 2012-11-14 09:20:51

DSpider
Member
From: Romania
Registered: 2009-08-23
Posts: 2,273

Re: A startup message!

karol wrote:

Define 'everything' - /tmp too?

The fstab entry for /tmp is specified by default when you install the base package group (more specifically, the filesystem package from there). And since you're dumping the output of genfstab with two ">>" (append) instead of just one ">" (which would replace the entire file), you're appending to whatever /etc/fstab is already there:

# 
# /etc/fstab: static file system information
#
# <file system>	<dir>	<type>	<options>	<dump>	<pass>
tmpfs		/tmp	tmpfs	nodev,nosuid	0	0

If you don't believe me, check out the default /etc/fstab file for yourself:

# pacman -Syw filesystem --cachedir ~/

karol wrote:

I have only this one partition, so this is everything I've got :-)

Um, genfstab only picks up mounted partitions. That's why it appends "relatime", "data=ordered" and other crap. Because it's too dumb to know better. It just piggybacks on the mount command:

$ mount

Last edited by DSpider (2012-11-14 09:22:56)


"How to Succeed with Linux"

I have made a personal commitment not to reply in topics that start with a lowercase letter. Proper grammar and punctuation is a sign of respect, and if you do not show any, you will NOT receive any help (at least not from me).

Offline

#21 2012-11-14 09:46:13

karol
Archivist
Registered: 2009-05-06
Posts: 25,427

Re: A startup message!

I haven't yet had time to configure my newly installed system, but fstab is on my todo list.


Do you think we should add a note about editing fstab once everything's up and running?
If so, where to put it - https://wiki.archlinux.org/index.php/In … the_system ?

If I have more questions / issues, I'll open a new thread. You can open a discussion in https://wiki.archlinux.org/index.php/Ta … tion_Guide if you want.

Offline

#22 2012-11-14 11:29:18

falconindy
Developer
From: New York, USA
Registered: 2009-10-22
Posts: 4,092
Website

Re: A startup message!

If genfstab assigned a single root partition with a pass of 2, its a bug. Can you reproduce this and provide your /proc/self/mountinfo?

Offline

#23 2012-11-14 11:58:04

karol
Archivist
Registered: 2009-05-06
Posts: 25,427

Re: A startup message!

$ cat /proc/self/mountinfo
14 18 0:3 / /proc rw,nosuid,nodev,noexec,relatime shared:5 - proc proc rw
15 18 0:13 / /sys rw,nosuid,nodev,noexec,relatime shared:6 - sysfs sys rw
16 18 0:5 / /dev rw,nosuid,relatime shared:2 - devtmpfs dev rw,size=254108k,nr_inodes=63527,mode=755
17 18 0:14 / /run rw,nosuid,nodev,relatime shared:10 - tmpfs run rw,mode=755
18 1 8:1 / / rw,relatime shared:1 - ext4 /dev/sda1 rw,data=ordered
19 15 0:15 / /sys/kernel/security rw,nosuid,nodev,noexec,relatime shared:7 - securityfs securityfs rw
20 16 0:16 / /dev/shm rw,nosuid,nodev shared:3 - tmpfs tmpfs rw
21 16 0:10 / /dev/pts rw,nosuid,noexec,relatime shared:4 - devpts devpts rw,gid=5,mode=620,ptmxmode=000
22 15 0:17 / /sys/fs/cgroup rw,nosuid,nodev,noexec shared:8 - tmpfs tmpfs rw,mode=755
23 22 0:18 / /sys/fs/cgroup/systemd rw,nosuid,nodev,noexec,relatime shared:9 - cgroup cgroup rw,release_agent=/usr/lib/systemd/systemd-cgroups-agent,name=systemd
24 22 0:19 / /sys/fs/cgroup/cpuset rw,nosuid,nodev,noexec,relatime shared:11 - cgroup cgroup rw,cpuset
25 22 0:20 / /sys/fs/cgroup/cpu,cpuacct rw,nosuid,nodev,noexec,relatime shared:12 - cgroup cgroup rw,cpuacct,cpu
26 22 0:21 / /sys/fs/cgroup/memory rw,nosuid,nodev,noexec,relatime shared:13 - cgroup cgroup rw,memory
27 22 0:22 / /sys/fs/cgroup/devices rw,nosuid,nodev,noexec,relatime shared:14 - cgroup cgroup rw,devices
28 22 0:23 / /sys/fs/cgroup/freezer rw,nosuid,nodev,noexec,relatime shared:15 - cgroup cgroup rw,freezer
29 22 0:24 / /sys/fs/cgroup/net_cls rw,nosuid,nodev,noexec,relatime shared:16 - cgroup cgroup rw,net_cls
30 22 0:25 / /sys/fs/cgroup/blkio rw,nosuid,nodev,noexec,relatime shared:17 - cgroup cgroup rw,blkio
31 14 0:26 / /proc/sys/fs/binfmt_misc rw,relatime shared:18 - autofs systemd-1 rw,fd=19,pgrp=1,timeout=300,minproto=5,maxproto=5,direct
32 15 0:7 / /sys/kernel/debug rw,relatime shared:19 - debugfs debugfs rw
33 16 0:27 / /dev/hugepages rw,relatime shared:20 - hugetlbfs hugetlbfs rw
34 16 0:12 / /dev/mqueue rw,relatime shared:21 - mqueue mqueue rw
35 18 0:28 / /tmp rw,nosuid,nodev,relatime shared:22 - tmpfs tmpfs rw
falconindy wrote:

If genfstab assigned a single root partition with a pass of 2, its a bug. Can you reproduce this and provide your /proc/self/mountinfo?

I used archlinux-2012.10.06-dual.iso as November image wasn't yet available back then.
WonderWoofy says that it happened for him too and he uses a different partition setup: https://bbs.archlinux.org/viewtopic.php … 5#p1192725

Last edited by karol (2012-11-14 12:51:51)

Offline

#24 2012-11-14 12:15:01

ploub
Member
Registered: 2007-05-16
Posts: 128

Re: A startup message!

I can confirm that genfstab assigned the root partition with a pass of 2 on my multi partition setup, install medium 2012.11.01, installed 2 days ago

Last edited by ploub (2012-11-14 14:54:32)

Offline

#25 2012-11-14 15:06:22

falconindy
Developer
From: New York, USA
Registered: 2009-10-22
Posts: 4,092
Website

Re: A startup message!

I see where this is breaking. Thanks for the heads up.

Offline

Board footer

Powered by FluxBB