You are not logged in.

#1 2012-11-10 21:18:57

FarmerF
Member
From: Netherlands
Registered: 2009-06-08
Posts: 76

wlan works on install media, not after reboot

Hi All,

I have seen some other posts about this chipset but so far not been able to solve my issue. The (to me) confusing part is that the card works perfectly well under the live environment 2012.11.01 (kernel 3.6.4-1) but after a reboot does not work anymore. I use netcfg and would prefer to use it as I use it on two other machines (with realtek chips) which keeps things consistent. I tried the lts kernel (3.0.51-1-lts) instead of the stock one(3.6.6-1) in case it was a kernel issue but to no avail.

lspci gives AR2413/AR2414 [AR5005G(S) 802.11bg]

ip link set wlan0 up gives the error "link is not ready"

lsmod shows ath5k is loaded

wifi-menu does work and shows a few networks, just not mine... It does show one network with an active connection but no essid. Trying to connect to it fails. running netcfg with the profile from the live environment gives a message about authentication/association failing which seems plausible if the netwok can not be found.

Any suggestions of how to find the cause?

Last edited by FarmerF (2012-11-11 08:00:31)

Offline

#2 2012-11-10 23:52:46

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 13,816

Re: wlan works on install media, not after reboot

Just as a sanity check, please post the output of ip link

If eth0 is present, and it is in the DOWN state, try sudo ip link set up eth0 and see if eth0 has a carrier or not.  My system is running on wireless without an Ethernet cable connected to my wired port.

ewaller@odin:~ 1001 %ip link
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN mode DEFAULT 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN mode DEFAULT qlen 1000
    link/ether 00:23:5a:40:e1:40 brd ff:ff:ff:ff:ff:ff
3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP mode DORMANT qlen 1000
    link/ether 00:21:00:d9:45:47 brd ff:ff:ff:ff:ff:ff
ewaller@odin:~ 1002 %ip link set up eth0
RTNETLINK answers: Operation not permitted
ewaller@odin:~[2] 1003 %sudo ip link set up eth0
[sudo] password for ewaller: 
ewaller@odin:~ 1004 %ip link                 
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN mode DEFAULT 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN mode DEFAULT qlen 1000
    link/ether 00:23:5a:40:e1:40 brd ff:ff:ff:ff:ff:ff
3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP mode DORMANT qlen 1000
    link/ether 00:21:00:d9:45:47 brd ff:ff:ff:ff:ff:ff
ewaller@odin:~ 1005 %       
 

Last edited by ewaller (2012-11-10 23:53:21)


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
You assume people are rational and influenced by evidence.  You must not work with the public much. -- Trilby
----
How to Ask Questions the Smart Way

Online

#3 2012-11-11 08:44:38

FarmerF
Member
From: Netherlands
Registered: 2009-06-08
Posts: 76

Re: wlan works on install media, not after reboot

Here is the output from normal and live boot. Differences between the two have been marked red. Note that after bringing eth0 and wlan0 up the output is the same. wifi-menu however failed to find my network in the normal boot.:

normal

ip link

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN mode DEFAULT
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN mode DEFAULT qlen 1000
    link/ether 54:04:a6:62:0a:ad brd ff:ff:ff:ff:ff:ff
3: wlan0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN mode DEFAULT qlen 1000
    link/ether 00:1d:0f:b5:2e:fd brd ff:ff:ff:ff:ff:ff

ip link set eth0 up
ip link

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN mode DEFAULT
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN mode DEFAULT qlen 1000
    link/ether 54:04:a6:62:0a:ad brd ff:ff:ff:ff:ff:ff
3: wlan0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN mode DEFAULT qlen 1000
    link/ether 00:1d:0f:b5:2e:fd brd ff:ff:ff:ff:ff:ff

ip link set wlan0 up
ip link

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN mode DEFAULT
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN mode DEFAULT qlen 1000
    link/ether 54:04:a6:62:0a:ad brd ff:ff:ff:ff:ff:ff
3: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN mode DEFAULT qlen 1000
    link/ether 00:1d:0f:b5:2e:fd brd ff:ff:ff:ff:ff:ff

wifi-menu

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN mode DEFAULT
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN mode DEFAULT qlen 1000
    link/ether 54:04:a6:62:0a:ad brd ff:ff:ff:ff:ff:ff
3: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN mode DEFAULT qlen 1000
    link/ether 00:1d:0f:b5:2e:fd brd ff:ff:ff:ff:ff:ff

live

ip link

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN mode DEFAULT
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN mode DEFAULT qlen 1000
    link/ether 54:04:a6:62:0a:ad brd ff:ff:ff:ff:ff:ff
3: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN mode DEFAULT qlen 1000
    link/ether 00:1d:0f:b5:2e:fd brd ff:ff:ff:ff:ff:ff

ip link set eth0 up
ip link

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN mode DEFAULT
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN mode DEFAULT qlen 1000
    link/ether 54:04:a6:62:0a:ad brd ff:ff:ff:ff:ff:ff
3: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN mode DEFAULT qlen 1000
    link/ether 00:1d:0f:b5:2e:fd brd ff:ff:ff:ff:ff:ff

ip link set wlan0 up
ip link

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN mode DEFAULT
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN mode DEFAULT qlen 1000
    link/ether 54:04:a6:62:0a:ad brd ff:ff:ff:ff:ff:ff
3: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN mode DEFAULT qlen 1000
    link/ether 00:1d:0f:b5:2e:fd brd ff:ff:ff:ff:ff:ff

wifi-menu
ip link

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN mode DEFAULT
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN mode DEFAULT qlen 1000
    link/ether 54:04:a6:62:0a:ad brd ff:ff:ff:ff:ff:ff
3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP mode DORMANT qlen 1000
    link/ether 00:1d:0f:b5:2e:fd brd ff:ff:ff:ff:ff:ff

messages like below show up when issuing a "link set up" command both in live and normal boot and wireless does work in live.

Pv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready

The dmesg output for the chips is the same for  live and normal

dmesg | grep r8169
[    5.728802] r8169 Gigabit Ethernet driver 2.3LK-NAPI loaded
[    5.729172] r8169 0000:03:00.0: irq 44 for MSI/MSI-X
[    5.729469] r8169 0000:03:00.0: eth0: RTL8168e/8111e at 0xffffc9000066e000, 54:04:a6:62:0a:ad, XID 0c200000 IRQ 44
[    5.729475] r8169 0000:03:00.0: eth0: jumbo features [frames: 9200 bytes, tx checksumming: ko]
[  138.134881] r8169 0000:03:00.0: eth0: link down

dmesg | grep ath
[    9.702595] ath5k 0000:05:00.0: registered as 'phy0'
[   10.448684] ath: EEPROM regdomain: 0x809c
[   10.448696] ath: EEPROM indicates we should expect a country code
[   10.448701] ath: doing EEPROM country->regdmn map search
[   10.448706] ath: country maps to regdmn code: 0x52
[   10.448711] ath: Country alpha2 being used: CN
[   10.448716] ath: Regpair used: 0x52
[   10.506192] ath5k: phy0: Atheros AR2413 chip found (MAC: 0x78, PHY: 0x45)

The live environment however has cfg and ieee output in dmesg which is not there during the normal boot

 
[    9.515095] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[    9.515099] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[    9.515102] cfg80211:   (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[    9.515105] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[    9.515108] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[    9.515111] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[    9.602393] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[   10.502214] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
[   10.504309] cfg80211: Calling CRDA for country: CN
[   10.508798] cfg80211: Regulatory domain changed to country: CN
[   10.508806] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[   10.508810] cfg80211:   (2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm)
[   10.508813] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (N/A, 3000 mBm)
[   10.515170] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready

lspci gives the following for both systems:

03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 06)
	Subsystem: ASUSTeK Computer Inc. P8P67 and other motherboards
	Flags: bus master, fast devsel, latency 0, IRQ 44
	I/O ports at e000 [size=256]
	Memory at d0004000 (64-bit, prefetchable) [size=4K]
	Memory at d0000000 (64-bit, prefetchable) [size=16K]
	Capabilities: [40] Power Management version 3
	Capabilities: [50] MSI: Enable+ Count=1/1 Maskable- 64bit+
	Capabilities: [70] Express Endpoint, MSI 01
	Capabilities: [b0] MSI-X: Enable- Count=4 Masked-
	Capabilities: [d0] Vital Product Data
	Capabilities: [100] Advanced Error Reporting
	Capabilities: [140] Virtual Channel
	Capabilities: [160] Device Serial Number XX-XX
	Kernel driver in use: r8169

05:00.0 Ethernet controller: Atheros Communications Inc. AR2413/AR2414 Wireless Network Adapter [AR5005G(S) 802.11bg] (rev 01)
	Subsystem: Atheros Communications Inc. Compex Wireless 802.11 b/g  MiniPCI Adapter, Rev A1 [WLM54G]
	Flags: bus master, medium devsel, latency 168, IRQ 18
	Memory at fea00000 (32-bit, non-prefetchable) [size=64K]
	Capabilities: [44] Power Management version 2
	Kernel driver in use: ath5k

lsmod shows some differences in order (in live r8169 is loaded after ath5k and ath) but the rest is the same

lsmod
Module                  Size  Used by
r8169                  56839  0 
ath5k                 135456  0 
ath                    15361  1 ath5k
mac80211              424764  1 ath5k
cfg80211              176994  3 ath,ath5k,mac80211
rfkill                 15604  2 cfg80211,asus_wmi
mii                     4091  1 r8169

Disabling the wiredchip in the bios did not seem to change much. I additionaly tried to use a wireless stick (rt2800, rt3070) which finds my ssid (but no others) but can not connect.

Last edited by FarmerF (2012-11-11 08:45:41)

Offline

#4 2012-11-11 18:18:58

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 13,816

Re: wlan works on install media, not after reboot

Okay, wait.  I must have been paying too much attention to the (American Rules) football game last night.  I (somehow) thought you were fighting with the wired LAN.  Rewind...

The wireless LAN shows up in your list of interfaces.

Lets look at a couple things.  These may require you install some packages.

What is the output of rfkill list and of iwlist scan?

ewaller@odin:~ 1001 %rfkill list
0: hp-wifi: Wireless LAN
	Soft blocked: no
	Hard blocked: no
1: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no
ewaller@odin:~ 1002 %sudo iwlist scan
[sudo] password for ewaller: 
usb0      Interface doesn't support scanning.

eth0      Interface doesn't support scanning.

lo        Interface doesn't support scanning.

wlan0     No scan results

(BTW, I've no scan results as I am away from civilization watch my equestrian daughter ride.  Android Tethers work great)


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
You assume people are rational and influenced by evidence.  You must not work with the public much. -- Trilby
----
How to Ask Questions the Smart Way

Online

#5 2012-11-12 21:31:26

FarmerF
Member
From: Netherlands
Registered: 2009-06-08
Posts: 76

Re: wlan works on install media, not after reboot

Rfkill list gives:

 
0: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no

Iwlist scan gives a multitude of networks around here.

Meanwhile another problem has manifested itself. I first tried another distribution but it would randomly hang. Now it seems the distribution was not at fault.

Under arch I get message about ohci_eci or some similar dying. Google suggests it is an usb issue but given my situation I removed the wireless card to see if that helps. I if so I'll just get a replacement with another chip set.

I'll update this issue either way in about two days.

@ewaller: thanks for the help so far.

Offline

Board footer

Powered by FluxBB