You are not logged in.

#1 2012-11-11 23:59:10

JesApp
Member
Registered: 2012-11-11
Posts: 2

[SOLVED] No audio when playing DVDs (totem/gstreamer)

Hey everybody,

I have just reinstalled archlinux from scratch and so far it is working great, except for one thing: I can not get the sound on DVDs to play. I am using totem with gstreamer as a backend. When I run totem from the command line, I get the following error (among a lot of other messages):

** Message: Missing plugin: gstreamer|1.0|totem|DVD AC-3 (ATSC A/52)-Decoder|decoder-audio/x-private1-ac3 (DVD AC-3 (ATSC A/52)-Decoder)

I have installed the following packages:

gstreamer0.10
gstreamer0.10-plugins
gst-libav
libdvdcss
libdvdnav
libdvdread
a52dec

The video from the dvd works fine, as do all other video formats I have tried including their audio streams. In other words: gstreamer seems to be unable to locate the one plugin that decodes ATSC A/52 audio data, despite being able to find all other plugins.

I am pretty much out of ideas, here. Any help would be greatly appreciated!

Last edited by JesApp (2012-11-12 22:56:04)

Offline

#2 2012-11-12 00:03:49

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: [SOLVED] No audio when playing DVDs (totem/gstreamer)

There was an update for gstreamer.  So there are now two sets of gstreamer packages in the repos.  This is because apparently not all programs have been updated to use the new library as of yet, so both sets may be needed.  They are labeled gst-plugins-{good,bad,ugly,etc}

Offline

#3 2012-11-12 22:55:46

JesApp
Member
Registered: 2012-11-11
Posts: 2

Re: [SOLVED] No audio when playing DVDs (totem/gstreamer)

Yes, that did it! Thank you ever so much, WonderWoofy!

Offline

Board footer

Powered by FluxBB