You are not logged in.

#1 2012-11-13 15:29:21

jo-shva
Member
From: Sherman, TX USA
Registered: 2010-10-18
Posts: 124

Gnome-Shell freezes with 'win'key or 'hot-corner' [SOLVED]

The freeze with gnome-shell happens with 'win'key or 'hot-corner'.  It seems to be random.  Gnome is completely frozen except that I can still move the cursor.   I can exit the session by tty2.  I have tried the  pkill X in shell and tried to restart x.  I get stuck back at the login with the message Oh no! Some thing has gone wrong. Every TIme.  The only answer is to Reboot.
During shutdown I receive this error:  CRITICAL **: unable to create file '/run/user/1000/dconf/user': Permission denied.  dconf will not work properly. I get this message filling the screen.
Btw, still happening with Gnome-Shell 3.6.2. 
Perhaps this pertains to the problem:
I have a fresh reinstall of Arch.  I have found several places in my home directory's 'dot' files where the permissions are set to root user.  For example the ~/.cache file was owned by root, I was unable to start Rhythmbox until I changed it.  I mention this because the error message after the crash pertains to file permissions.  And I don't believe that this is caused by gnome-shell, but I think it is exposed by gnome-shell. 
Anyone with any ideas? Why does root have ownership of several dot directories in home directory.  It seems like file permissions are wrong/off throughout this fresh reinstall.

I can list any logs that may be of use, but the logs listed by user 'syslock' on the post in 'TESTING' listed bellow are near identical.

Several posts with the same issue are in the 'TESTING' repo topics. https://bbs.archlinux.org/viewtopic.php?id=151788   Since 3.6 is no longer in testing I figured I should post here.
HELP

Last edited by jo-shva (2012-11-19 13:11:22)


"Democracy is being allowed to vote for the candidate you dislike least." -- Robert Byrne
http://killhellokitty.deviantart.com/

Offline

#2 2012-11-13 15:55:13

teateawhy
Member
From: GER
Registered: 2012-03-05
Posts: 1,001
Website

Re: Gnome-Shell freezes with 'win'key or 'hot-corner' [SOLVED]

For your home folder it is save to change the ownership of its contents to your user.

chown -R youruser:users /home/youruser

You can also create your own group so other users can not read your files.

The other issue about wrong permissions in the /run/user/1000/ directory is a bug, you should follow the thread you linked to.
Currently the last comment says the issue is not fixed.

Offline

#3 2012-11-14 12:10:59

jo-shva
Member
From: Sherman, TX USA
Registered: 2010-10-18
Posts: 124

Re: Gnome-Shell freezes with 'win'key or 'hot-corner' [SOLVED]

Thank you, and yes I did that for my home folder.  I was offering that as another example of  incorrect directories permissions on fresh install.
As for the other thread, it only includes messages from users experiencing the same problem.  The last post was 6 days ago, and nobody has offered any ideas or options as to what to do.  This issue has been plaguing some of us since gnome3.6 hit testing.  I'm frustrated and anxious for answeres.

I found a blog describing how to use sudo to start x-applications instead of gksu.  So far so good.  I don't recieve any error messages with gedit or nautilus while opened as root.  If gnome-shell doesn't crash for a day than im in the clear and will post solution.

Last edited by jo-shva (2012-11-14 13:29:05)


"Democracy is being allowed to vote for the candidate you dislike least." -- Robert Byrne
http://killhellokitty.deviantart.com/

Offline

#4 2012-11-15 15:59:11

jo-shva
Member
From: Sherman, TX USA
Registered: 2010-10-18
Posts: 124

Re: Gnome-Shell freezes with 'win'key or 'hot-corner' [SOLVED]

The culprit of the gnome-shell crashing is GKSU.  Since removing  'gksu 2.0.2-4' and  'libgksu 2.0.12-5'  i haven't had and crashes and no flooding the system with

gnome-session[2850]: CRITICAL: unable to create file '/run/user/1000/dconf/user': Permission denied.  dconf will not work properly.

error messages.

In the meantime I am using the suggestion from this blog http://dev-loki.blogspot.com/2010/06/su … nsuse.html  to have sudo open x-applications.
With visudo I added this line

 Defaults env_keep += "DISPLAY XAUTHORITY XAUTHLOCALHOSTNAME"

Then I created this wrapper script

#!/bin/bash
[ -n "$XAUTHORITY" ] || XAUTHORITY="$HOME/.Xauthority"
export XAUTHORITY
exec sudo "$@"

I then installed it to /usr/local/bin/xsudo
I use xsudo to call it.
Is this done correctly for ArchLinux?  Is there anyway to be able to use it in the RUN-Dialog(alt-f2) in gnome-shell? 
Help would be greatly appreciated.

The only downside to using it so far is that it doesn't retain bookmarks etc withing its sudo-oppened windows. And that I have to run it within a terminal application.

Last edited by jo-shva (2012-11-15 16:04:38)


"Democracy is being allowed to vote for the candidate you dislike least." -- Robert Byrne
http://killhellokitty.deviantart.com/

Offline

#5 2012-11-19 13:10:46

jo-shva
Member
From: Sherman, TX USA
Registered: 2010-10-18
Posts: 124

Re: Gnome-Shell freezes with 'win'key or 'hot-corner' [SOLVED]

I found a better solution that uses polkit here: https://alderaan.archlinux.org/viewtopi … id=1020120
I'll mark as solved.


"Democracy is being allowed to vote for the candidate you dislike least." -- Robert Byrne
http://killhellokitty.deviantart.com/

Offline

Board footer

Powered by FluxBB