You are not logged in.

#1 2012-11-14 09:12:46

FreeTheBee
Member
Registered: 2011-01-02
Posts: 124

[Solved] 0 size packages and no video after update

Hi, I have a bit of a problem after updating my system. I updated libgsf, libpng12, luajit, pango and gnome-icon-theme(+symbolic) and cannot start x anymore (awesome wm). I thought libpng12 might be the culprit, so I tried downgrading, but this didn't work because of conflicting files errors.

Looking in the cache folder I saw that all of the above mentioned packages, except gnome-icon...symbolic, have 0 size in /var/cache/pacman/pkg. So, I deleted the packages with rm -f, since it wouldn't work without forcing and tried reinstalling, giving the conflicting files errors again. I kinda expected that, but trying takes only a second smile.
I am also, not sure if the 0 size is related to my accidentally resetting my pc, and possibly being a  mere filesystem issue.

My next step would be forcing the reinstallation of these packages, but since this could be risky, I though to ask some advice first. Would forcing be the best thing to do, or would there be something else I can try first?

Last edited by FreeTheBee (2012-11-14 09:33:13)

Offline

#2 2012-11-14 09:32:50

FreeTheBee
Member
Registered: 2011-01-02
Posts: 124

Re: [Solved] 0 size packages and no video after update

I was too impatient (need to get to work), so I uninstalled all the packages that were involved in the last update, but this did not remove any files it seemed. So I forced the reinstalls hoping to overwrite the corrupt files and that worked. Things seem fine again.

Offline

Board footer

Powered by FluxBB