You are not logged in.

#1 2012-11-14 16:31:58

tuxtard
Member
Registered: 2012-10-11
Posts: 30

[SOLVED] Archiso autostart gdm

Hello there. I am trying to enable automatic startup of GDM (or KDM) on my liveiso built with Archiso. I was able to do this before using initscripts, but now when the systemd is a way to go I don't know how to achieve this. Any hints?

Last edited by tuxtard (2012-11-15 10:30:00)

Offline

#2 2012-11-14 18:29:28

Lord Bo
Member
Registered: 2012-11-11
Posts: 143

Re: [SOLVED] Archiso autostart gdm

Look for the service file, which is reponsible for starting gdm, should be in /usr/lib/systemd/system, then look into the install section to see, where you have to create symlinks for this file. See also man systemd, the part where the enable command is explained.

Offline

#3 2012-11-14 19:22:31

tuxtard
Member
Registered: 2012-10-11
Posts: 30

Re: [SOLVED] Archiso autostart gdm

I tried to manually create this symlink:

/etc/systemd/system/display-manager.service -> /usr/lib/systemd/system/gdm.service

but it did not work. Symlink appeared in the proper location on the live iso, but it had no effect.

Offline

#4 2012-11-14 22:53:54

solar
Member
Registered: 2011-03-01
Posts: 75

Re: [SOLVED] Archiso autostart gdm

nano releng/root-image/root/customise-root.sh

s/multi-user.target/graphical.target gdm.service/

When I do it this way, I also comment out the autologin getty service.

np


I am hilariously insane. yup. you won't notice though.. I promise...I think.

Offline

#5 2012-11-14 22:55:40

solar
Member
Registered: 2011-03-01
Posts: 75

Re: [SOLVED] Archiso autostart gdm

on a side note.... system files including your own custom ones should be placed in /usr/lib/systemd/system

so when you *enable* them, systemd automatically creates a symlink IN /etc/systemd/system lol smile

Not the other way round.


I am hilariously insane. yup. you won't notice though.. I promise...I think.

Offline

#6 2012-11-15 10:29:46

tuxtard
Member
Registered: 2012-10-11
Posts: 30

Re: [SOLVED] Archiso autostart gdm

It worked, thank you. I tried before to enable gdm.service and disable autologin, but I forgot to switch to graphical.target. My systemctl line in customize_root_image.sh now looks like this:

systemctl enable graphical.target gdm.service pacman-init.service dhcpcd.service

Offline

#7 2012-11-17 02:58:42

solar
Member
Registered: 2011-03-01
Posts: 75

Re: [SOLVED] Archiso autostart gdm

sounds good. By enabling gdm.service it automatically links to default.target (or is meant to)... however, perhaps some of the scripts have defined default.target already or so.. worth playing around with. smile


I am hilariously insane. yup. you won't notice though.. I promise...I think.

Offline

Board footer

Powered by FluxBB