You are not logged in.

#26 2012-11-14 20:21:59

zozo
Member
From: Belgium
Registered: 2012-11-14
Posts: 3

Re: [solved] skype 4.1 not running on 64bit

Shouldn't this thread be marked as solved?

Offline

#27 2012-11-14 20:31:51

capoeira
Member
From: Vila Velha - Brasil
Registered: 2010-05-25
Posts: 448

Re: [solved] skype 4.1 not running on 64bit

zozo wrote:

Shouldn't this thread be marked as solved?


it's not solved

Offline

#28 2012-11-14 21:37:42

Vegita
Member
Registered: 2009-10-06
Posts: 111

Re: [solved] skype 4.1 not running on 64bit

and that yaourt/aur thing has 404 in PKGBUILD (as I didn't want to build 25+ packages from aur, I removed the lib32-gstreamer-base from the dependencies, but realised, that it's still unable to get installed)

Offline

#29 2012-11-14 21:41:29

merilius
Member
Registered: 2012-06-15
Posts: 10

Re: [solved] skype 4.1 not running on 64bit

I am installing lib32-qtwebkit from aur...
I already compiled and installed some 20 "lib32-*" packages and it is getting more and more...
I am giving up!
Someone should compile lib32-qtwebkit and move it to extra, multilib or so...

The update of skype was definitely NOT tested. I am disappointed !!

Offline

#30 2012-11-14 21:51:24

rudygotya
Member
Registered: 2011-10-04
Posts: 4

Re: [solved] skype 4.1 not running on 64bit

The update of skype was definitely NOT tested. I am disappointed !!

happens (to me, too). relax - there's much more important stuff than that proprietary blob wink and v4.0 still works.

Offline

#31 2012-11-14 22:01:48

merilius
Member
Registered: 2012-06-15
Posts: 10

Re: [solved] skype 4.1 not running on 64bit

Offline

#32 2012-11-14 22:09:57

Vegita
Member
Registered: 2009-10-06
Posts: 111

Re: [solved] skype 4.1 not running on 64bit

It will require that gstreamer thing too in lib32, but that's not true that it requires that much libs

But as I told before: don't try, in the end it will turn out that the PKGBUILD of the lib32-qtwebkit is completely wrong, even if you can istall those 25+ lib32s (from which only 3 is required actually, qtwebkit and 2 gstreamer packages, check i686 in pacman repos).

Offline

#33 2012-11-14 22:41:03

phil
Member
Registered: 2012-09-22
Posts: 72

Re: [solved] skype 4.1 not running on 64bit

It works. It takes some time but Skype works after it. But a downgrade and waiting would be easier...

Offline

#34 2012-11-14 23:57:26

capoeira
Member
From: Vila Velha - Brasil
Registered: 2010-05-25
Posts: 448

Re: [solved] skype 4.1 not running on 64bit

merilius wrote:

The update of skype was definitely NOT tested. I am disappointed !!



agree. I know Arch is bleeding edge, but what are testing repros for if not for testing?

Offline

#35 2012-11-15 00:03:58

marijus
Member
Registered: 2012-03-12
Posts: 20

Re: [solved] skype 4.1 not running on 64bit

capoeira wrote:
marijus wrote:

for me just installing qtwebkit from extra repo solved the problem...

# pacman -S qtwebkit

you're on 32bit?

yes 32 bit here

sorry... misreading the topic

Offline

#36 2012-11-15 00:24:58

Allan
Developer
From: Brisbane, AU
Registered: 2007-06-09
Posts: 10,397
Website

Re: [solved] skype 4.1 not running on 64bit

merilius wrote:

The update of skype was definitely NOT tested. I am disappointed !!

What are users for if not testing?

(BTW, this issue was not caught primarily due to it being a binary blob)

Offline

#37 2012-11-15 01:49:38

pbCyanide
Member
Registered: 2012-06-15
Posts: 30

Re: [solved] skype 4.1 not running on 64bit

after installing trillion packages, i couldn't install the one i needed... so I framed this one instead https://www.archlinux.org/packages/extra/i686/qtwebkit/
and it worked, now skype is working... I didn't test it though (neither are Arch tester) but you could try to install this package only...

Offline

#38 2012-11-15 04:24:22

silent
Member
Registered: 2008-08-05
Posts: 51

Re: [solved] skype 4.1 not running on 64bit

.

Last edited by silent (2013-08-21 09:04:52)

Offline

#39 2012-11-15 04:53:27

phanisvara
Member
From: west bengal, india
Registered: 2012-07-08
Posts: 74

Re: [solved] skype 4.1 not running on 64bit

Allan wrote:
merilius wrote:

The update of skype was definitely NOT tested. I am disappointed !!

What are users for if not testing?

not a particularly friendly reply. i thought [testing] was for what it's name implies, and the other repos supposed to be more or less stable. of course things go wrong, and with arch that happens much less than i was expecting. still, if the above quote from one of arch's main developers reflected the distro's overall philosophy & working, i'd have to change my opinion about the project. (and while this is of no importance to 'the project,' it is to me.)

Allan wrote:

(BTW, this issue was not caught primarily due to it being a binary blob)

how's that? blob or not, this accident means that nobody tried to install the new skype on a 64bit system before pushing the upgrade. fair enough, but why not say so?

Offline

#40 2012-11-15 05:29:05

Allan
Developer
From: Brisbane, AU
Registered: 2007-06-09
Posts: 10,397
Website

Re: [solved] skype 4.1 not running on 64bit

phanisvara wrote:
Allan wrote:
merilius wrote:

The update of skype was definitely NOT tested. I am disappointed !!

What are users for if not testing?

not a particularly friendly reply. i thought [testing] was for what it's name implies, and the other repos supposed to be more or less stable. of course things go wrong, and with arch that happens much less than i was expecting. still, if the above quote from one of arch's main developers reflected the distro's overall philosophy & working, i'd have to change my opinion about the project. (and while this is of no importance to 'the project,' it is to me.)

Only packages in the [core] repo are required to go through [testing] first.  Anything else can be moved straight to the main repos.

phanisvara wrote:
Allan wrote:

(BTW, this issue was not caught primarily due to it being a binary blob)

how's that? blob or not, this accident means that nobody tried to install the new skype on a 64bit system before pushing the upgrade. fair enough, but why not say so?

That would be one conclusion...   The other could be the the person who uploaded it had lib32-webkitqt (or whatever the needed package was) installed on their system and so everything worked.  But of course assuming no testing at all makes this a bigger issue than it is - downgrading to fix is simple.

Offline

#41 2012-11-15 06:24:11

phanisvara
Member
From: west bengal, india
Registered: 2012-07-08
Posts: 74

Re: [solved] skype 4.1 not running on 64bit

Allan wrote:

Only packages in the [core] repo are required to go through [testing] first.  Anything else can be moved straight to the main repos.

ah, thank you; i didn't know that.

Allan wrote:

But of course assuming no testing at all makes this a bigger issue than it is - downgrading to fix is simple.

yes, and i don't consider this is a big issue at all. the only issue i had was with the tone of your above reply, and what that would imply if taken literally. i prefer to think you didn't have your 'social graces' switch on for some reason, and that arch actually does try to keep the distro stable, even for leeches like me -- which seems to be substantiated by the way everything 'just works,' 99% of the time.

Offline

#42 2012-11-15 06:30:40

jasonwryan
Forum & Wiki Admin
From: .nz
Registered: 2009-05-09
Posts: 18,577
Website

Re: [solved] skype 4.1 not running on 64bit

Allan is greatly misunderstood. Many people assume his brusque demeanour is indicative of a hard and flinty heart that cares little about the woes of the good people on these boards; that is not the case. It is just that he is utterly exhausted, spent from pouring every ounce of his energy into doing as much as he can to push to production the automated refund gateway on the downloads page. I think he is pretty close now...

We all pray that he has the strength to finish this magnificently ambitious project.


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Online

#43 2012-11-15 06:55:25

phanisvara
Member
From: west bengal, india
Registered: 2012-07-08
Posts: 74

Re: [solved] skype 4.1 not running on 64bit

jasonwryan wrote:

Many people assume his brusque demeanour is indicative of a hard and flinty heart that cares little about the woes of the good people on these boards; that is not the case.

which is obvious from the fact that he hangs around here and bothers to reply to twerps like me...

...as much as he can to push to production the automated refund gateway on the downloads page.

grin; don't think i'll be needing this any time soon, but a good thing to have.

Offline

#44 2012-11-15 08:45:45

bluewind
Administrator
From: Austria
Registered: 2008-07-13
Posts: 165
Website

Re: [solved] skype 4.1 not running on 64bit

multilib has been fixed (lib32-qt now ships qtwebkit). Sorry for the mess guys. I'll try to fix my packaging process.


"Everything should be made as simple as possible, but not simpler."
-- Albert Einstein

Offline

#45 2012-11-15 09:06:11

post-factum
Member
From: /ukraine/kyiv
Registered: 2008-09-12
Posts: 82
Website

Re: [solved] skype 4.1 not running on 64bit

Thanks, it works.


Linux spock 4.4.0-pf1 #1 SMP PREEMPT Mon Jan 18 11:03:05 UTC 2016 x86_64 GNU/Linux

Offline

#46 2012-11-15 10:34:19

gturtle
Member
Registered: 2012-04-12
Posts: 23

Re: [solved] skype 4.1 not running on 64bit

Yes, it works now. Could be marked as 'Sovled'

Offline

#47 2012-11-15 11:03:17

capoeira
Member
From: Vila Velha - Brasil
Registered: 2010-05-25
Posts: 448

Re: [solved] skype 4.1 not running on 64bit

thanks a lot to the maintainer.

shit happens

Last edited by capoeira (2012-11-15 11:03:36)

Offline

#48 2012-11-15 11:04:55

iambig
Member
Registered: 2012-08-21
Posts: 24

Re: [solved] skype 4.1 not running on 64bit

for me skype doesnt' work.
i used aur for lib32-qtwebkit, when I installed a ton of package lib32, i couldn't install lib32-qtwebkit.
so i tried qtwebkit. but skype still doesn't work with the same error.

/usr/lib32/skype/skype: error while loading shared libraries: libQtWebKit.so.4: cannot open shared object file: No such file or directory

what do i miss?


Carthago delenda est

Offline

#49 2012-11-15 11:05:25

bluewind
Administrator
From: Austria
Registered: 2008-07-13
Posts: 165
Website

Re: [solved] skype 4.1 not running on 64bit

You need lib32-qt 4.8.3-2


"Everything should be made as simple as possible, but not simpler."
-- Albert Einstein

Offline

#50 2012-11-15 11:13:01

lybin
Member
From: Russia / Siberia
Registered: 2012-09-27
Posts: 16

Re: [solved] skype 4.1 not running on 64bit

Thanks

Offline

Board footer

Powered by FluxBB