You are not logged in.

#1 2012-11-14 20:31:41

BentB
Member
From: Birkerød, Denmark
Registered: 2007-01-17
Posts: 19
Website

[SOLVED] KDE won't automount USB and optical devices

After a recent update KDE stopped being willing to automount e.g. USB devices such as sticks, HDs, cameras, GPS etc.

My ArchLinux is updated today and is thus on kernel 3.6.6, My wife's ArchLinux, which is still on kernel 3.5.5, has no problems automounting, so it must be due to a recent change, but which?

When I insert e.g. a USB stick, I get the 'Available Devices' popup, but when I select 'Open with File Manager' I get the following message at the bottom of the popup: 'Could not mount the following device:  xxxxx' followed by 'An unspecified error has occurred.: Not Authorized'

I'm still on sysvinit but would like to switch to systemd, because I have the haunch that switching to systemd would cure the problem. So far my attempts to switch to systemd has failed (see my woes in this thread https://bbs.archlinux.org/viewtopic.php … 6#p1193076

I have tried to install 'udiskie' but that did not help.

I could give many more details but which? I'll supply any information required as we go.

Any help and/or pointer will be much appreciated.

Bent

Edit: URL to other thread added

Last edited by BentB (2012-11-15 09:21:34)

Offline

#2 2012-11-14 21:15:59

65kid
Member
From: Germany
Registered: 2011-01-26
Posts: 663

Re: [SOLVED] KDE won't automount USB and optical devices

Any help and/or pointer will be much appreciated.

Well, you could read the news on the front page regarding logind replacing ConsoleKit or use the search function to find the 9001 other threads discussing the same issue.

Offline

#3 2012-11-14 21:32:51

BentB
Member
From: Birkerød, Denmark
Registered: 2007-01-17
Posts: 19
Website

Re: [SOLVED] KDE won't automount USB and optical devices

65kid wrote:

Well, you could read the news on the front page regarding logind replacing ConsoleKit or use the search function to find the 9001 other threads discussing the same issue.

I have (of course) but I find myself in a circular situation apparently. 'logind' is a systemd thing and as you can see from the above thread I'm trying to switch to systemd but am having problems. So until that issue is solved I could use other suggestions...

Offline

#4 2012-11-15 09:20:48

BentB
Member
From: Birkerød, Denmark
Registered: 2007-01-17
Posts: 19
Website

Re: [SOLVED] KDE won't automount USB and optical devices

The problem simply went away when my problem about not being able to boot into systemd (see above) was solved.

Offline

Board footer

Powered by FluxBB