You are not logged in.

#1 2005-09-30 17:28:30

Moo-Crumpus
Member
From: Hessen / Germany
Registered: 2003-12-01
Posts: 1,444

(A7N8X-E) pure sata issues when reinstalling

I am lost to ubuntu.

It is not love.

My system suffered under a little fire, and now my motherboard and some other things are new. My aim was to create a pure sata machine:

- A7N8X-E Deluxe
- Plextor Sata DVD+-RW
- Sata disk

The setup cd - arch 0.7 - booted, and first I tried to load modules for the giga ethernet chip. I really was surprised  when arch told me there was no cdrom found. Erm ... I booted it from the cd, so what? There was no device node for a cdrom. I decided to give cd install without extra modules a try. Surprisingly this was a successor. Rebooting the system was surprising again: my machine did nothing.

I decided to add my scsi card, and add an scsi dvd. Tried again, installed from scsi dvd, rebooted - nothing.

I was depressed. My hardware was quite expensive. I threw an ubuntu installation cd in the machine, and was shocked. The thing installed proper, and rebooted into ubuntu.

Wassup? Might it be arch 0.7 can't handle sata cd's and boot sata only?


Frumpus addict
[mu'.krum.pus], [frum.pus]

Offline

#2 2005-10-04 16:47:57

Moo-Crumpus
Member
From: Hessen / Germany
Registered: 2003-12-01
Posts: 1,444

Re: (A7N8X-E) pure sata issues when reinstalling

Current vanilla kernels from http://www.kernel.org have the code for ATAPI support via SATA already included, but it's not enabled by default. The developers warn to activate it, the code is still in development. Furthermore, they are very angry about some distributions that have enabled the code.  The code is considered to be very unstable and still buggy, but I had no errors yet using it with an ubuntu live cd.

How to enter kernel-bug-land:

Fetch the kernel source, in includes/linux/libata.h you have to change

#undef ATA_ENABLE_ATAPI                /* define to enable ATAPI support */
#undef ATA_ENABLE_PATA         /* define to enable PATA support in some
                                 * low-level drivers */
#undef ATAPI_ENABLE_DMADIR     /* enables ATAPI DMADIR bridge support */

to

#define ATA_ENABLE_ATAPI                /* define to enable ATAPI support */
#define ATA_ENABLE_PATA         /* define to enable PATA support in some
                                 * low-level drivers */
#define ATAPI_ENABLE_DMADIR     /* enables ATAPI DMADIR bridge support */

Build and install the kernel.

Here is another helpfull hint I found in the www:

After rebooting into the new kernel, the optical drive should then be accessible via /dev/scd0 (or /dev/sr0) for reading and /dev/sg1 for writing.

If your system still uses /dev/hdc (i.e. the drive is not found in /proc/scsi/scsi) it's maybe because the IDE-detection routines at startup find the multi-burner before the libata subsystem tries to access it. You can disable the IDE-detection by passing "ide1=noprobe" as kernel parameter in your grub configuration.


Frumpus addict
[mu'.krum.pus], [frum.pus]

Offline

#3 2005-10-20 16:04:59

Moo-Crumpus
Member
From: Hessen / Germany
Registered: 2003-12-01
Posts: 1,444

Re: (A7N8X-E) pure sata issues when reinstalling

Works well so far ...


Frumpus addict
[mu'.krum.pus], [frum.pus]

Offline

Board footer

Powered by FluxBB