You are not logged in.

#1 2012-11-18 00:14:44

rzrscm
Member
Registered: 2012-11-17
Posts: 85

[SOLVED] Strange character issue...

I'm using Openbox, and sometimes (often) the text will mess up and start showing random characters in place of the characters that's supposed to be there.  I kill X and start it up again, and it's fixed until it happens again.  It usually happens after doing some package management and other system-related things, but a couple of times it's done it during a session where I didn't do any of those things.  This only happens in X/Openbox.

I figured it was a locale problem, so I checked all of my locale settings multiple times and everything appears correct.  Then I figured it was maybe a key mapping problem, so I checked that KEYMAP was set to us, and it is.

I have en_US.UTF-8 UTF-8 and ja_JP.UTF-8 UTF-8 enabled, and en_US.UTF-8 is my default...I use Terminus as my font for everything.  Any help with this is appreciated since I've spent two days trying to figure it out already and I just want to move on.

2012-11-17-174610_1920x1200_scrot.png

Here's an example...Sometimes there'll be huge characters and Japanese kanji thrown in there.

Last edited by rzrscm (2012-11-18 12:03:25)

Offline

#2 2012-11-18 01:03:23

sebikul
Member
Registered: 2011-05-25
Posts: 8

Re: [SOLVED] Strange character issue...

I'm having the same problem, but even weirder. I have a dual monitor setup, left monitor is fine, but if i drag a window, say a terminal, to the right monitor, it becomes almost unreadable. I use XFCE and the proprietary Nvidia blob. I can't really reproduce this bug, sometimes it happens, sometimes it doesn't.

Offline

#3 2012-11-18 01:12:17

rzrscm
Member
Registered: 2012-11-17
Posts: 85

Re: [SOLVED] Strange character issue...

sebikul wrote:

I'm having the same problem, but even weirder. I have a dual monitor setup, left monitor is fine, but if i drag a window, say a terminal, to the right monitor, it becomes almost unreadable. I use XFCE and the proprietary Nvidia blob. I can't really reproduce this bug, sometimes it happens, sometimes it doesn't.

I'm using the legacy proprietary Nvidia driver (nvidia-173xx)...I don't know if the video driver has anything to do with it for me since it's just a font character issue.

Offline

#4 2012-11-18 01:15:34

rzrscm
Member
Registered: 2012-11-17
Posts: 85

Re: [SOLVED] Strange character issue...

sebikul wrote:

I'm having the same problem, but even weirder. I have a dual monitor setup, left monitor is fine, but if i drag a window, say a terminal, to the right monitor, it becomes almost unreadable. I use XFCE and the proprietary Nvidia blob. I can't really reproduce this bug, sometimes it happens, sometimes it doesn't.

Do you have Option "RenderAccel" "1" under your Device section in your xorg.conf?  I think that MIGHT be the problem.

https://bugs.freedesktop.org/show_bug.cgi?id=1424

In any case, I'm going to comment it out and see what happens.

[update] Didn't work...Still having the same problem. [update 2] Uncommented it and set it to 0...Didn't have an issue until I made this edit, so the problem's still there, so that's definitely not the cause.
[update 3] Back to square one here...Same problem, no leads.

Last edited by rzrscm (2012-11-18 02:01:09)

Offline

#5 2012-11-18 02:53:22

rzrscm
Member
Registered: 2012-11-17
Posts: 85

Re: [SOLVED] Strange character issue...

Is it possible that this is being caused because I'm not using a display manager?  I didn't feel that I needed one.

Offline

#6 2012-11-18 09:11:06

fritz
Member
Registered: 2011-06-17
Posts: 38

Re: [SOLVED] Strange character issue...

rzrscm wrote:

Is it possible that this is being caused because I'm not using a display manager?

No. Xorg 1.13.04 does not work well with nvidia drivers.
This problem is dealt with in several topics:
https://bbs.archlinux.org/viewtopic.php?id=153138
https://bbs.archlinux.org/viewtopic.php?id=152899
https://bbs.archlinux.org/viewtopic.php?id=152837
Only "solution" so far: Downgrading xorg.
1.13.03 might be enough according to user corion's post).

Last edited by fritz (2012-11-18 09:25:28)


Celeron 1610, Intel B75, 4GB Ram, Intel HD-Graphics

Offline

#7 2012-11-18 10:44:13

rzrscm
Member
Registered: 2012-11-17
Posts: 85

Re: [SOLVED] Strange character issue...

fritz wrote:
rzrscm wrote:

Is it possible that this is being caused because I'm not using a display manager?

No. Xorg 1.13.04 does not work well with nvidia drivers.
This problem is dealt with in several topics:
https://bbs.archlinux.org/viewtopic.php?id=153138
https://bbs.archlinux.org/viewtopic.php?id=152899
https://bbs.archlinux.org/viewtopic.php?id=152837
Only "solution" so far: Downgrading xorg.
1.13.03 might be enough according to user corion's post).

Alright...Thanks for the info.  I guess I was completely wrong in how I was thinking of the problem.  So, am I able to just downgrade the xorg-server package to solve the issue, or am I going to have to downgrade other related packages such as xorg-server-common?

Offline

#8 2012-11-18 12:18:01

thisoldman
Member
From: Pittsburgh
Registered: 2009-04-25
Posts: 1,172

Re: [SOLVED] Strange character issue...

I switched to the nouveau driver, which solved the problem for me.  My on board graphics card was no longer supported with the latest nvidia package, and the nvidia-304xx driver showed the same font problem.  Rather than downgrade xorg, I tried the nouveau driver and the font problem disappeared.

There seems to be a slight difference, on my monitor, in color rendition compared to nvidia, but I'm OK with it.  I'm also not a gamer so I don't know how that might be affected.

Offline

#9 2012-11-18 13:39:44

bangkok_manouel
Member
From: indicates a starting point
Registered: 2005-02-07
Posts: 1,554

Re: [SOLVED] Strange character issue...

fritz wrote:
rzrscm wrote:

Is it possible that this is being caused because I'm not using a display manager?

No. Xorg 1.13.04 does not work well with nvidia drivers.
This problem is dealt with in several topics:
https://bbs.archlinux.org/viewtopic.php?id=153138
https://bbs.archlinux.org/viewtopic.php?id=152899
https://bbs.archlinux.org/viewtopic.php?id=152837
Only "solution" so far: Downgrading xorg.
1.13.03 might be enough according to user corion's post).

there are no such things as 1.13.0{3,4}


All design goals must be phrased in such a way that it is hard to use them as slogans to justify stupidity.

Offline

#10 2012-11-19 07:03:06

rzrscm
Member
Registered: 2012-11-17
Posts: 85

Re: [SOLVED] Strange character issue...

bangkok_manouel wrote:
fritz wrote:
rzrscm wrote:

Is it possible that this is being caused because I'm not using a display manager?

No. Xorg 1.13.04 does not work well with nvidia drivers.
This problem is dealt with in several topics:
https://bbs.archlinux.org/viewtopic.php?id=153138
https://bbs.archlinux.org/viewtopic.php?id=152899
https://bbs.archlinux.org/viewtopic.php?id=152837
Only "solution" so far: Downgrading xorg.
1.13.03 might be enough according to user corion's post).

there are no such things as 1.13.0{3,4}

They're xorg-server-1.13.0-(3,4)...Same difference.

Offline

#11 2012-11-20 17:20:34

ensarman
Member
Registered: 2012-11-20
Posts: 1

Re: [SOLVED] Strange character issue...

rzrscm wrote:

Do you have Option "RenderAccel" "1" under your Device section in your xorg.conf?  I think that MIGHT be the problem.


thanks it worked for me, I'm ussing KDE and kdm and I dont need to downgrade my xorg thanks

UPDATE: the solution is not effective, i have to downgrade my xorg sad

Last edited by ensarman (2012-11-21 00:00:55)

Offline

#12 2012-11-28 22:24:38

dunder
Member
Registered: 2012-11-28
Posts: 2

Re: [SOLVED] Strange character issue...

Try this:

Option "BackingStore" "True"

This worked for me using nvidia-304xx & newest xorg.

edit:
Just in case, my /etc/X11/xorg.conf.d/20-nvidia.conf looks like this:

Section "Device"
    Identifier "nvidia"
    Driver "nvidia"
    Option "NoLogo" "True"
    Option "RenderAccel" "True"
    Option "TripleBuffer" "True"
    Option "RegistryDwords" "PerfLevelSrc=0x3333"
    Option "OnDemandVBlankInterrupts" "True"
    Option "BackingStore" "True"
    Option "AddARGBGLXVisuals" "True"
EndSection

Last edited by dunder (2012-11-28 22:52:37)

Offline

#13 2012-12-02 16:09:51

dunder
Member
Registered: 2012-11-28
Posts: 2

Re: [SOLVED] Strange character issue...

Might also be related:

If dmesg shows something like this:

Nov 19 12:00:05 localhost kernel: [   22.105033] NVRM: Your system is not currently configured to drive a VGA console
Nov 19 12:00:05 localhost kernel: [   22.105041] NVRM: on the primary VGA device. The NVIDIA Linux graphics driver
Nov 19 12:00:05 localhost kernel: [   22.105046] NVRM: requires the use of a text-mode VGA console. Use of other console
Nov 19 12:00:05 localhost kernel: [   22.105051] NVRM: drivers including, but not limited to, vesafb, may result in
Nov 19 12:00:05 localhost kernel: [   22.105054] NVRM: corruption and stability problems, and is not supported.

add grub options (/boot/grub/grub.cfg):

video=vesa:off vga=normal

Offline

Board footer

Powered by FluxBB