You are not logged in.

#1 2012-11-14 06:23:05

Aghosh993
Member
Registered: 2012-09-24
Posts: 11

Packet loss / pausing when using 802.11N (Intel 6300)

Hi,

Previously, I had posted a thread involving the Intel 6250, and lack of detection of N WiFi on that card. Some time later, I bit the bullet and got an Intel 6300 card off eBay. After receiving it today, I popped it into my Thinkpad X220, and it worked.... sort of. I can definitely see wireless N support, and can associate with my 2.4 GHz mixed-mode B/G/N network at 130 Mbps, and my 5 GHz N-only router at around 243 - 270 Mbps. However, right off the bat, it seems the number of "Tx Excessive Retries" in iwconfig climb up to several thousand within ~ 15 - 20 minutes of connecting. Also right off the bat, pings are rather inconsistent (typically at least 2 ms greater than when the card is forced to work in G-only mode, and with pauses and spikes up to 800 - 2000 ms, and packet loss from 5 - 10%)

From what I have gathered so far, there has been a bug in the iwlwifi kernel tree that affects N wireless users, and this bug has been around since around 2010 or even earlier. However, I was under the impression that some sort of fix has been merged into the mainline Kernel at this point (I'm on 3.5.3-1-ARCH BTW), and my symptoms are somewhat less aggressive than the ones others described (basic web browsing works reasonably well, though there is often noticeable lag in the response times, but anything latency/packet loss-sensitive will suffer in a major way.) Has anyone managed to get wireless N to actually work reasonably well on Arch (or for that matter, ANY linux distro)? As I understand it, the matter is one of relation to the kernel module itself, so distro-distro variations of userspace apps shouldn't be as much a factor anyway. I am using WICD for my network manager, and am happy to say that it does its job admirably well (assuming the card is set to G-only mode, but the connection itself is actually maintained quite stably even in N mode.)

While I understand that the 11n_disable=1 "fix" allows most people to get on with their lives, I am rather alarmed that this is being considered a long-term solution. Many laptop owners (ThinkPad owners like myself for example) are essentially locked into Intel WiFi cards, unless we are willing to take an expensive risk and flash our BIOS to one that that doesn't have a "whitelist" of approved cards (something that can void the warranty or worse, brick a laptop.) All the while, Intel is still claiming Linux support for a card whose major capabilities are essentially neutered purely based on the OS a user chooses to run (yes, I do consider N to be a major capability, considering 300 Mbps N WiFi is basically old news, with many manufacturers coming out with full 450 Mbps routers. Also, chipsets like Atheros seem to have no problems with offering both performance and stability under Linux... my desktop rig using an Atheros card manages perfectly fine on a full-rate wireless-N network with essentially no packet loss or latency spikes.)

Below is some information that might be useful:

iwconfig (802.11g, ~ 1 hour after connection and running a few speedtests, browsing, ping testing):

wlan0     IEEE 802.11abg  ESSID:"dd-wrt"  
          Mode:Managed  Frequency:2.437 GHz  Access Point: XXXXXX
          Bit Rate=54 Mb/s   Tx-Power=15 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=69/70  Signal level=-41 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:359   Missed beacon:0

iwconfig (802.11n, 5GHz after ~10 minutes browsing/ping testing):

wlan0     IEEE 802.11abgn  ESSID:"net2"  
          Mode:Managed  Frequency:5.745 GHz  Access Point: XXXXXX
          Bit Rate=243 Mb/s   Tx-Power=15 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=55/70  Signal level=-55 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:860  Invalid misc:50   Missed beacon:0

iwconfig (802.11n, 2.4 GHz after connecting and running a speedtest):

wlan0     IEEE 802.11abgn  ESSID:"dd-wrt"  
          Mode:Managed  Frequency:2.437 GHz  Access Point: XXXXXX   
          Bit Rate=117 Mb/s   Tx-Power=15 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=66/70  Signal level=-44 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:974  Invalid misc:59   Missed beacon:0

dmesg | grep iwl :

[12011.488089] iwlwifi: Intel(R) Wireless WiFi Link AGN driver for Linux, in-tree:
[12011.488092] iwlwifi: Copyright(c) 2003-2012 Intel Corporation
[12011.488269] iwlwifi 0000:03:00.0: pci_resource_len = 0x00002000
[12011.488271] iwlwifi 0000:03:00.0: pci_resource_base = ffffc900050f8000
[12011.488273] iwlwifi 0000:03:00.0: HW Revision ID = 0x35
[12011.488585] iwlwifi 0000:03:00.0: irq 50 for MSI/MSI-X
[12011.491862] iwlwifi 0000:03:00.0: loaded firmware version 9.221.4.1 build 25532
[12011.492112] iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEBUG disabled
[12011.492114] iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEBUGFS disabled
[12011.492116] iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEVICE_TRACING enabled
[12011.492117] iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEVICE_TESTMODE enabled
[12011.492119] iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_P2P disabled
[12011.492121] iwlwifi 0000:03:00.0: Detected Intel(R) Centrino(R) Ultimate-N 6300 AGN, REV=0x74
[12011.492206] iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S
[12011.502925] iwlwifi 0000:03:00.0: device EEPROM VER=0x436, CALIB=0x6
[12011.502928] iwlwifi 0000:03:00.0: Device SKU: 0x1F0
[12011.502930] iwlwifi 0000:03:00.0: Valid Tx ant: 0x7, Valid Rx ant: 0x7
[12011.502946] iwlwifi 0000:03:00.0: Tunable channels: 13 802.11bg, 24 802.11a channels
[12011.503105] ieee80211 phy8: Selected rate control algorithm 'iwl-agn-rs'
[12011.503456] iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S
[12011.503661] iwlwifi 0000:03:00.0: Radio type=0x0-0x3-0x1
[12011.745631] iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S
[12011.745868] iwlwifi 0000:03:00.0: Radio type=0x0-0x3-0x1
[12073.651471] iwlwifi: Intel(R) Wireless WiFi Link AGN driver for Linux, in-tree:
[12073.651474] iwlwifi: Copyright(c) 2003-2012 Intel Corporation
[12073.651660] iwlwifi 0000:03:00.0: pci_resource_len = 0x00002000
[12073.651661] iwlwifi 0000:03:00.0: pci_resource_base = ffffc900050b8000
[12073.651663] iwlwifi 0000:03:00.0: HW Revision ID = 0x35
[12073.652241] iwlwifi 0000:03:00.0: irq 50 for MSI/MSI-X
[12073.655662] iwlwifi 0000:03:00.0: loaded firmware version 9.221.4.1 build 25532
[12073.655887] iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEBUG disabled
[12073.655890] iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEBUGFS disabled
[12073.655891] iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEVICE_TRACING enabled
[12073.655891] iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEVICE_TESTMODE enabled
[12073.655892] iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_P2P disabled
[12073.655894] iwlwifi 0000:03:00.0: Detected Intel(R) Centrino(R) Ultimate-N 6300 AGN, REV=0x74
[12073.655975] iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S
[12073.666587] iwlwifi 0000:03:00.0: device EEPROM VER=0x436, CALIB=0x6
[12073.666593] iwlwifi 0000:03:00.0: Device SKU: 0x1F0
[12073.666595] iwlwifi 0000:03:00.0: Valid Tx ant: 0x7, Valid Rx ant: 0x7
[12073.666618] iwlwifi 0000:03:00.0: Tunable channels: 13 802.11bg, 24 802.11a channels
[12073.667056] ieee80211 phy9: Selected rate control algorithm 'iwl-agn-rs'
[12073.667456] iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S
[12073.667659] iwlwifi 0000:03:00.0: Radio type=0x0-0x3-0x1
[12073.908411] iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S
[12073.908632] iwlwifi 0000:03:00.0: Radio type=0x0-0x3-0x1
[12087.261869] iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S
[12087.262090] iwlwifi 0000:03:00.0: Radio type=0x0-0x3-0x1
[12087.487757] iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S
[12087.488010] iwlwifi 0000:03:00.0: Radio type=0x0-0x3-0x1
[12087.699574] iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S
[12087.699781] iwlwifi 0000:03:00.0: Radio type=0x0-0x3-0x1
[12087.837322] iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S
[12087.837526] iwlwifi 0000:03:00.0: Radio type=0x0-0x3-0x1
[12097.329577] iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S
[12097.329832] iwlwifi 0000:03:00.0: Radio type=0x0-0x3-0x1
[12097.797748] iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S
[12097.797970] iwlwifi 0000:03:00.0: Radio type=0x0-0x3-0x1
[12098.016220] iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S
[12098.016458] iwlwifi 0000:03:00.0: Radio type=0x0-0x3-0x1
[12100.458762] iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S
[12100.459006] iwlwifi 0000:03:00.0: Radio type=0x0-0x3-0x1
[12100.608769] iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S
[12100.609021] iwlwifi 0000:03:00.0: Radio type=0x0-0x3-0x1
[12100.764093] iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S
[12100.764341] iwlwifi 0000:03:00.0: Radio type=0x0-0x3-0x1
[12100.979029] iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S
[12100.979228] iwlwifi 0000:03:00.0: Radio type=0x0-0x3-0x1
[12101.159987] iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S
[12101.160208] iwlwifi 0000:03:00.0: Radio type=0x0-0x3-0x1

lshw | less :

           *-network
                description: Wireless interface
                product: Centrino Ultimate-N 6300
                vendor: Intel Corporation
                physical id: 0
                bus info: pci@0000:03:00.0
                logical name: wlan0
                version: 35
                serial: 00:24:d7:be:9e:74
                width: 64 bits
                clock: 33MHz
                capabilities: pm msi pciexpress bus_master cap_list ethernet phy
sical wireless
                configuration: broadcast=yes driver=iwlwifi driverversion=3.5.3-
1-ARCH firmware=9.221.4.1 build 25532 ip=192.168.1.145 latency=0 link=yes multic
ast=yes wireless=IEEE 802.11abgn
                resources: irq:50 memory:f2500000-f2501fff

Thanks,
- A.G.

Offline

#2 2012-11-14 18:14:44

Aghosh993
Member
Registered: 2012-09-24
Posts: 11

Re: Packet loss / pausing when using 802.11N (Intel 6300)

Upon further investigation, it appears that a better fix is to pass 11n_disable=2 to the kernel module iwlwifi. Based on the output of modinfo iwlwifi, this value only turns on aggregation for the TX data path, while a value of 1 would start full aggregation. This makes me suspect some sort of driver/firmware bug in the receive channel aggregation code. Either way, using wireless N now is reasonably stable (pings are still about 2 ms higher and can vary up to 10 - 20 ms, but I can live with that for the time being.) I will probably later test this fix with my college's campus WiFi, as that will actually stress-test the card due to the higher potential bandwidth on campus.

- A.G.

Offline

#3 2012-11-18 15:28:01

orschiro
Member
Registered: 2009-06-04
Posts: 2,136
Website

Re: Packet loss / pausing when using 802.11N (Intel 6300)

Thanks for your analysis Aghosh.

I am experiencing the same issues with my Intel 5300 card on a ThinkPad X200T but only when I am connected to an enterprise WPA2 network. When doing a google search, most fellows recommend to use 11n_disable=1 option. However, 11n_disable=2 works much more faster except for total connectivity aborts from time to time.

Do you experience the same?

Offline

#4 2012-11-18 18:54:15

estan
Member
Registered: 2011-03-11
Posts: 13

Re: Packet loss / pausing when using 802.11N (Intel 6300)

I have the same problem with my Intel Corporation Centrino Advanced-N 6205 in an ThinkPad X220.

It's very annoying since I just got a new router with 802.11n, hoping to get some more speed.

I've tried both 11n_disable=1 and 11n_disable=2. The excessive TX retries seems to go down with both, but the invalid misc count is still high and the connection is still flaky/slow sad

I've subscribed to some of the bugs at intel's bugzilla about this and hope they can come up with a fix soon.

I don't run any power management on the card btw, and the router I have is running in mixed mode.

Offline

#5 2012-11-19 00:28:48

Aghosh993
Member
Registered: 2012-09-24
Posts: 11

Re: Packet loss / pausing when using 802.11N (Intel 6300)

The 11n_disable=1 option should force wireless-G, which ought to work towards at least a stable connection. If that's not happening for you, check your antennas and try changing channels on your router (maybe try doing a site survey for offending networks). Also, try 11n_disable=4, as it disables channel aggregation on the return path IIRC. Also, are your problems occurring on the 5 GHz or 2.4 GHz band (or have you tried both?) As for myself, I have settled for 11n_disable=2, which keeps the Tx retries in check (but far from the 0 I'm used to on 802.11g.) However, pings and packet loss are somewhat stable on that setting. Using 11n_disable=0 enables full channel aggregation which I can notice on speedtests I did at my college campus, when I pulled 54 Mbit/s down and nearly 60 Mbps up during off-peak hours. On another part of the campus, I was able to get even better speeds... around 91 Mbps down and 72 Mbps up. However, the Tx retries went into the 400,000 range at that point, though the connection "felt" OK.

Offline

#6 2012-11-19 00:32:24

Aghosh993
Member
Registered: 2012-09-24
Posts: 11

Re: Packet loss / pausing when using 802.11N (Intel 6300)

orchiro: Anything besides 11n_disable=1 causes instabilities from time to time, but it's really hard to document. I have had 1 or 2 kernel panics since installing this card, and both have occurred when I ventured to test the card with the 11n_disable=2 and 4 options, so there's definitely something wrong with the interaction between driver and microcode (timing issue? a badly-handled malloc, or memory leak? *shrug*) If stability is of importance, I would definitely recommend sticking with 11n_disable=1 for the time being, and keep badgering Intel to actually deliver on their claims for the Linux platform, as the situation right now is simply unacceptable.... neutering about half my card's abilities is NOT an answer when I'm paying the money for a "premium" product.

Offline

#7 2012-11-19 00:35:37

Aghosh993
Member
Registered: 2012-09-24
Posts: 11

Re: Packet loss / pausing when using 802.11N (Intel 6300)

By the way, for those of you who are poking around the module options, doing a "modinfo iwlwifi" lets you know more about the various driver arguments before messing around with settings that could potentially cause damage to your setup

Offline

#8 2012-11-19 05:10:58

dikei
Member
Registered: 2010-12-08
Posts: 10

Re: Packet loss / pausing when using 802.11N (Intel 6300)

I've have been having the same problem for over a year now with my Intel 6200 cards.
Download speed is OK but sometime I just can't visit any webpages.
11n_disable=1 & 11n_disable=2 reduce the Tx excessive retries but connection remain unstable so I don't use it anymore

Offline

#9 2013-02-17 01:30:27

Tuxdude
Member
Registered: 2013-02-17
Posts: 2

Re: Packet loss / pausing when using 802.11N (Intel 6300)

I have an ASUS UX32VD-DB71 which has the Intel Centrino 6235 wifi card. I've been having this laptop for more than 6 months and I've tried different solutions to fix the issue with Wireless-N but none of them were stable other than disabling N completely using 11n_disable=1

I've tried different kernels all the way from 3.2 to the latest 3.7 series of kernels (both in the openSUSE tree as well as mainline) with no luck whasoever. I also tried installing the compat-drivers from 2013-01-23-1-u version onto my 3.6 kernel which provided the same results too. I see packet loss with N and the G speeds are just too slow. I have a workstation in my network and I can only transfer effectively at 1.5 MB /s max over G whereas an old laptop from 2007 which has an 1x1 MIMO antenna (again Intel though) can connect at 144 Mbps to my router and transfer files at least 3-4 times faster (if not more).

It is totally unacceptable for Intel to not just fix this issue for Linux.

Last edited by Tuxdude (2013-02-17 01:38:59)

Offline

#10 2013-02-17 04:24:53

Tuxdude
Member
Registered: 2013-02-17
Posts: 2

Re: Packet loss / pausing when using 802.11N (Intel 6300)

UPDATE:

I just switched my router to do 5 Ghz 802.11n instead of 2.4 GHz and the performance seems much much better, which I'm attributing to lesser interference with neighboring wireless networks (I live in an apartment complex). I also did a flood ping test to verify packet loss over 2 wireless hops in the same network and I got 0% packet loss. smile With 2.4 GHz the packet loss was not very significant, but was not 0 either.

But agreed this is not a solution as other devices (even 5+ years older) seem to be able to handling this without any significant drop in speeds.

Offline

Board footer

Powered by FluxBB