You are not logged in.

#1 2012-11-13 02:06:25

AxGS
Member
From: Mexico
Registered: 2011-11-06
Posts: 12
Website

Problem with font rendering: Random characters or font styles.

Here the screenshot

Can someone help me please? I don't know how the problem started, but I think that my fonts have the problem or my bashrc file:

Fonts:

$ yaourt -Qm | grep ttf
local/ttf-adobe-fonts 10.1.2-1
local/ttf-aefonts 20071109-1
local/ttf-anonymous-pro 1.002-1
local/ttf-castlequeen 0-1
local/ttf-chromeos-fonts 1.21.0-1
local/ttf-exljbris 1.1-3
local/ttf-funfonts 2-1
local/ttf-mac-fonts 1-5
local/ttf-ms-fonts 2.0-9
local/ttf-openlogos 0.806-3
local/ttf-pizzadude-bullets 2.0-2
local/ttf-roboto 20121102-1
local/ttf-sil-fonts 6-1

BashRC:

#
# ~/.bashrc
#

# If not running interactively, don't do anything
[[ $- != *i* ]] && return

# Configuraciones personales
PS1='\e[0;34m[ \u: \W ]\e[m\e[1;94m\$ \e[m'
PACMAN="pacman-color"

alias ls='ls -BFhX --color=auto'
alias syu='sudo $PACMAN -Syu'
alias syua='yaourt -Syua'
alias grep='grep --color=auto'

# Aplicaciones
command cowsay -f tux  $(fortune)

Im not so good in English tongue

Thanks.


Amateur game developer, who needs help with pixel art or a team for make games as a hobby.

Offline

#2 2012-11-13 04:05:53

fritz
Member
Registered: 2011-06-17
Posts: 38

Re: Problem with font rendering: Random characters or font styles.

AxGS wrote:

Here the screenshot
I don't know how the problem started, but I think that my fonts have the problem or my bashrc file:

I don't know what exactly the problem is, either, but downgrading xorg to 1.12 solved it for me so far.


Celeron 1610, Intel B75, 4GB Ram, Intel HD-Graphics

Offline

#3 2012-11-13 06:25:01

AxGS
Member
From: Mexico
Registered: 2011-11-06
Posts: 12
Website

Re: Problem with font rendering: Random characters or font styles.

fritz wrote:

I don't know what exactly the problem is, either, but downgrading xorg to 1.12 solved it for me so far.

Thank you very much fritz, I downgraded the xorg-server package and the problem is gone, thank you. wink


Amateur game developer, who needs help with pixel art or a team for make games as a hobby.

Offline

#4 2012-11-13 06:42:03

fritz
Member
Registered: 2011-06-17
Posts: 38

Re: Problem with font rendering: Random characters or font styles.

AxGS wrote:

I downgraded the xorg-server package and the problem is gone

Glad to hear it was useful for you.
I was wondering if I was the only one having this problem.
Hopefully someone will come up with a better solution. I had no time so far to have a deeper look into it.


Celeron 1610, Intel B75, 4GB Ram, Intel HD-Graphics

Offline

#5 2012-11-13 08:33:16

ToJa92
Member
From: ~
Registered: 2012-08-31
Posts: 9
Website

Re: Problem with font rendering: Random characters or font styles.

I've got the same issue, luckily it only happens in Firefox. Or rather, it only seem to happen in programs using TTF fonts, as both RXVT-unicode and Emacs seem unaffected.
Unfortunately I'm missing Xorg-server from my package cache so I'm hoping this issue is resolved soon.

Here's what it looks like for me, sometimes the issue disappear when I press Ctrl+A: http://i.imgur.com/v5Wiv.png

Offline

#6 2012-11-13 09:03:29

bernarcher
Forum Fellow
From: Germany
Registered: 2009-02-17
Posts: 2,271

Re: Problem with font rendering: Random characters or font styles.

I experienced a similar problem yesterday. But it has been gone after a reboot.


To know or not to know ...
... the questions remain forever.

Offline

#7 2012-11-13 10:42:49

cviorel
Member
Registered: 2010-11-26
Posts: 13

Re: Problem with font rendering: Random characters or font styles.

8181745074_e26b589a71_n.jpg
screenshot-20121113123531

8181745084_1d08b2df69_n.jpg
screenshot-20121113095129

After reboot the issue is gone but reappears after a little while.
I also rebuilt my font cache, no luck with that either.

Offline

#8 2012-11-13 12:18:49

corion
Member
Registered: 2008-09-13
Posts: 36
Website

Re: Problem with font rendering: Random characters or font styles.

ToJa92 wrote:

I've got the same issue, luckily it only happens in Firefox. Or rather, it only seem to happen in programs using TTF fonts, as both RXVT-unicode and Emacs seem unaffected.
Unfortunately I'm missing Xorg-server from my package cache so I'm hoping this issue is resolved soon.

Here's what it looks like for me, sometimes the issue disappear when I press Ctrl+A: http://i.imgur.com/v5Wiv.png

You can find the old packages from ARM.

BTW: I have the same issues with the fonts, and downgrading to xorg-server-1.13.0-3 was enough.

Last edited by corion (2012-11-13 12:19:14)

Offline

#9 2012-11-13 14:11:14

ToJa92
Member
From: ~
Registered: 2012-08-31
Posts: 9
Website

Re: Problem with font rendering: Random characters or font styles.

corion wrote:
ToJa92 wrote:

I've got the same issue, luckily it only happens in Firefox. Or rather, it only seem to happen in programs using TTF fonts, as both RXVT-unicode and Emacs seem unaffected.
Unfortunately I'm missing Xorg-server from my package cache so I'm hoping this issue is resolved soon.

Here's what it looks like for me, sometimes the issue disappear when I press Ctrl+A: http://i.imgur.com/v5Wiv.png

You can find the old packages from ARM.

BTW: I have the same issues with the fonts, and downgrading to xorg-server-1.13.0-3 was enough.

Yeah, I read the "Downgrade packages" Wiki page(like I should have done in the first place), installed downgrade from AUR and downgraded xorg-server. The version 1.13.0-3 works perfectly fine as you point out.

Offline

#10 2012-11-13 14:33:40

niski
Member
Registered: 2012-09-09
Posts: 8

Re: Problem with font rendering: Random characters or font styles.

ToJa92 wrote:

I've got the same issue, luckily it only happens in Firefox. Or rather, it only seem to happen in programs using TTF fonts, as both RXVT-unicode and Emacs seem unaffected.
Unfortunately I'm missing Xorg-server from my package cache so I'm hoping this issue is resolved soon.

Here's what it looks like for me, sometimes the issue disappear when I press Ctrl+A: http://i.imgur.com/v5Wiv.png

I've tried Opera and it showed everything properly. On the other hand, Thunderbird is affected as well.

Offline

#11 2012-11-13 19:49:38

AxGS
Member
From: Mexico
Registered: 2011-11-06
Posts: 12
Website

Re: Problem with font rendering: Random characters or font styles.

I think the problem is this patch:

upgpkg: xorg-server 1.13.0-4
Update to current git snapshot from server-1.13 branch, backport patch from git master to utilize the new pixman glyph cache
git-svn-id: file:///srv/svn-packages@170560 eb2447ed-0c53-47e4-bac8-5bc4a241df78


Amateur game developer, who needs help with pixel art or a team for make games as a hobby.

Offline

#12 2012-11-14 04:06:46

dolby
Member
From: 1992
Registered: 2006-08-08
Posts: 1,581

Re: Problem with font rendering: Random characters or font styles.

Are you guys and girls using nvidia's crappy blob?
See https://bugs.archlinux.org/task/32612


There shouldn't be any reason to learn more editor types than emacs or vi -- mg (1)
[You learn that sarcasm does not often work well in international forums.  That is why we avoid it. -- ewaller (arch linux forum moderator)

Offline

#13 2012-11-14 04:15:46

AxGS
Member
From: Mexico
Registered: 2011-11-06
Posts: 12
Website

Re: Problem with font rendering: Random characters or font styles.

dolby wrote:

Are you guys and girls using nvidia's crappy blob?
See https://bugs.archlinux.org/task/32612

Thank you, waiting for a package update wink


Amateur game developer, who needs help with pixel art or a team for make games as a hobby.

Offline

#14 2012-11-14 07:29:12

abutanaev
Member
From: Russia, Novosibirsk
Registered: 2011-03-29
Posts: 27

Re: Problem with font rendering: Random characters or font styles.

Yes, I use nvidia driver.

Offline

#15 2012-11-14 11:30:04

Schumbi
Member
Registered: 2009-04-12
Posts: 3

Re: Problem with font rendering: Random characters or font styles.

Hey,

unfortunately this problem hits me, too. Firefox and most of the programs using gtk are more or less unreadable. But programs using qt are fine. Like arora or the qtcreator. I'm not sure, if the posted bug https://bugs.archlinux.org/task/32612 causes this behaviour.
But I'm not an expert.

System:

$>uname -a
Linux rw184 3.6.6-1-ARCH #1 SMP PREEMPT Mon Nov 5 11:57:22 CET 2012 x86_64 GNU/Linux

$>lspci | grep VGA
00:12.0 VGA compatible controller: NVIDIA Corporation C68 [GeForce 7050 PV / nForce 630a] (rev a2)

$>pacman -Qi nvidia | head -n2
Name           : nvidia
Version              : 304.64-1

$>pacman -Qi xorg-server | head -n2
Name           : xorg-server
Version              : 1.13.0-4

Offline

#16 2012-11-14 12:30:14

kokoko3k
Member
Registered: 2008-11-14
Posts: 1,440

Re: Problem with font rendering: Random characters or font styles.

I've no issues with nvidia-beta-all (310.14)

Offline

#17 2012-11-18 12:21:12

Raynman
Member
Registered: 2011-10-22
Posts: 1,074

Re: Problem with font rendering: Random characters or font styles.

kokoko3k wrote:

I've no issues with nvidia-beta-all (310.14)

310.19 is in extra now, does that (appear to) solve the problem for others? (Apparently I'm stuck with 304xx for my 7600GT.)

Offline

#18 2012-11-18 17:13:10

ajaxas
Member
Registered: 2009-02-23
Posts: 65
Website

Re: Problem with font rendering: Random characters or font styles.

Yes, 310.19 solves the problem.
Although while using it, I'm stuck with another headache, so it's a tie smile

@abutanaev
Poke.

Last edited by ajaxas (2012-11-18 17:15:56)

Offline

#19 2012-11-19 02:14:16

abutanaev
Member
From: Russia, Novosibirsk
Registered: 2011-03-29
Posts: 27

Re: Problem with font rendering: Random characters or font styles.

310.19 stopped to support my card: https://bbs.archlinux.org/viewtopic.php?id=153247

Offline

#20 2012-11-19 04:13:20

abutanaev
Member
From: Russia, Novosibirsk
Registered: 2011-03-29
Posts: 27

Re: Problem with font rendering: Random characters or font styles.

What I did, I found than I have internal video adapter which is ATI. So I installed xf86-video-ati driver and re-plugged monitor into that adapter. And it now works.

Offline

#21 2012-11-19 12:13:04

jarav
Member
Registered: 2008-09-04
Posts: 63

Re: Problem with font rendering: Random characters or font styles.

AxGS wrote:

I think the problem is this patch:

upgpkg: xorg-server 1.13.0-4
Update to current git snapshot from server-1.13 branch, backport patch from git master to utilize the new pixman glyph cache
git-svn-id: file:///srv/svn-packages@170560 eb2447ed-0c53-47e4-bac8-5bc4a241df78

Confirmed for me too. Downgrading to xorg-server-1.13.0-3 removed the font problems. Bug report here: https://bugs.archlinux.org/task/32612

Offline

#22 2012-11-21 10:37:04

ToJa92
Member
From: ~
Registered: 2012-08-31
Posts: 9
Website

Re: Problem with font rendering: Random characters or font styles.

abutanaev wrote:

310.19 stopped to support my card: https://bbs.archlinux.org/viewtopic.php?id=153247

Same situation for me as well. No possibility of upgrading either(the computers belong to the Uni). Perhaps Nouveau works better with the new X, though last time I tried I just got random graphical artifacts.

Offline

#23 2012-11-21 11:14:18

thisoldman
Member
From: Pittsburgh
Registered: 2009-04-25
Posts: 1,172

Re: Problem with font rendering: Random characters or font styles.

ToJa92 wrote:
abutanaev wrote:

310.19 stopped to support my card: https://bbs.archlinux.org/viewtopic.php?id=153247

Same situation for me as well. No possibility of upgrading either(the computers belong to the Uni). Perhaps Nouveau works better with the new X, though last time I tried I just got random graphical artifacts.

I switched to the nouveau driver for my desktop PC after 310.19 dropped support.  I still had artifacts with nvidia-304xx.  The on-board video of the desktop is a GeForce 6150SE.

The nouveau driver stopped the artifact generation with the latest Xorg.  There's a slight change in overall brightness or something – a difference in the colors that I notice when compared to the nvidia driver.  I haven't bothered to sort it out yet because it's merely an annoyance, not a problem.  I'm not a gamer so I wouldn't know if there's any problem with games.

Offline

#24 2012-11-21 11:24:33

ToJa92
Member
From: ~
Registered: 2012-08-31
Posts: 9
Website

Re: Problem with font rendering: Random characters or font styles.

thisoldman wrote:
ToJa92 wrote:
abutanaev wrote:

310.19 stopped to support my card: https://bbs.archlinux.org/viewtopic.php?id=153247

Same situation for me as well. No possibility of upgrading either(the computers belong to the Uni). Perhaps Nouveau works better with the new X, though last time I tried I just got random graphical artifacts.

I switched to the nouveau driver for my desktop PC after 310.19 dropped support.  I still had artifacts with nvidia-304xx.  The on-board video of the desktop is a GeForce 6150SE.

The nouveau driver stopped the artifact generation with the latest Xorg.  There's a slight change in overall brightness or something – a difference in the colors that I notice when compared to the nvidia driver.  I haven't bothered to sort it out yet because it's merely an annoyance, not a problem.  I'm not a gamer so I wouldn't know if there's any problem with games.

I've got the 6150LE - had to add "nouveau.noaccel=1" to the kernel parameters to fix the corruption. I'm gonna try upgrading xorg-server now and see if I can enable acceleration.

EDIT: No dice. Without "nouveau.noaccel=1" I now at least saw part of the console with about half the top showing graphical corruption. Last thing printed is "Rebooting system...". With "nouveau.noaccel=1" it works, but text in SLiM and Emacs is the same color as the background color (or something along those lines). urxvt and Firefox still works.

EDIT2: Actually, it looks like the text is extremely tinted or something. I tried screenshotting but in the screenshot the text actually shows up.

Last edited by ToJa92 (2012-11-21 11:40:55)

Offline

#25 2012-11-22 12:23:42

falmp
Member
Registered: 2011-11-18
Posts: 25

Re: Problem with font rendering: Random characters or font styles.

Do you think they will ever find a way out to get nvidia-304xx and xorg-server working together?

Offline

Board footer

Powered by FluxBB