You are not logged in.

#1 2012-11-19 13:56:56

ds2369
Member
Registered: 2011-08-21
Posts: 13

[SOLVED] Problem installing Calibre (conflicting files?)

Hi there, I'm up to date but am unable to install calibre. Spits out:

 $ yaourt -S calibre
resolving dependencies...
looking for inter-conflicts...

Targets (21): chmlib-0.40-3  imagemagick-6.8.0.3-1  liblqr-0.4.1-3  libmtp-1.1.5-1  libunrar-4.2.4-1  podofo-0.9.1-3  poppler-0.20.5-1  poppler-data-0.4.5-1 poppler-qt-0.20.5-1  python2-beautifulsoup3-3.2.1-1  python2-cherrypy-3.2.2-2  python2-cssselect-0.7.1-2  python2-cssutils-0.9.9-3 python2-dateutil-1.5-2  python2-dnspython-1.10.0-1  python2-imaging-1.1.7-5  python2-lxml-3.0.1-1  python2-mechanize-0.2.5-3  python2-netifaces-0.8-1 python2-psutil-0.6.1-2  calibre-0.9.6-2

Total Installed Size:   89.86 MiB

Proceed with installation? [Y/n] y
(21/21) checking package integrity                                                                   [############################################################] 100%
(21/21) loading package files                                                                        [############################################################] 100%
(21/21) checking for file conflicts                                                                  [############################################################] 100%
error: failed to commit transaction (conflicting files)
poppler: /usr/bin/pdfdetach exists in filesystem
poppler: /usr/share/man/man1/pdfdetach.1.gz exists in filesystem
Errors occurred, no packages were upgraded.

What could it be conflicting with?
Thanks.

Last edited by ds2369 (2012-11-19 15:17:34)

Offline

#2 2012-11-19 13:58:42

damdim
Member
Registered: 2010-03-13
Posts: 42

Re: [SOLVED] Problem installing Calibre (conflicting files?)

pacman -Qo /usr/bin/pdfdetach

It will show you the offending package, if any.

Offline

#3 2012-11-19 14:10:59

bernarcher
Forum Fellow
From: Germany
Registered: 2009-02-17
Posts: 2,280

Re: [SOLVED] Problem installing Calibre (conflicting files?)

Those files belong to poppler only as pkgfile tells:

$ pkgfile pdfdetach
extra/poppler

Hence it should be safe to simply rename (instead of simple deletion, just to be sure) them to some pdfdetach.old or so and then try the upgrade again.


To know or not to know ...
... the questions remain forever.

Online

#4 2012-11-19 14:26:38

ds2369
Member
Registered: 2011-08-21
Posts: 13

Re: [SOLVED] Problem installing Calibre (conflicting files?)

damdim wrote:

pacman -Qo /usr/bin/pdfdetach

It will show you the offending package, if any.

Seems like the culprit is xpdf-nodrm, thanks.

Offline

#5 2012-11-19 23:48:19

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 6,068

Re: [SOLVED] Problem installing Calibre (conflicting files?)

Is your system up to date? I ask because I have Calibre (and poppler) installed and haven't needed to rename anything as the result of conflicts...


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | refind | stub loader | systemd | LVM2 on LUKS
Lenovo x270 | Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz | Intel Corporation Wireless 8265 / 8275 | US keyboard with Euro | 512G NVMe INTEL SSDPEKKF512G7L

Offline

#6 2012-11-20 00:35:25

Trilby
Forum Fellow
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 17,609
Website

Re: [SOLVED] Problem installing Calibre (conflicting files?)

xpdf-nodrm is an AUR package.  I just confirmed this does conflict with poppler.  This should be reported to the maintainer of the AUR package.  Xpdf should not provide that file ... xpdf does not, so xpdf-nodrm should not either.


Resist the GNU world order.

Offline

Board footer

Powered by FluxBB