You are not logged in.

#1 2012-11-18 21:55:17

ninjaprawn
Member
From: Manchester, UK
Registered: 2008-01-26
Posts: 455

[solved]gui is wrong on transmission and deadbeef only..... hmmmm

Hi.... for some reason, since the systemd upgrade, transmission-gtk, deadbeef and nm-applet dont display correctly.... they look ok, but the colours are not as the gtk theme should be.... for example, the gtk theme is making pcmanfm have file, edit, view, etc have black background with white writing, but in transmission-gtk, deadbeef and nm-applet, file, edit, view et have dark grey writing, with a lighter grey background, then an additional background of lighter grey.

any ideas? it just looks messy!

Last edited by ninjaprawn (2012-11-19 22:04:21)


- Samsung Series 3, Intel(R) Core(TM) i5-3210M CPU @ 2.50GHz - 6Gb DDR3 ram - 700Gb HDD
On board intel Graphics & Sound

Offline

#2 2012-11-19 04:28:18

dolby
Member
From: 1992
Registered: 2006-08-08
Posts: 1,581

Re: [solved]gui is wrong on transmission and deadbeef only..... hmmmm

Lets not blame systemd for everything, shall we?
Your theme is busted. All those applications are gtk+3 ones.


There shouldn't be any reason to learn more editor types than emacs or vi -- mg (1)
[You learn that sarcasm does not often work well in international forums.  That is why we avoid it. -- ewaller (arch linux forum moderator)

Offline

#3 2012-11-19 17:07:43

ninjaprawn
Member
From: Manchester, UK
Registered: 2008-01-26
Posts: 455

Re: [solved]gui is wrong on transmission and deadbeef only..... hmmmm

No, I know, but its all just coincidental..... in all fairness, i like systemd so far.... just a few issues, which can be expected for such a major change...... any tips on how to fix the theme? I thought that was the issue, so downloaded some fresh new themes and installed them, and they were all the same. GTK themes work perfectly in everything else.... its just those 3 programs.


- Samsung Series 3, Intel(R) Core(TM) i5-3210M CPU @ 2.50GHz - 6Gb DDR3 ram - 700Gb HDD
On board intel Graphics & Sound

Offline

#4 2012-11-19 17:59:42

anonymous_user
Member
Registered: 2009-08-28
Posts: 3,058

Re: [solved]gui is wrong on transmission and deadbeef only..... hmmmm

Which themes have you tried? Are you sure the other programs are indeed GTK3 and not GTK2?

Offline

#5 2012-11-19 18:50:37

ninjaprawn
Member
From: Manchester, UK
Registered: 2008-01-26
Posts: 455

Re: [solved]gui is wrong on transmission and deadbeef only..... hmmmm

no, not sure what is gtk3 and what is gtk2.... but just going through a few more programs installed and my list of "broken" gtk things has increased to include;
deadbeef
transmission
nm-applet
character map
Disks
galculator

but working fine are;
leafpad
chromium
gpicview
pcmanfm
parcellite
orage

themes i have tried include;
delorean dark theme 3.6
crux

I am using LXAppearance to set/change themes, and have noticed that in the programs that are sturggling.... the appearance never changes.... odd?


- Samsung Series 3, Intel(R) Core(TM) i5-3210M CPU @ 2.50GHz - 6Gb DDR3 ram - 700Gb HDD
On board intel Graphics & Sound

Offline

#6 2012-11-19 19:26:39

lucke
Member
From: Poland
Registered: 2004-11-30
Posts: 4,018

Re: [solved]gui is wrong on transmission and deadbeef only..... hmmmm

lxappearance changes gtk2 themes. For gtk3: https://wiki.archlinux.org/index.php/GTK%2B#GTK.2B_3.x

Offline

#7 2012-11-19 19:46:16

Šaran
Member
From: Bosnia
Registered: 2011-09-03
Posts: 407

Re: [solved]gui is wrong on transmission and deadbeef only..... hmmmm

It changes gtk3, too.
Try this theme.

Offline

#8 2012-11-19 21:28:10

ninjaprawn
Member
From: Manchester, UK
Registered: 2008-01-26
Posts: 455

Re: [solved]gui is wrong on transmission and deadbeef only..... hmmmm

@Šaran - I tried that one, but no joy....

~/.gtkrc-2.0

# DO NOT EDIT! This file will be overwritten by LXAppearance.
# Any customization should be done in ~/.gtkrc-2.0.mine instead.

gtk-theme-name="Faience"
gtk-icon-theme-name="AwOken"
gtk-font-name="Sans 10"
gtk-cursor-theme-name="oxy-oxygen"
gtk-cursor-theme-size=0
gtk-toolbar-style=GTK_TOOLBAR_ICONS
gtk-toolbar-icon-size=GTK_ICON_SIZE_SMALL_TOOLBAR
gtk-button-images=0
gtk-menu-images=0
gtk-enable-event-sounds=1
gtk-enable-input-feedback-sounds=1
gtk-xft-antialias=1
gtk-xft-hinting=1
gtk-xft-hintstyle="hintslight"
gtk-xft-rgba="rgb"
gtk-color-scheme="tooltip_fg_color:#000000\nbase_color:#1B1B1B\nselected_fg_color:#999999\ntext_color:#999999\nbg_color:#1B1B1B\ntooltip_bg_color:#d7d7d7\nselected_bg_color:#484848\nfg_color:#999999\n"
include "/home/danny/.gtkrc-2.0.mine"

$XDG_CONFIG_HOME/gtk-3.0/settings.ini

[Settings] 
gtk-theme-name=Faience
gtk-icon-theme-name=AwOken
gtk-font-name=Sans 10
gtk-cursor-theme-name=oxy-oxygen
gtk-cursor-theme-size=0
gtk-toolbar-style=GTK_TOOLBAR_ICONS
gtk-toolbar-icon-size=GTK_ICON_SIZE_SMALL_TOOLBAR
gtk-button-images=0
gtk-menu-images=0
gtk-enable-event-sounds=1
gtk-enable-input-feedback-sounds=1
gtk-xft-antialias=1
gtk-xft-hinting=1
gtk-xft-hintstyle=hintslight
gtk-xft-rgba=rgb
gtk-color-scheme=tooltip_fg_color:#000000\nbase_color:#1B1B1B\nselected_fg_color:#999999\ntext_color:#999999\nbg_color:#1B1B1B\ntooltip_bg_color:#d7d7d7\nselected_bg_color:#484848\nfg_color:#999999\n

still have the same issue.... even rebooted just incase..... got this new theme on some programs, and some horrid mess on the others still.

EDIT = pacman -S librsvg has improved the look... but the problem programs i mentioned before have a black them with green progress bar, but Faience is a white/grey theme!

Last edited by ninjaprawn (2012-11-19 21:38:25)


- Samsung Series 3, Intel(R) Core(TM) i5-3210M CPU @ 2.50GHz - 6Gb DDR3 ram - 700Gb HDD
On board intel Graphics & Sound

Offline

#9 2012-11-19 21:37:07

anonymous_user
Member
Registered: 2009-08-28
Posts: 3,058

Re: [solved]gui is wrong on transmission and deadbeef only..... hmmmm

@ninjaprawn - The file you should be checking is ~/.config/gtk-3.0/settings.ini

For themes, I would first try the default Adwaita. Also try xfce-theme-bluebird or xfce-theme-bluebird from the AUR.

Offline

#10 2012-11-19 21:42:18

ninjaprawn
Member
From: Manchester, UK
Registered: 2008-01-26
Posts: 455

Re: [solved]gui is wrong on transmission and deadbeef only..... hmmmm

thanks ... just had a look in ~/.config/gtk-3.0/settings.ini and it was almost blank bar one lilne, so copied & pasted  $XDG_CONFIG_HOME/gtk-3.0/settings.ini but still not worked... just tried Adwaita and it left the programs causing trouble unchanged sad


- Samsung Series 3, Intel(R) Core(TM) i5-3210M CPU @ 2.50GHz - 6Gb DDR3 ram - 700Gb HDD
On board intel Graphics & Sound

Offline

#11 2012-11-19 21:44:31

anonymous_user
Member
Registered: 2009-08-28
Posts: 3,058

Re: [solved]gui is wrong on transmission and deadbeef only..... hmmmm

Its very odd that it is (almost) blank. Lxappearance should create and fill it. Try deleting it and changing themes with Lxappearance. Make sure to select a GTK3 theme.

Offline

#12 2012-11-19 21:44:58

Šaran
Member
From: Bosnia
Registered: 2011-09-03
Posts: 407

Re: [solved]gui is wrong on transmission and deadbeef only..... hmmmm

My bad, you need gtk-engine-unico for Faince.

Offline

#13 2012-11-19 21:56:13

ninjaprawn
Member
From: Manchester, UK
Registered: 2008-01-26
Posts: 455

Re: [solved]gui is wrong on transmission and deadbeef only..... hmmmm

@Šaran - got it already.... still no joy

sorry, made a mistake when i ran leafpad ~/.config/gtk-3.0/settings.ini ,,,, i was logged in as root... just looked in my user file, and it is filled in correctly... so lxappearance is doing its job with the config files.....

I have also worked my way through this entire section of arch wiki relating to gtk3.... guess what... still no luck sad

GTK+ 3.x
If you use GNOME 3, the theme can be changed with the gnome-tweak-tool.
If you use Xfce 4.8, both GTK+ 3.x and GTK+ 2.x themes can be managed by Appearance tool. Go to Settings-->Appearance. If selected style has both GTK+ 2.x and GTK+ 3.x themes, they will be used. If selected style has only GTK+ 2.x theme, it will be used for GTK+ 2.x applications and (ugly) defaults will be used for GTK+ 3.x applications. If selected style has only GTK+ 3.x theme, it will be used for GTK+ 3.x applications and (ugly) defaults will be used for GTK+ 2.x applications. Thus for uniform UI appearance and best experience one can use style that has both GTK+ 2.x and GTK+ 3.x themes. Search packages and AUR. One example of this is theme clearwaita-gtk-theme.
If you use a GTK+ 2.x based DE, like Xfce, LXDE, gnome-tweak-tool won't work; see FS#23644. You need to install librsvg, and set your theme manually in $XDG_CONFIG_HOME/gtk-3.0/settings.ini (this is usually ~/.config/gtk-3.0/settings.ini. An example settings.ini file:
$XDG_CONFIG_HOME/gtk-3.0/settings.ini
[Settings]
gtk-application-prefer-dark-theme = false
gtk-theme-name = Zukitwo
gtk-fallback-icon-theme = gnome
gtk-icon-theme-name = [icon theme name]
gtk-font-name = [font name] [font size]
If it still does not change, delete old gtk-3.0 folder in $XDG_CONFIG_HOME and copy gtk-3.0 folder from /path/to/theme to $XDG_CONFIG_HOME. Example:
$ rm -r ~/.config/gtk-3.0/
$ cp -r /usr/share/themes/Zukitwo/gtk-3.0/ ~/.config/


- Samsung Series 3, Intel(R) Core(TM) i5-3210M CPU @ 2.50GHz - 6Gb DDR3 ram - 700Gb HDD
On board intel Graphics & Sound

Offline

#14 2012-11-19 22:03:55

ninjaprawn
Member
From: Manchester, UK
Registered: 2008-01-26
Posts: 455

Re: [solved]gui is wrong on transmission and deadbeef only..... hmmmm

thank you everyone... just deleted the gtk3 folder in ~/.config/ and everything is working now! apart from lxappearance cant apply a theme on the fly, gtk3 programs have to be restarted to work, where as gtk2 dont.


- Samsung Series 3, Intel(R) Core(TM) i5-3210M CPU @ 2.50GHz - 6Gb DDR3 ram - 700Gb HDD
On board intel Graphics & Sound

Offline

#15 2012-11-19 22:09:46

drcouzelis
Member
From: Connecticut, USA
Registered: 2009-11-09
Posts: 3,473
Website

Re: [solved]gui is wrong on transmission and deadbeef only..... hmmmm

ninjaprawn wrote:

just had a look in ~/.config/gtk-3.0/settings.ini and it was almost blank bar one lilne, so copied & pasted  $XDG_CONFIG_HOME/gtk-3.0/settings.ini but still not worked

Wait a minute... Is this a trick? Those are totally the same directory!

$ ls ~/.config/gtk-3.0/settings.ini
/home/drcouzelis/.config/gtk-3.0/settings.ini

$ ls $XDG_CONFIG_HOME/gtk-3.0/settings.ini
/home/drcouzelis/.config/gtk-3.0/settings.ini

Offline

#16 2012-11-19 22:16:27

ninjaprawn
Member
From: Manchester, UK
Registered: 2008-01-26
Posts: 455

Re: [solved]gui is wrong on transmission and deadbeef only..... hmmmm

drcouzelis wrote:
ninjaprawn wrote:

just had a look in ~/.config/gtk-3.0/settings.ini and it was almost blank bar one lilne, so copied & pasted  $XDG_CONFIG_HOME/gtk-3.0/settings.ini but still not worked

Wait a minute... Is this a trick? Those are totally the same directory!

$ ls ~/.config/gtk-3.0/settings.ini
/home/drcouzelis/.config/gtk-3.0/settings.ini

$ ls $XDG_CONFIG_HOME/gtk-3.0/settings.ini
/home/drcouzelis/.config/gtk-3.0/settings.ini

i was logged in as root when i looked at ~ so it took me to my root home rather than my user home... good spot though


- Samsung Series 3, Intel(R) Core(TM) i5-3210M CPU @ 2.50GHz - 6Gb DDR3 ram - 700Gb HDD
On board intel Graphics & Sound

Offline

Board footer

Powered by FluxBB