You are not logged in.

#1 2012-11-19 22:19:08

10PinkPanther
Member
From: Croatia
Registered: 2012-11-10
Posts: 333

[SOLVED]Cannot install Yaourt- missing required signature

I'm trying to install Yaourt whole afternoon but all I get a message that signature is missing.I even tried to make PKGBUILD but it ends with same message.

nino@nino ~]$ sudo pacman -S yaourt
resolving dependencies...
looking for inter-conflicts...

Targets (3): package-query-1.1-2  yajl-2.0.4-1  yaourt-1.2.1-1

Total Installed Size:   0.66 MiB

Proceed with installation? [Y/n] y
(3/3) checking package integrity                   [-------------------] 100%
error: package-query: missing required signature
error: yaourt: missing required signature
error: failed to commit transaction (invalid or corrupted package (PGP signature))
Errors occurred, no packages were upgraded.

Last edited by 10PinkPanther (2012-11-20 06:45:56)

Offline

#2 2012-11-19 22:50:00

googol-1
Member
Registered: 2012-10-21
Posts: 22

Re: [SOLVED]Cannot install Yaourt- missing required signature

Likely you have set the default signature verification level to Required, in the /etc/pacman.conf.

If you aren't sure post your /etc/pacman.conf

Last edited by googol-1 (2012-11-19 22:52:04)

Offline

#3 2012-11-19 22:50:34

mzneverdies
Member
Registered: 2012-02-04
Posts: 147

Re: [SOLVED]Cannot install Yaourt- missing required signature

I think this should be easy, you need to ¿regenerate? your pacman keys.
Open 2 terminals, one should run "ls -R /" which is an intensive work (needed for the process, you can just run any other intensive script, but this one is harmless, just lists everything on your harddrive.

After a while, on the other termnal, you must run

pacman-key --init
pacman-key --populate archlinux

and you should be done smile

source: arch wiki Pacman-key https://wiki.archlinux.org/index.php/Pa … he_keyring

Offline

#4 2012-11-19 22:50:46

WorMzy
Forum Moderator
From: England
Registered: 2010-06-16
Posts: 5,059

Re: [SOLVED]Cannot install Yaourt- missing required signature

Remove the repo you added, then build and install package-query, then build and install yaourt.


Sakura:-
Mobo: ASUS P8Z77-V PRO // Processor: Intel Core i7-3770K 3.4GHz // GFX: nVidia GeForce GTX 970 Ti // RAM: 32GB (4x 8GB) Corsair DDR3 (@ 2133MHz) // Storage: 1x 3TB Seagate SATAII 5x 1TB Samsung SATAII, 2x 120GB Corsair SSD

Online

#5 2012-11-20 06:30:12

10PinkPanther
Member
From: Croatia
Registered: 2012-11-10
Posts: 333

Re: [SOLVED]Cannot install Yaourt- missing required signature

Thanks a lot guys for your reply.
I removed "SigLevel = RecquiredPackage" from /etc/pacman.conf and now it's O.K.

Offline

Board footer

Powered by FluxBB