You are not logged in.

#1 2012-11-19 01:10:00

Registered: 2011-12-08
Posts: 4

Resolution and 3D issues with NVIDIA proprietary driver

I bought a new PC recently and I installed Arch x86_64 on it. The hardware is the following:

Intel Core i5 - Ivy Bridge, Quad Core, has integrated GPU
EVGA GTX 660 Superclocked
Asrock z77 Extreme 4 - Has UEFI
2x4 GB Corsair DDR3

I installed mesa, the nvidia driver and xorg. For window manager I installed awesome. The xorg.conf was generated using the nvidia-settings utility.
The first problem is that in the nvidia-settings utility I don't have the option to select a resolution higher than 1024x768 even though I am using a widescreen. Editing the xorg.conf to edit the modes line to Modes "1440x900_60.00" - does nothing. In fact when I auto generate xorg.conf with the nvidia xorg generator, I end up in 640x280 permanently.
The second problem is that the games that I have seem to be loading the driver of the intel integrated gpu instead of the dedicated video card. Xonotic, native, works at 60 FPS with uncapped frames and maximum detail settings. Portal 2 through a 32bit wine prefix does not load at all: instead libgl throws an error that it cannot load I don't know why the nvidia driver is not being loaded.
Thirdly, I had to add "nomodeset" to the kernel parameters because without it the system boots to a black screen. The system works underneath - blindly logging in and shutting down works - but I can't get away from the blacks screen without booting to the install medium, mounting the root and efi partitions and adding nomodeset to the line of kernel parameters.

I tried the beta drivers from AUR, uninstalling mesa, same result.
lspci output

Thanks in advance!

Last edited by kirilz (2012-11-19 01:11:03)


#2 2012-11-19 08:58:30

Registered: 2007-04-03
Posts: 3,615

Re: Resolution and 3D issues with NVIDIA proprietary driver

The later nvidia drivers have screwed up xrandr. E.g. I have to compile wine 1.5.9 and above with --without-xrandr, otherwise Sniper Elite 1 moans about the video resolution and doesn't start.


#3 2012-11-19 23:17:14

Registered: 2011-12-08
Posts: 4

Re: Resolution and 3D issues with NVIDIA proprietary driver

I tried all the suggestion in this topic:
nvidia and xrandr resolutions missing
to no avail. The only thing that I managed regarding the resolution is that when I have this line in my xorg.conf's screen section:

Option "metamodes" "CRT-0: nvidia-auto-select {ViewPortIn=1440x900}

The screen resolution sort of changes, it basically shrinks the 1024x768 desktop and plasters it in a muddily stretched 1440x900.


Board footer

Powered by FluxBB