You are not logged in.

#1 2012-11-18 08:34:08

colbert
Member
Registered: 2007-12-16
Posts: 809

Can't run sickbeard after update

I'm using the sickbeard-git package that has always worked fine from AUR, just updated and followed the instructions in the update message. Now running the command gives an error:

┌─[ 11/18/12 10:23:59 PM ][ ~ ]
└─> systemctl --user start sickbeard
Failed to get D-Bus connection: No connection to service manager.

I do have dbus running in rc.conf and with ps it shows it's running:

└─> psaux dbus
dbus       535  0.0  0.0  17692  1368 ?        Ss   03:23   0:00 dbus-daemon --system
bobby     1278  0.0  0.0  12820   716 tty1     S    03:23   0:00 ck-launch-session dbus-launch startfluxbox
bobby     1295  0.0  0.0  17408  1228 ?        Ss   03:23   0:00 /usr/bin/dbus-daemon --fork --print-pid 4 --print-address 6 --session

Haven't run into this with anything else so not sure what's up, appreciate any help, thanks!

Offline

#2 2012-11-18 09:58:22

kevin89
Arch Linux f@h Team Member
From: Netherlands
Registered: 2007-03-14
Posts: 218

Re: Can't run sickbeard after update

Not that much help from me, but just a confirmation that I had this problem as well. Eventually, I just decided to run it without the --user option, because I couldn't fix it.

Offline

#3 2012-11-18 19:35:51

colbert
Member
Registered: 2007-12-16
Posts: 809

Re: Can't run sickbeard after update

Even without the --user option, I get the same error sad

Offline

#4 2012-11-18 21:03:34

Serg555
Member
Registered: 2008-11-27
Posts: 7

Re: Can't run sickbeard after update

@colbert
When there is a new screenshot? smile

Last edited by Serg555 (2012-11-18 21:03:46)

Offline

#5 2012-11-19 19:44:39

colbert
Member
Registered: 2007-12-16
Posts: 809

Re: Can't run sickbeard after update

@Serg555, probably not for a while smile

Still trying to get sickbeard running if anyone's got any ideas sad

Offline

#6 2012-11-21 08:25:02

colbert
Member
Registered: 2007-12-16
Posts: 809

Re: Can't run sickbeard after update

Ok I properly switched to systemd, most stuff is fine but sickbeard is still giving me problems:

└─> systemctl start --user sickbeard
Failed to issue method call: Process /bin/false exited with status 1

Running it without the --user option returns no error, but in the systemctl list it still shows as failed:

sickbeard.service                                                                        loaded failed failed        SickBeard Daemon

EDIT: For the moment I have just gone into /opt/sickbeard and run "python2 Sickbeard.py --daemon" and it's working, but I would like to figure out why it can't jive with systemctl, appreciate any help :S

Last edited by colbert (2012-11-21 08:32:13)

Offline

#7 2012-11-21 08:51:01

jrussell
Member
From: Cape Town, South Africa
Registered: 2012-08-16
Posts: 510

Re: Can't run sickbeard after update

Double check the permissions of /opt/sickbeard.

I think I had a similar problem and 775 sorted me out


bitcoin: 1G62YGRFkMDwhGr5T5YGovfsxLx44eZo7U

Offline

#8 2012-11-23 19:14:20

colbert
Member
Registered: 2007-12-16
Posts: 809

Re: Can't run sickbeard after update

Yep, it's 775, still nothing sad

Offline

#9 2012-11-23 20:57:52

teekay
Member
Registered: 2011-10-26
Posts: 270

Re: Can't run sickbeard after update

It works here as user with systemd. I do use a custom git branch, though, not the AUR package. Here's my /etc/systemd/system/sickbeard.service if it helps:

[Unit]
Description=Sick Beard Daemon

[Service]
Type=simple
User=tom
Group=sickbeard
ExecStart=/usr/bin/env python2 /opt/sickbeard/SickBeard.py --quiet --config /opt/sickbeard/config.ini --port 8081
Restart=always

[Install]
WantedBy=multi-user.target

Offline

#10 2012-11-23 23:12:33

colbert
Member
Registered: 2007-12-16
Posts: 809

Re: Can't run sickbeard after update

Thanks so much teekay! Okay I just did a series of tinkerings, constant "systemctl restart sickbeard" + "systemctl --system daemon-reload"'s and finally I got it working. What seemed to be wrong was having sickbeard.service in the wrong place and/or not symlinked properly, as well as I had the wrong group in "Group=" line in sickbeard.service. Also, the "ExecStart" line had "datadir=/opt/sickbeard" which had to be taken out. In case anyone else runs into this:

[Unit]
Description=SickBeard Daemon
#After=network.target

[Service]
Type=simple
User=bobby
Group=users
#ExecStart=/usr/bin/env python2 /opt/sickbeard/SickBeard.py --config /opt/sickbeard/config.ini --datadir /opt/sickbeard
ExecStart=/usr/bin/env python2 /opt/sickbeard/SickBeard.py --config %h/.sickbeard/config.ini

[Install]
WantedBy=multi-user.target

This is the sickbeard.service file which I put in /usr/lib/systemd/system/, and then made a symlink to it from /etc/systemd/system/multi-user.target.wants. Finally I reloaded the daemons after restarting the sickbeard and it's up (tested in browser as well of course):

sickbeard.service                                                                        loaded active running       SickBeard Daemon

big_smile  Thanks for the help!

Offline

#11 2012-11-24 10:55:14

teekay
Member
Registered: 2011-10-26
Posts: 270

Re: Can't run sickbeard after update

Great it works now. I recommend putting your customized sickbeard.service file into /etc/systemd/system/ instead, so it will not be overwritten by future updates.
Afterwards do a

systemctl --system daemon-reload
systemctl reenable sickbeard

Last edited by teekay (2012-11-24 10:57:53)

Offline

Board footer

Powered by FluxBB