You are not logged in.

#1 2012-11-23 07:30:33

From: Linköping, Sweden
Registered: 2008-03-30
Posts: 6

[solved] pacman -Su fails ("openntpd and ntp are in conflict")

I have ntp installed. Today when I tried to do a full upgrade I got:

# pacman -Su
:: Starting full system upgrade...
resolving dependencies...
looking for inter-conflicts...
:: openntpd and ntp are in conflict. Remove ntp? [y/N] 
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: openntpd and ntp are in conflict

If I accept to remove ntp, pacman tells me that the following packages will be upgraded:

# pacman -Su
:: Starting full system upgrade...
resolving dependencies...
looking for inter-conflicts...
:: openntpd and ntp are in conflict. Remove ntp? [y/N] y

Targets (155): archlinux-keyring-20121113-1  at-spi2-atk-2.6.2-1
               at-spi2-core-2.6.2-1  aurvote-1.5-1  automake-1.12.5-1
               binutils-multilib-2.23.1-1  bison-2.6.5-1  blas-3.4.2-1
               boost-1.50.0-3  boost-libs-1.50.0-3  brasero-3.6.1-1
               ca-certificates-20121105-1  colord-0.1.24-3  cronie-1.4.8-4
               emacs-24.2-3  evolution-data-server-3.6.2-1  farstream-0.2.2-1
               ffmpeg-1:1.0-2  ffmpeg-compat-20120509-2  firefox-17.0-1
               fontforge-20120731_b-2  fuse-2.9.2-1  gcr-3.6.2-2  gedit-3.6.2-1
               glib-networking-2.34.2-1  glib2-2.34.2-1  glpk-4.47-2
               gnome-desktop-1:3.6.2-1  gnome-icon-theme-3.6.2-1
               gnome-icon-theme-symbolic-3.6.2-1  gnome-keyring-3.6.2-1
               gnome-menus-3.6.1-1  gnome-mplayer-1.0.7-2
               gnome-online-accounts-3.6.2-1  gnome-panel-3.6.2-1
               gnutls-3.1.4-1  gobject-introspection-1.34.2-1
               gsettings-desktop-schemas-3.6.1-1  gst-plugins-bad-1.0.3-1
               gst-plugins-base-1.0.3-1  gst-plugins-base-libs-1.0.3-1
               gst-plugins-good-1.0.3-1  gstreamer-1.0.3-1
               gstreamer0.10-ugly-plugins-0.10.19-3  gucharmap-3.6.1-1
               gvfs-1.14.2-1  harfbuzz-0.9.6-1  icu-50.1-2  intel-dri-9.0.1-1
               iputils-20121114-1  khrplatform-devel-9.0.1-1  kmod-11-2
               lapack-3.4.2-1  ldns-1.6.16-1  lib32-cairo-1.12.8-1
               lib32-gdk-pixbuf2-2.26.5-1  lib32-glib2-2.34.2-1
               lib32-gnutls-3.1.4-1  lib32-harfbuzz-0.9.6-1  lib32-icu-50.1-1
               lib32-intel-dri-9.0.1-1  lib32-libdrm-2.4.40-1
               lib32-libgl-9.0.1-1  lib32-libglapi-9.0.1-1  lib32-mesa-9.0.1-1
               lib32-nspr-4.9.3-2  lib32-nss-3.14-2  lib32-pango-1.32.2-1
               lib32-pixman-0.28.0-1  lib32-qt-4.8.3-3  libcap-ng-0.7.3-1
               libegl-9.0.1-1  libgbm-9.0.1-1  libgl-9.0.1-1  libglapi-9.0.1-1
               libgles-9.0.1-1  libgsf-1.14.25-1  libgweather-3.6.2-1
               libpng12-1.2.50-2  libquicktime-1.2.4-3
               libreoffice-base-3.6.3-3  libreoffice-calc-3.6.3-3
               libreoffice-common-3.6.3-3  libreoffice-draw-3.6.3-3
               libreoffice-impress-3.6.3-3  libreoffice-math-3.6.3-3
               libreoffice-sdk-3.6.3-3  libreoffice-writer-3.6.3-3
               libsecret-0.12-2  libsoup-2.40.2-1  libsoup-gnome-2.40.2-1
               libtracker-sparql-0.14.4-2  libwnck3-3.4.4-1
               live-media-2012.11.08-1  logrotate-3.8.2-2  ltrace-0.7.0-1
               lv2-1.2.0-1  maxima-5.28.0-4  mesa-9.0.1-1  mkinitcpio-0.11.2-1
               mplayer-35421-1  nautilus-3.6.3-1  ntp-4.2.6.p5-11 [removal]
               openntpd-3.9p1-21  openssh-6.1p1-4  opera-12.11.1661-1
               pango-1.32.2-1  pkgfile-7-2  plotutils-2.6-3
               pygobject-devel-3.4.2-1  python-distribute-0.6.30-1
               python-pytz-2012h-1  python2-distribute-0.6.30-1
               python2-gobject-3.4.2-1  python2-logilab-astng-0.24.1-2
               python2-logilab-common-0.58.3-2  python2-matplotlib-1.2.0-3
               python2-opengl-3.0.2-2  python2-pytz-2012h-1  qjson-0.8.0-1
               qt-4.8.3-6  raptor-2.0.8-2  rfkill-0.4-6  sbcl-1.1.1-2
               sdl_mixer-1.2.12-3  shadow-  skype-
               sord-0.10.4-1  suil-0.6.6-1  telepathy-glib-0.20.1-1
               texmacs-  thunderbird-17.0-1  tzdata-2012j-1
               util-linux-2.22.1-3  vi-1:050325-3  vlc-2.0.4-4
               vte-common-0.34.2-1  webkitgtk2-1.10.1-3  webkitgtk3-1.10.1-3
               wine-1.5.17-1  wxgtk-  wxmaxima-12.09.0-1
               x264-20121113-1  xf86-video-intel-2.20.13-1  xmms-1.2.11-6
               xulrunner-17.0-1  yelp-3.6.2-1  zsh-5.0.0-3

Total Download Size:    495.69 MiB
Total Installed Size:   2334.87 MiB
Net Upgrade Size:       61.25 MiB

Proceed with installation? [Y/n] n

How can I investigate what's the source of the problem? Is there a way to get pacman to tell me which package it is that is trying to pull in openntpd? (Or does anybody know right away how to resolve this issue?)

Oh, by the way: "pacman -Sii openntpd" says

Required By    : networkmanager-dispatcher-openntpd

but I don't use networkmanager.

Last edited by halun (2012-11-23 07:54:51)


#2 2012-11-23 07:37:05

From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: [solved] pacman -Su fails ("openntpd and ntp are in conflict")

Are these pacakages on your system?  Use the query function instead of the sync function with pacman.  See the man page for more info.


#3 2012-11-23 07:54:13

From: Linköping, Sweden
Registered: 2008-03-30
Posts: 6

Re: [solved] pacman -Su fails ("openntpd and ntp are in conflict")

Ha, how stupid of me...

I thought openntpd was being pulled in, but it was already installed (by me, apparently) although I've never used it. Removing it by hand before upgrading resolved the problem. Thanks!


Board footer

Powered by FluxBB