You are not logged in.

#1 2012-11-22 15:03:59

Spheerys
Member
Registered: 2012-05-01
Posts: 12

Pulseaudio used by first launched application and blocked for other

Hi,

Since I have switch to systemd, I have annoying problem with pulseaudio.

If I want to use vlc to listen music for example, I don't have sound.

After lots of searchs, I have found a way to unlock the sound.
I do this :

$ fuser -v /dev/snd/*
                     UTIL.       PID ACCÈS  COMMANDE
/dev/snd/controlC0:  hedy        870 F.... hotot-gtk3
/dev/snd/pcmC0D0p:   hedy        870 F...m hotot-gtk3
/dev/snd/timer:      hedy        870 f.... hotot-gtk3

We can see the sound device is used by hotot.
I kill it with a kill -15 870

I restart pulseaudio :

$ pulseaudio --kill
$ pulseaudio --start

After did this, I have this :

$ fuser -v /dev/snd/*
                     UTIL.       PID ACCÈS  COMMANDE
/dev/snd/controlC0:  hedy       1683 F.... pulseaudio

And now, I can use vlc (or other sound application !)

How can I fix this definitely ?

Last edited by Spheerys (2012-11-22 16:45:40)

Offline

#2 2012-11-23 08:41:56

whoops
Member
Registered: 2009-03-19
Posts: 842

Re: Pulseaudio used by first launched application and blocked for other

So... I guess this "hothot" panel thing starts with the panel and then tries to play its own system notification sounds over alsa/oss, blocking the sound card? Did it work before you switched to systemd or is it new?

- Did you maybe have an important module blacklist entry before you switched to systemd and forget to make it systemd compliant?
- Is systemd starting something sound-related that you didn't have before?
- Can you find out, where "hothot" is getting its sound device choice from? Might be your DE's settings...

If nothing else helps, you can try having pavucontrol started BEFORE the panel / hothot, so pulseaudio has dips on the sound card. This is a bad'ish workaround, but adding a panel plugin for pulseaudio mixer might just work if it gets loaded first.

Last edited by whoops (2012-11-23 08:42:38)

Offline

#3 2012-11-23 17:10:22

Spheerys
Member
Registered: 2012-05-01
Posts: 12

Re: Pulseaudio used by first launched application and blocked for other

I don't have blacklisted module.
I don't find where hotot get sound, so I have disabled the startup launch of hotot and the problem "disappears"...

Not a real solution, but a kind of workaround smile

Offline

Board footer

Powered by FluxBB