You are not logged in.

#1 2012-11-20 19:11:33

Captain Rage
Member
Registered: 2012-02-02
Posts: 27

3D rendering extremely slow in awesome wm after migrating to systemd

Good evening, fellow Archers!
Once again your expertise and assistance is required!

The problem:
3D rendering is very, very, slow after switching to awesome wm and/or upgrading to systemd. Things like turning 3D plots generated in GNU Octave (via gnuplot), as well as glxgears, are running extremely slowy.

Typing "glxinfo | grep direct" into a terminal yields a "yes", though.

Longer version of the problem:
My Asus Eee Pc 901 has been running OpenBox for a long time, but I haven't used that machine for 2-3 months now. Recently I booted it up again, and discovered that Arch Linux is now using systemd while updating the system. Migrating to systemd was rather painless. However, while doing these upgrades I decided to ditch OpenBox in favor of trying out awesome wm. Everything worked superb in awesome wm, which I would say is now my window manager of choice.
Then I discovered that 3D rendering is very choppy/unresponsive/slow (other than that, the computer is as fast as before). What is going on here? My netbook has an integrated Intel graphics card, by the way, that worked fine before.

Offline

#2 2012-11-21 16:35:41

masteryod
Member
Registered: 2010-05-19
Posts: 433

Re: 3D rendering extremely slow in awesome wm after migrating to systemd

Captain Rage wrote:

Typing "glxinfo | grep direct" into a terminal yields a "yes", though.

That's not enough. You should paste whole 2 lines of the output. Second line is important to see what driver do you use.

Captain Rage wrote:

My netbook has an integrated Intel graphics card, by the way, that worked fine before.

It might be related to group handling in systemd, go through this thread: https://bbs.archlinux.org/viewtopic.php?id=151080

Last edited by masteryod (2012-11-21 16:36:09)

Offline

#3 2012-11-22 00:05:54

Captain Rage
Member
Registered: 2012-02-02
Posts: 27

Re: 3D rendering extremely slow in awesome wm after migrating to systemd

I think you're on to something here!! Thanks for the pointer.

Didn't mention it before, because I thought it was unrelated, but this might have something to do with the issue: when logging in, just before awesome wm starts up,

-bash: /home/username/.bash_profile: Permission denied

is displayed.

How do I know/change what tty is being used for awesome wm (which seems to be using tty1)? When OpenBox was running before it might have been using another tty (think it was tty7).
I read the information you linked, albeit it was not very clear to me (I don't know how to add my user to different groups, to see if that works better).

This is what glxinfo says:

name of display: :0
display: :0  screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.4
server glx extensions:
    GLX_ARB_create_context, GLX_ARB_create_context_profile, 
    GLX_ARB_multisample, GLX_EXT_create_context_es2_profile, 
    GLX_EXT_import_context, GLX_EXT_texture_from_pixmap, GLX_EXT_visual_info, 
    GLX_EXT_visual_rating, GLX_MESA_copy_sub_buffer, GLX_OML_swap_method, 
    GLX_SGI_swap_control, GLX_SGIS_multisample, GLX_SGIX_fbconfig, 
    GLX_SGIX_pbuffer, GLX_SGIX_visual_select_group, GLX_INTEL_swap_event
client glx vendor string: Mesa Project and SGI

Offline

#4 2012-11-23 18:48:08

Captain Rage
Member
Registered: 2012-02-02
Posts: 27

Re: 3D rendering extremely slow in awesome wm after migrating to systemd

Okay, disabling vsync by typing "export vblank_mode=0" in a terminal made glxgears' FPS jump from 20-40 to 350-400. Perhaps vsync somehow got enabled when upgrading (don't know whether it was enabled or not before, though). Rotating 3D plots (generated with gnuplot in GNU Octave) is still not very responsive, thought. Maybe this is as good as it gets.

Offline

Board footer

Powered by FluxBB