You are not logged in.

#1 2012-11-24 21:07:40

micer
Member
Registered: 2012-05-14
Posts: 12

[solved] systemd - can't enable slim.service

Hi! I've finally decided to move from init scripts to systemd. I'm using Xfce and Slim as login manager. Following the guide on wiki, I've enabled services that are in my DAEMONS array. After reboot my graphical interface didn't start. I figured out I should also enable slim.service. It should be available according to Daemons List. But executing

systemctl enable slim.service

returns this:

Operation failed: No such file or directory

How could I resolve this?

Thanks!

Last edited by micer (2012-11-25 20:14:28)

Offline

#2 2012-11-24 21:39:41

root
Member
From: 127.0.0.1
Registered: 2012-04-13
Posts: 296

Re: [solved] systemd - can't enable slim.service

What is the output of,

systemctl status slim

?

Do you run the enable command as root or as user (without sudo)?

Just to make sure the service file is actually there,

ls /usr/lib/systemd/system/ |grep slim

Last edited by root (2012-11-24 21:40:02)


\(o_X)/
                        'Cause I wanna be an Archy - An Archy in the UK // Sex Pistols

Offline

#3 2012-11-24 21:45:14

micer
Member
Registered: 2012-05-14
Posts: 12

Re: [solved] systemd - can't enable slim.service

Yes, I run enable with root.

systemctl status slim

returns:

Failed to get D-Bus connection: No connection to service manager.

and

ls /usr/lib/systemd/system/ |grep slim

doens't return anything

Seems like service is not there - how can I add it?

Last edited by micer (2012-11-24 22:08:30)

Offline

#4 2012-11-24 22:38:09

jv2112
Member
Registered: 2011-07-23
Posts: 154

Re: [solved] systemd - can't enable slim.service

Looks like Dbus is not running. You need that to run slim. Try enabling that.


Life is pleasant. Death is peaceful. It's the transition that's troublesome. Isaac Asimov - / -  My Pastebin

Offline

#5 2012-11-24 22:52:52

root
Member
From: 127.0.0.1
Registered: 2012-04-13
Posts: 296

Re: [solved] systemd - can't enable slim.service

@jv2112

According to the wiki it should be running automatically if dbus-core is installed.

@micer

Are you booting with systemd?

On the basis of a similar thread it seems that by not doing so may be the reason for your trouble.


\(o_X)/
                        'Cause I wanna be an Archy - An Archy in the UK // Sex Pistols

Offline

#6 2012-11-25 11:08:40

micer
Member
Registered: 2012-05-14
Posts: 12

Re: [solved] systemd - can't enable slim.service

Thanks for replies!

I wasn't booting with systemd so I tried it ("cat /proc/1/comm" now returns "systemd", I've started gui manually), but it didn't solve the problem. Slim.service still isn't in the list of services (systemctl list-unit-files).

"systemctl status slim" now returns:

slim.service
	  Loaded: error (Reason: No such file or directory)
	  Active: inactive (dead)

There must be a way how to put it there. :-)

Offline

#7 2012-11-25 12:08:34

65kid
Member
From: Germany
Registered: 2011-01-26
Posts: 663

Re: [solved] systemd - can't enable slim.service

micer wrote:

Thanks for replies!

I wasn't booting with systemd so I tried it ("cat /proc/1/comm" now returns "systemd", I've started gui manually), but it didn't solve the problem. Slim.service still isn't in the list of services (systemctl list-unit-files).

"systemctl status slim" now returns:

slim.service
	  Loaded: error (Reason: No such file or directory)
	  Active: inactive (dead)

There must be a way how to put it there. :-)

slim.service is part of the slim package, so if it isn't there you either don't have slim installed or somehow screwed up and the file got deleted - a reinstall of slim would fix that. Well, or you haven't updated your system in a long, long time... wink

Offline

#8 2012-11-25 13:19:07

10PinkPanther
Member
From: Croatia
Registered: 2012-11-10
Posts: 333

Re: [solved] systemd - can't enable slim.service

Same happened to me.Then I instaled slim and it worked.

Offline

#9 2012-11-25 14:11:41

micer
Member
Registered: 2012-05-14
Posts: 12

Re: [solved] systemd - can't enable slim.service

@65kid @10PinkPanther
Thanks, you're right - I installed slim and the service is there now. :-) Don't understand why it wasn't there before since I'm using slim all the time.

Now - after boot, it stays on tty1. How to make systemd to automaticaly switch to tty7 where is my slim login manager?

EDIT: after another restart it works fine :-) problem solved, thanks for your help guys!

Last edited by micer (2012-11-25 20:14:03)

Offline

Board footer

Powered by FluxBB