You are not logged in.

#1 2012-11-22 17:56:02

deltaecho
Member
From: Seattle, Washington (USA)
Registered: 2008-08-06
Posts: 182

[SOLVED] Intel i7-3920XM Laptop CPU Linux Kernel Support

Recently, I purchased a laptop with an Intel i7-3920XM CPU, with the intention of utilizing it for scientific computing (I've become strongly interested in machine learning and artificial neural networks).  Supposedly, the CPU has a variable clock speed of 2.90 -- 3.80 GHz, which would be great, but my kernel has throttled it to 1200MHz.  I've tried both the cpufreq performance and userspace kernel modules (configured for performance), but the laptop stubbornly refuses to increase the clockspeed more than 1200MHz; I gave up on cpufreq and have uninstalled it.  I've read some accounts that it is possible that the Linux kernel may not support my CPU yet --- does anybody know if that is the case?  If it is not, can anybody point me to some literature describing how to un-throttle my CPU?

Last edited by deltaecho (2013-03-03 21:59:30)


Dylon

Offline

#2 2012-11-22 18:17:54

Meyithi
Member
From: Wirral, UK
Registered: 2009-06-21
Posts: 550
Website

Re: [SOLVED] Intel i7-3920XM Laptop CPU Linux Kernel Support

CPU frequency scaling is enabled by default, 1200MHz is fine for your processor as it's lowest frequency, I have the 3960x and it's lowest frequency is 1200MHz as well.

You should just leave things as they are, if you can actually feel sluggish performance ( I don't with 6 cores @ 1200MHz) you can try this:-  https://wiki.archlinux.org/index.php/Cp … erformance

Which will liven things up a bit at the cost of more battery juice.

EDIT/ compile something and whilst compiling

cat /proc/cpuinfo | grep MHz

to see what's reported at full load, but be aware it still may not report correctly due to turbo.

Last edited by Meyithi (2012-11-22 18:20:56)


The mind roams more freely in empty rooms.
dwm - colours - ncmpcpp - system
irc://irc.freenode.net:meyithi

Offline

#3 2012-11-24 03:24:36

hunterthomson
Member
Registered: 2008-06-22
Posts: 794
Website

Re: [SOLVED] Intel i7-3920XM Laptop CPU Linux Kernel Support

You only need to enable Intel Speed Step and Turbo Bost in BIOS/CMOS settings. New CPU's do not need any cpufreq or anything.

Your CPU is working as it should, however the Kernel is not reporting the speed as it should. You need to use the Intel program "i7z" in community/i7z

In this command line program you will see the correct speeds. There will also be a line that says something like this:
Max TURBO Multiplier (if Enabled) with 1/2/3/4 Cores is 36x/34x/34x/34x

That is what that line looks like for my CPU. The Bus clock frequency  is 99.76 MHz
So, the Max speeds are like this for 1 core used, 2 cores and so on...
> 99.76*36
[1] 3591.36
> 99.76*34
[1] 3391.84
> q()

Last edited by hunterthomson (2012-11-24 03:27:03)


OpenBSD-current Thinkpad X230, i7-3520M, 16GB CL9 Kingston, Samsung 830 256GB
Contributor: linux-grsec

Offline

#4 2012-11-24 07:43:33

runny6play
Member
Registered: 2012-02-18
Posts: 85

Re: [SOLVED] Intel i7-3920XM Laptop CPU Linux Kernel Support

I had this problem with my i7. its a werid acpi glitch.  see if it will upclock while plugged it. if so disable the ac module. that fixed it for me. My laptop still charges fine
also i7z will tell you the correct clock including turbo

Last edited by runny6play (2012-11-24 07:52:03)

Offline

#5 2012-11-24 07:51:09

runny6play
Member
Registered: 2012-02-18
Posts: 85

Re: [SOLVED] Intel i7-3920XM Laptop CPU Linux Kernel Support

Meyithi wrote:

CPU frequency scaling is enabled by default, 1200MHz is fine for your processor as it's lowest frequency, I have the 3960x and it's lowest frequency is 1200MHz as well.

You should just leave things as they are, if you can actually feel sluggish performance ( I don't with 6 cores @ 1200MHz) you can try this:-  https://wiki.archlinux.org/index.php/Cp … erformance

Which will liven things up a bit at the cost of more battery juice.

EDIT/ compile something and whilst compiling

cat /proc/cpuinfo | grep MHz

to see what's reported at full load, but be aware it still may not report correctly due to turbo.

you really should read the post closer. his processor is maxing out at 1200mhz severely underclocked

Offline

#6 2012-11-24 14:45:58

Meyithi
Member
From: Wirral, UK
Registered: 2009-06-21
Posts: 550
Website

Re: [SOLVED] Intel i7-3920XM Laptop CPU Linux Kernel Support

runny6play wrote:

you really should read the post closer. his processor is maxing out at 1200mhz severely underclocked

You have no idea what you are talking about, you really should have knowledge of what you criticize if you want to be taken seriously.

All of this is with no cpupower, just the default kernel "ondemand" governor that's loaded by default.

Top term is i7z, middle term is what system reports in /proc/cpuinfo
Idle:
http://ompldr.org/vZ2ZsNg
Load:
http://ompldr.org/vZ2ZsNw

Even at load /proc/cpuinfo reports incorrectly, this is because of turbo states which is too variable for Linux to be able to understand so the MHz you get reported is the maximum non turbo speed - i7z is pretty much the only way to get the correct frequencies, matches up to when I set the overclock in Windows -  http://www.meyithi.com/graphics/oc.png.

So yeah, I know what I'm talking about, sorry you disagree, maybe you should read my posts closer.


The mind roams more freely in empty rooms.
dwm - colours - ncmpcpp - system
irc://irc.freenode.net:meyithi

Offline

#7 2012-11-24 23:40:45

runny6play
Member
Registered: 2012-02-18
Posts: 85

Re: [SOLVED] Intel i7-3920XM Laptop CPU Linux Kernel Support

Meyithi wrote:

CPU frequency scaling is enabled by default, 1200MHz is fine for your processor as it's lowest frequency I have the 3960x and it's lowest frequency is 1200MHz as well.

You should just leave things as they are, if you can actually feel sluggish performance ( I don't with 6 cores @ 1200MHz) you can try this:-  https://wiki.archlinux.org/index.php/Cp … erformance

Which will liven things up a bit at the cost of more battery juice.

EDIT/ compile something and whilst compiling

cat /proc/cpuinfo | grep MHz

to see what's reported at full load, but be aware it still may not report correctly due to turbo.

deltaecho wrote:

Recently, I purchased a laptop with an Intel i7-3920XM CPU, with the intention of utilizing it for scientific computing (I've become strongly interested in machine learning and artificial neural networks).  Supposedly, the CPU has a variable clock speed of 2.90 -- 3.80 GHz, which would be great, but my kernel has throttled it to 1200MHz.  I've tried both the cpufreq performance and userspace kernel modules (configured for performance), but the laptop stubbornly refuses to increase the clockspeed more than 1200MHz; I gave up on cpufreq and have uninstalled it.  I've read some accounts that it is possible that the Linux kernel may not support my CPU yet --- does anybody know if that is the case?  If it is not, can anybody point me to some literature describing how to un-throttle my CPU?

I would agree with you if that was what the argument was about. I said the same thing about i7z as you just did, which is why i suggested it. as I understand it. your telling him 1.2 Ghz is an acceptable min and i would agree.How i am interperting his thread is 2.90 Ghz is his base. 3.80 Ghz is his max turbo. His CPU under 100 % load will not rise above 1.2 Ghz despite his stock clock is actually 2.90 Ghz. I can honestly say that this is the more likely story because my i7 did the same thing. on battery the max it would clock up to while runing /dev/urandom > /dev/null was 1.2 Ghz, while on Ac it would even turbo correctly. by unloading the module.  my proccessor would clock as expected 800 mhz min 3.4 max turbo. and if you look he even used the performance governor to try to increase the clock

Last edited by runny6play (2012-11-25 00:01:11)

Offline

#8 2012-11-26 09:25:12

hunterthomson
Member
Registered: 2008-06-22
Posts: 794
Website

Re: [SOLVED] Intel i7-3920XM Laptop CPU Linux Kernel Support

runny6play wrote:
Meyithi wrote:

CPU frequency scaling is enabled by default, 1200MHz is fine for your processor as it's lowest frequency I have the 3960x and it's lowest frequency is 1200MHz as well.

You should just leave things as they are, if you can actually feel sluggish performance ( I don't with 6 cores @ 1200MHz) you can try this:-  https://wiki.archlinux.org/index.php/Cp … erformance

Which will liven things up a bit at the cost of more battery juice.

EDIT/ compile something and whilst compiling

cat /proc/cpuinfo | grep MHz

to see what's reported at full load, but be aware it still may not report correctly due to turbo.

deltaecho wrote:

Recently, I purchased a laptop with an Intel i7-3920XM CPU, with the intention of utilizing it for scientific computing (I've become strongly interested in machine learning and artificial neural networks).  Supposedly, the CPU has a variable clock speed of 2.90 -- 3.80 GHz, which would be great, but my kernel has throttled it to 1200MHz.  I've tried both the cpufreq performance and userspace kernel modules (configured for performance), but the laptop stubbornly refuses to increase the clockspeed more than 1200MHz; I gave up on cpufreq and have uninstalled it.  I've read some accounts that it is possible that the Linux kernel may not support my CPU yet --- does anybody know if that is the case?  If it is not, can anybody point me to some literature describing how to un-throttle my CPU?

I would agree with you if that was what the argument was about. I said the same thing about i7z as you just did, which is why i suggested it. as I understand it. your telling him 1.2 Ghz is an acceptable min and i would agree.How i am interperting his thread is 2.90 Ghz is his base. 3.80 Ghz is his max turbo. His CPU under 100 % load will not rise above 1.2 Ghz despite his stock clock is actually 2.90 Ghz. I can honestly say that this is the more likely story because my i7 did the same thing. on battery the max it would clock up to while runing /dev/urandom > /dev/null was 1.2 Ghz, while on Ac it would even turbo correctly. by unloading the module.  my proccessor would clock as expected 800 mhz min 3.4 max turbo. and if you look he even used the performance governor to try to increase the clock

Ya, really the OP did not tell us 'how' he was reading his CPU speed....

deltaecho wrote:

Recently, I purchased a laptop with an Intel i7-3920XM CPU, with the intention of utilizing it for scientific computing (I've become strongly interested in machine learning and artificial neural networks).  Supposedly, the CPU has a variable clock speed of 2.90 -- 3.80 GHz, which would be great, but my kernel has throttled it to 1200MHz.  I've tried both the cpufreq performance and userspace kernel modules (configured for performance), but the laptop stubbornly refuses to increase the clockspeed more than 1200MHz; I gave up on cpufreq and have uninstalled it.  I've read some accounts that it is possible that the Linux kernel may not support my CPU yet --- does anybody know if that is the case?  If it is not, can anybody point me to some literature describing how to un-throttle my CPU?

runny6play: If deltaecho is also seeing these same slow speeds in i7z then both you and he should look into your BIOS settings. For sure this would be a BIOS setting on a ThinkPad. "If on battery....slow... if on AC...fast".

Yes, it is the Linux Kernel that is no "Reporting" the correct speed. This is a known bug. However, there is nothing wrong with your CPU. It is running at High Speed.. Like this is the read out from my Kernel at idle...

[user@archtop:~]% sudo cat /proc/cpuinfo | grep MHz
[sudo] password for user: 
cpu MHz         : 1200.000
cpu MHz         : 1200.000
cpu MHz         : 2901.000
cpu MHz         : 1200.000

The BEST way to test your CPU is, again i7z then compile some code... Like change the MAKEFLAGS="-j4" to -j1 for 1 thread, -j2 for 2 threads.... and so on. Compiling software will push your CPU all the way up.

When testing like this, i7z will show on 1 thread my CPU runs at 3.6GHz, on all 4 threads it runs at 3.4GHz, as it should. However, /proc/cpuinfo will only say wacky stuff like cpu MHz: 1200.000 cpu MHz: 2901.000

Last edited by hunterthomson (2012-11-26 09:28:13)


OpenBSD-current Thinkpad X230, i7-3520M, 16GB CL9 Kingston, Samsung 830 256GB
Contributor: linux-grsec

Offline

#9 2012-12-03 19:36:26

runny6play
Member
Registered: 2012-02-18
Posts: 85

Re: [SOLVED] Intel i7-3920XM Laptop CPU Linux Kernel Support

runny6play: If deltaecho is also seeing these same slow speeds in i7z then both you and he should look into your BIOS settings. For sure this would be a BIOS setting on a ThinkPad. "If on battery....slow... if on AC...fast".

I have all power saving off. I also think that the BIOS would recognize weather or not your on AC with or without the module. I mean I can't say for sure, but logically I don't think the BIOS relies on the OS for acpi events, and disabling the module fixed it. although I am still having problems with my nvidia gpu clock speeds

also I do know he didn't specify but because This has happened to me in this way I feel like its a fair assumption.

Offline

#10 2013-03-03 21:58:29

deltaecho
Member
From: Seattle, Washington (USA)
Registered: 2008-08-06
Posts: 182

Re: [SOLVED] Intel i7-3920XM Laptop CPU Linux Kernel Support

The problem seems to have been with my BIOS.  Setting the kernel parameter ignore_ppc=1 fixed the issue for me:

https://wiki.archlinux.org/index.php/CP … limitation


Dylon

Offline

Board footer

Powered by FluxBB