You are not logged in.

#1 2012-11-24 08:17:53

rzrscm
Member
Registered: 2012-11-17
Posts: 86

Video slowdown followed by out-of-sync audio on Mplayer

I'm having some trouble playing videos on mplayer.  The video will slow down for a few moments and then the audio will be out of sync and I'll get the "Your system is too SLOW to play this" message.  I've tried all the suggestions in that message and played around with other config settings and tried every different ao and vo option available to me, and nothing has solved the problem.  I'm on an older laptop (almost a decade old), but I'm not trying to play HD videos and I  never had this problem playing the same videos with other distros on this laptop.  I have a 1.5mhz processor, 512MB RAM, and an Nvidia FX go5200 graphics card which I'm using the proprietary drivers for.  The mplayer output looks like this...

MPlayer2 UNKNOWN (C) 2000-2012 MPlayer Team
Can't open joystick device /dev/input/js0: No such file or directory
Can't init input joystick
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing videos/[H-S] GoGoV 1-5/[H-S]Kyuukyuu_Sentai_GoGoV_03[DVD][BE6CE4FF].mkv.
[mkv] Track ID 1: subtitles (S_TEXT/ASS), -sid 0, -slang und
[mkv] Track ID 2: video (V_MPEG4/ISO/AVC), -vid 0
[mkv] Track ID 3: audio (A_AAC), -aid 0, -alang jpn
[mkv] Will play video track 2.
Detected file format: Matroska
Load subtitles in videos/[H-S] GoGoV 1-5/
[ass] auto-open
Selected video codec: H.264 / AVC / MPEG-4 AVC / MPEG-4 part 10 [libavcodec]
Selected audio codec: AAC (Advanced Audio Coding) [libavcodec]
AUDIO: 48000 Hz, 2 ch, s16le, 128.0 kbit/8.33% (ratio: 16000->192000)
AO: [alsa] 48000Hz 2ch s16le (2 bytes per sample)
Starting playback...
VIDEO:  640x480  23.976 fps    0.0 kbps ( 0.0 kB/s)
VO: [xv] 640x480 => 640x480 Planar YV12  [fs]
A:  49.4 V:  48.9 A-V:  0.505 ct:  0.005   0/  0 38% 16%  1.1% 50 0 


           ************************************************
           **** Your system is too SLOW to play this!  ****
           ************************************************

Possible reasons, problems, workarounds:
- Most common: broken/buggy _audio_ driver
  - Try -ao sdl or use the OSS emulation of ALSA.
  - Experiment with different values for -autosync, 30 is a good start.
- Slow video output
  - Try a different -vo driver (-vo help for a list) or try -framedrop!
- Slow CPU
  - Don't try to play a big DVD/DivX on a slow CPU! Try some of the lavdopts,
    e.g. -vfm ffmpeg -lavdopts lowres=1:fast:skiploopfilter=all.
- Broken file
  - Try various combinations of -nobps -ni -forceidx -mc 0.
- Slow media (NFS/SMB mounts, DVD, VCD etc)
  - Try -cache 8192.
- Are you using -cache to play a non-interleaved AVI file?
  - Try -nocache.
Read DOCS/HTML/en/video.html for tuning/speedup tips.
If none of this helps you, read DOCS/HTML/en/bugreports.html.

Right now my mplayer config file looks like this...

ao             = alsa
vo             = xv

lavdopts       = lowres=1:fast:skiploopfilter=all

double         = yes
monitoraspect  = 16:9
framedrop      = 1
hardframedrop  = 0

autoq          = 100
autosync       = 30

Here's my /proc/cpuinfo...

processor    : 0
vendor_id    : GenuineIntel
cpu family    : 6
model        : 9
model name    : Intel(R) Pentium(R) M processor 1500MHz
stepping    : 5
microcode    : 0x5
cpu MHz        : 600.000
cache size    : 1024 KB
fdiv_bug    : no
hlt_bug        : no
f00f_bug    : no
coma_bug    : no
fpu        : yes
fpu_exception    : yes
cpuid level    : 2
wp        : yes
flags        : fpu vme de pse tsc msr mce cx8 sep mtrr pge mca cmov clflush dts acpi mmx fxsr sse sse2 tm pbe up bts est tm2
bogomips    : 1196.07
clflush size    : 64
cache_alignment    : 64
address sizes    : 32 bits physical, 32 bits virtual
power management:

My main priority here is getting it so the audio and video stays in sync...I'm willing to sacrifice quality to fix this problem.  Any help would be highly appreciated.

Last edited by rzrscm (2012-11-24 08:19:19)

Offline

#2 2012-11-24 22:16:43

brebs
Member
Registered: 2007-04-03
Posts: 3,443

Re: Video slowdown followed by out-of-sync audio on Mplayer

I'd suggest recompiling mpg123 *without* --enable-int-quality

See if it makes a difference?

Offline

#3 2012-11-25 05:57:37

rzrscm
Member
Registered: 2012-11-17
Posts: 86

Re: Video slowdown followed by out-of-sync audio on Mplayer

brebs wrote:

I'd suggest recompiling mpg123 *without* --enable-int-quality

See if it makes a difference?

That seems to have possibly made a little bit of a difference...In the tests I did the audio stayed in sync, but it still slowed down (and sped up, assumingly to get the video/audio sync back on track) and I still got the "system too slow" message.

I've also noticed that there's a problem with the cache...I don't know if that could be contributing to the problem or not...

Cache fill:  0.00% (0 bytes)   

[mkv] Track ID 1: video (V_MPEG4/ISO/AVC), -vid 0
[mkv] Track ID 2: audio (A_AAC), -aid 0, -alang jpn
[mkv] Track ID 3: subtitles (S_TEXT/ASS), -sid 0, -slang und
[mkv] Will play video track 1.
Detected file format: Matroska
Load subtitles in .
Cache not responding!

I have the following in  my config file...

cache          = 8192
cache-min      = 20.0
cache-seek-min = 50

Offline

#4 2012-11-25 11:03:49

brebs
Member
Registered: 2007-04-03
Posts: 3,443

Re: Video slowdown followed by out-of-sync audio on Mplayer

Also, from wiki:

[[ -e /proc/sys/dev/hpet ]] && echo 1024 > /proc/sys/dev/hpet/max-user-freq
[[ -e /sys/class/rtc/rtc0/max_user_freq ]] && echo 1024 > /sys/class/rtc/rtc0/max_user_freq

Offline

#5 2012-11-25 11:58:30

rzrscm
Member
Registered: 2012-11-17
Posts: 86

Re: Video slowdown followed by out-of-sync audio on Mplayer

brebs wrote:

Also, from wiki:

[[ -e /proc/sys/dev/hpet ]] && echo 1024 > /proc/sys/dev/hpet/max-user-freq
[[ -e /sys/class/rtc/rtc0/max_user_freq ]] && echo 1024 > /sys/class/rtc/rtc0/max_user_freq

I think adding this did the trick...I still get the slow system message, but not as frequently with the videos I tested, and I don't see any noticable slowdowns so far even when the message shows up.  Thank you for your help and pointing me in the right direction.

Offline

#6 2012-11-25 12:15:10

Gusar
Member
Registered: 2009-08-25
Posts: 3,466

Re: Video slowdown followed by out-of-sync audio on Mplayer

Does the config file support spaces around '='? I don't think so, though I'm not completely sure. In any case, try removing them and see if cache works then.

Offline

#7 2012-11-26 00:42:47

rzrscm
Member
Registered: 2012-11-17
Posts: 86

Re: Video slowdown followed by out-of-sync audio on Mplayer

Gusar wrote:

Does the config file support spaces around '='? I don't think so, though I'm not completely sure. In any case, try removing them and see if cache works then.

Other settings in my config work just fine with the spaces, but I'll try it and see what happens.

[update] Yeah, didn't make a difference...I also tried raising the cache size and setting cache-min to 50, and that didn't help either.

[update 2]  I decided to set my cache to 252144 with cache-min set to 50, and it started filling...But it still showed that the cache wasn't responding. [edited because I'm an idiot]

Last edited by rzrscm (2012-11-26 01:06:06)

Offline

#8 2012-11-30 02:09:29

rzrscm
Member
Registered: 2012-11-17
Posts: 86

Re: Video slowdown followed by out-of-sync audio on Mplayer

Is there a way I can better optimize CPU usage for mplayer?  I was monitoring mplayer with htop while playing a video, and it'll use an average of 30% CPU, but it'll spike to almost 100% and that's when the slow system message occurs.  I've tried playing around with nice values and that doesn't seem to help.

Offline

Board footer

Powered by FluxBB