You are not logged in.

#1 2012-11-25 15:36:49

AlmostSurelyRob
Member
From: UK
Registered: 2012-03-17
Posts: 47

paraview - segmentation fault

Dear All,

on one of my recent upgrades I run into a problem. Paraview 3.14 from community repository (link here) is no longer executing. It gives a segmentation fault. No other inforomation is given and to be honest I do not know how to debug this problem further. I am currently attempting to compile it from sources but this will take me a while.

I would be obliged for advice.

Offline

#2 2012-11-25 16:00:06

alevinearch
Member
Registered: 2012-11-24
Posts: 26

Re: paraview - segmentation fault

When you installed this software, did you install from AUR or [community]?


Arch vs Ubuntu; User friendly or user centric?

Offline

#3 2012-11-25 16:02:21

alevinearch
Member
Registered: 2012-11-24
Posts: 26

Re: paraview - segmentation fault

When you mean "installing from source", do you mean AUR , makepkg, and pacman -U, a tool like yaourt, or the standard ./configure make make install? Do you have the base-devel part of the Arch system installed?


Arch vs Ubuntu; User friendly or user centric?

Offline

#4 2012-11-25 16:17:03

AlmostSurelyRob
Member
From: UK
Registered: 2012-03-17
Posts: 47

Re: paraview - segmentation fault

I should have been more explicit, sorry.

Originally the package was installed from community. As far as I know it doesn't exist on AUR anyway. It is this package that is causing problems.

When I said I am attempting to compile I meant downloading the code directly from ParaView git repositores (link here). They also have a nice step by step tutorial over here. It uses cmake + Qt libraries. I am compiling it now but it's a lengthy process on my computer (30%). Also I should note there is a version mismatch between the two.

Last edited by AlmostSurelyRob (2012-11-25 16:17:48)

Offline

#5 2012-11-25 16:23:32

alevinearch
Member
Registered: 2012-11-24
Posts: 26

Re: paraview - segmentation fault

No offense. but you are wrong on that one. the [community] repo is the most popular packages from AUR, maintained by TUs. What stage of the build process are you currently at?


Arch vs Ubuntu; User friendly or user centric?

Offline

#6 2012-11-25 16:30:15

AlmostSurelyRob
Member
From: UK
Registered: 2012-03-17
Posts: 47

Re: paraview - segmentation fault

Oh, don't worry - I don't take offence easily. ;-) In any case, please check it for yourself. On AUR I found only ParaView documentation package which seems to be a colleciton of html files. Maybe it's there under a different name... but I really did try a couple of search terms.

It's still building object files 48%.

Offline

#7 2012-11-25 17:37:39

AlmostSurelyRob
Member
From: UK
Registered: 2012-03-17
Posts: 47

Re: paraview - segmentation fault

For now I can report that the version compiled from git repositories works fine. Is this a case where I should send a request to update the package? The current version is 3.98 and the one in [community] is 3.14.

Offline

#8 2012-11-29 11:47:54

vanja_z
Member
Registered: 2012-04-11
Posts: 32

Re: paraview - segmentation fault

I have 3 machines running arch and paraview and as of Monday 26/11/2012 paraview is segmentation faulting on one of them. It is very strange that paraview still works fine on the other 2 machines? I should add that both 3.14 and 3.98 binaries from paraview.org work just fine.

Offline

#9 2012-11-29 15:35:41

vanja_z
Member
Registered: 2012-04-11
Posts: 32

Re: paraview - segmentation fault

OK, I've narrowed down the problem to the proprietary nvidia drivers. If I downgrade the following packages,
nvidia (310.19-2 -> 304.64-1)
nvidia-utils (310.19-1 -> 304.64-1)
then paraview works fine again. It seems strange that the binaries from paraview.org are unaffected by this problem and that I have another computer working with the 310 driver. The only difference between the two computers that seems relevant is that the working computer has a GTX580 while the problematic one has a 9600GSO. My third computer has intel graphics and works fine.
The workaround is to downgrade the packages

pacman -Udd /var/cache/pacman/pkg/nvidia-304.64-1-x86_64.pkg.tar.xz
pacman -Udd /var/cache/pacman/pkg/nvidia-utils-304.64-1-x86_64.pkg.tar.xz

and then to prevent them from being updated for the time being, add this line to /etc/pacman.conf

IgnorePkg   = nvidia nvidia-utils

Does anyone know why this is happening?

Offline

#10 2012-12-03 16:06:31

gregorburger
Member
From: Innsbruck, Tirol, Austria
Registered: 2009-10-12
Posts: 5

Re: paraview - segmentation fault

It seems your not alone! I first thought it was some old config files because i migrated a home dir.

Offline

#11 2012-12-03 16:11:44

gregorburger
Member
From: Innsbruck, Tirol, Austria
Registered: 2009-10-12
Posts: 5

Re: paraview - segmentation fault

Oddly enough it works under strace, so no way to debug the crash with strace.

Offline

#12 2013-01-11 22:45:50

lazork
Member
Registered: 2008-11-12
Posts: 25

Re: paraview - segmentation fault

I'm having the same problem.
It runs just fine if launched through gdb or strace and I can confirm that the binaries downloaded from the official site work fine as well.
Both version 3.14 and the latest 3.98 behave the same.

vanja_z wrote:

OK, I've narrowed down the problem to the proprietary nvidia drivers.

Out of curiosity, how did you manage to narrow it down to the nvidia drivers?
Seems reasonable anyway, since both the systems I've tested it on are using the official nvidia drivers, and both give segfaults.

Offline

#13 2013-01-17 19:47:30

coincoin
Member
Registered: 2013-01-12
Posts: 4

Re: paraview - segmentation fault

Hello all

I am reporting this problem too. I have paraview installed on two laptops. One has Nouveau driver and Paraview is working fine.
An other one has Nvidia driver giving a seg fault (it runs fine with gdb).

Offline

#14 2013-01-20 02:46:40

jonasdias
Member
Registered: 2013-01-20
Posts: 1

Re: paraview - segmentation fault

Hi, I am having the same problem. I am using the 3.10.19 nvidia driver on 3 DELL workstations with nVidia Quadro 6000. One machine has a single videocard, and the other two have two videocards. They are all running fc17 with mostly the same configuration. The machines with 2 videocards are using the Mosaic option of the nvidia driver to handle 4 monitors while the machine with a single videocard is using a simpler configuration to handle 2 monitors. Using nouveau, Paraview and another PyQt+OpenGL application used to work. However, I needed to move to nvidia proprietary driver because nouveau/Xserver/gdm could not handle 2 videocards and 4 monitors very well (at least in fc17). In the machine with a single videocard, things are working perfectly. However, on the machines with 2 videocards, I am facing a Segmenattion Fault (Core Dumped) error like the following:

$ pvserver
[node3:35659] *** Process received signal ***
[node3:35659] Signal: Segmentation fault (11)
[node3:35659] Signal code: Address not mapped (1)
[node3:35659] Failing at address: (nil)
[node3:35659] [ 0] /lib64/libc.so.6(+0x359b0) [0x7f747f6239b0]
[node3:35659] [ 1] /lib64/libc.so.6(+0x12ea3a) [0x7f747f71ca3a]
[node3:35659] [ 2] /lib64/libGL.so.1() [0x358e2aa926]
[node3:35659] *** End of error message ***
Segmentation Fault (Core Dumped)

I turned the Mosaic option On in the machine with a single videocard to check if it was the problem, but Paraview still works. So I have one machine working and two others, which the system is practically the same, not working. They are all using the same package versions, all freshly updated. I really do not wish to downgrade nvidia driver if there is another solution. Any ideas?

Thanks everybody

P.S.: I have just seen that this is a archlinux forum and I just posted the error I am having in fc17. Sorry about that. But since the error seems to be the same (I was googling about it and found the discussion), we may probably help ourselves. Sorry if this is incovenient.

Last edited by jonasdias (2013-01-20 02:51:31)

Offline

#15 2013-01-26 22:44:26

lazork
Member
Registered: 2008-11-12
Posts: 25

Re: paraview - segmentation fault

This problem seems to be solved with the latest nvidia drivers (313.18)

Offline

Board footer

Powered by FluxBB