You are not logged in.

#1 2012-11-25 21:42:10

orschiro
Member
Registered: 2009-06-04
Posts: 2,136
Website

[solved] Gnome set Evince as default PDF

Hello,

I wonder why I cannot select Evince as my default PDF viewer. The default application window simply does not let me choose Evince.

Screenshot: https://dl.dropbox.com/u/8902804/Screen … viewer.png

Any ideas what to do alternatively?

Thanks!

Last edited by orschiro (2012-11-26 05:53:37)

Offline

#2 2012-11-25 22:12:26

lucke
Member
From: Poland
Registered: 2004-11-30
Posts: 4,018

Re: [solved] Gnome set Evince as default PDF

See if perhaps setting NoDisplay to false in /usr/share/applications/evince.desktop changes anything.

Offline

#3 2012-11-25 22:28:23

diiis
Member
Registered: 2012-06-06
Posts: 33

Re: [solved] Gnome set Evince as default PDF

You can try

mimeopen -d <filename>

It might even work with nautilus.

Offline

#4 2012-11-26 00:59:43

mundigranja
Member
From: Galicia
Registered: 2010-09-18
Posts: 23

Re: [solved] Gnome set Evince as default PDF

Try this:

xdg-mime default evince.desktop application/pdf

Offline

#5 2012-11-26 05:57:06

orschiro
Member
Registered: 2009-06-04
Posts: 2,136
Website

Re: [solved] Gnome set Evince as default PDF

Thanks guys,

mundigranja's solution worked out. I was aware of the xdg way but I really wondered why this cannot be accomplished with Gnome on-board settings.

Regards

Offline

#6 2013-02-13 19:27:24

wombat23
Member
Registered: 2011-01-14
Posts: 45

Re: [solved] Gnome set Evince as default PDF

I'm sorry I'm digging up this old post. I just had the same problem as the OP, after I had installed Inkscape.

xdg-mime default evince.desktop application/pdf

solved the problem for me. I wonder if there is a bug to file, though? does evince register itself not properly as a PDF viewer within GNOME or does Inkscape somehow overwrite this?

Offline

#7 2013-02-14 07:01:33

nickread
Member
Registered: 2012-03-23
Posts: 1

Re: [solved] Gnome set Evince as default PDF

wombat23 wrote:

I wonder if there is a bug to file, though? does evince register itself not properly as a PDF viewer within GNOME or does Inkscape somehow overwrite this?

There's already a bunch of bugs about this filed against most distros. Previously it was just an issue with it not displaying in the application menus, but I think a recent Gnome Shell version (3.4/3.6?) is also now respecting NoDisplay in the Open With / Default application list.  I didn't have this problem on my previous Arch install from about 18 months ago up until two weeks ago - Evince was always the default app for opening PDFs - but with my shiny two-week-old Arch install it was a problem.

That said, using xdg-mime is the cross-desktop way of doing this at least.

Offline

Board footer

Powered by FluxBB