You are not logged in.

#1 2012-11-18 21:07:46

DanB91
Member
Registered: 2012-11-05
Posts: 6

[SOLVED] dolphin-emu doesn't build

I am trying to install dolphin-emu from AUR and when I do, it fails to build and I get the error message:

CMake Error at CMakeLists.txt:235 (message):
  GLU is required but not found

Note: It does find libGL.so

I tried manually cloning the git repo and I get the same error when trying to build it.

I have spend hours searching Google to no avail.  I have freeglut, nvidia-utils, etc all installed.  I found a fix for Ubuntu which was to install the freeglut3-dev package, but that doesn't seem to exist on Arch (or maybe it is just installed with freeglut?)

Any ideas?  Thanks!

Last edited by DanB91 (2012-11-26 14:31:44)

Offline

#2 2012-11-18 22:14:47

Pajaro
Member
Registered: 2004-04-21
Posts: 875

Re: [SOLVED] dolphin-emu doesn't build

they seem to say here that you have to set OPENGL_INCLUDE_DIR

http://code.google.com/p/dolphin-emu/wiki/Linux_Build

Offline

#3 2012-11-19 00:43:51

DanB91
Member
Registered: 2012-11-05
Posts: 6

Re: [SOLVED] dolphin-emu doesn't build

Pajaro wrote:

they seem to say here that you have to set OPENGL_INCLUDE_DIR

http://code.google.com/p/dolphin-emu/wiki/Linux_Build

Thanks for the reply!  The comment you seem to be referring to doesn't seem to be the problem, though.  CMake can find the OpenGL directory and the OpenGL library (libGL.so).

Last edited by DanB91 (2012-11-19 00:47:49)

Offline

#4 2012-11-25 06:43:37

DanB91
Member
Registered: 2012-11-05
Posts: 6

Re: [SOLVED] dolphin-emu doesn't build

bump

Offline

#5 2012-11-25 07:12:02

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: [SOLVED] dolphin-emu doesn't build

https://wiki.archlinux.org/index.php/Fo … te#Bumping

I actually am now not going to read the thread because this bothers me.

Offline

#6 2012-11-26 14:31:32

DanB91
Member
Registered: 2012-11-05
Posts: 6

Re: [SOLVED] dolphin-emu doesn't build

I apologize for not following this forum's rules.  Thanks for letting me know.  I was able to solve the problem by simply reinstalling libglu again.

Offline

Board footer

Powered by FluxBB