You are not logged in.

#1 2012-11-26 02:04:03

toadicus
Member
Registered: 2012-03-13
Posts: 7

GDM Password Prompt Does Not Appear

Alternate Title: systemctl: No space left on device.

I'll preface this by saying that GDM never has any trouble starting; this doesn't seem like the same issue as threads like this one.  But when trying to log in, after picking a user or typing in a username and pressing enter... nothing happens.  The password prompt never appears.  If I've clicked a user in the chooser, it will time out and go back to the chooser after a minute or so.

Whenever I start or stop GDM with systemctl, I get:

Error: No space left on device

This wouldn't be too bad, if GDM worked consistently (it happens with almost any systemctl action).   Output from systemctl status is below.

# systemctl status gdm
gdm.service - GNOME Display Manager
	  Loaded: loaded (/usr/lib/systemd/system/gdm.service; enabled)
	  Active: active (running) since Sun, 2012-11-25 17:35:13 PST; 1min 9s ago
	Main PID: 1005 (gdm-binary)
	  CGroup: name=systemd:/system/gdm.service
		  ├ 1005 /usr/sbin/gdm-binary
		  ├ 1009 /usr/lib/gdm/gdm-simple-slave --display-id /org/gnome/DisplayManager/Displays/_0
		  ├ 1012 /usr/bin/Xorg :0 -background none -verbose -auth /var/run/gdm/auth-for-gdm-1wTZMv/database -seat seat0 -nolisten tcp vt1
		  └ 1024 gdm-session-worker [pam/gdm-launch-environment]

Nov 25 17:35:13 saya systemd[1]: Starting GNOME Display Manager...
Nov 25 17:35:13 saya systemd[1]: Started GNOME Display Manager.
Nov 25 17:35:14 saya gdm-simple-slave[1009]: WARNING: Failed to give slave programs access to the display. Trying to proceed.
Nov 25 17:35:22 saya gdm-password][1098]: AccountsService-WARNING: Failed to monitor logind session changes: No space left on device

Also, certainly nothing is out of space:

$ df
Filesystem            1K-blocks      Used Available Use% Mounted on
rootfs                 15378832   8192380   6405248  57% /
dev                     4054552         0   4054552   0% /dev
run                     4090384       652   4089732   1% /run
/dev/sda1              15378832   8192380   6405248  57% /
tmpfs                   4090384       496   4089888   1% /dev/shm
tmpfs                   4090384         0   4090384   0% /sys/fs/cgroup
tmpfs                   4090384       264   4090120   1% /tmp
/dev/sda3              70345220  45409040  24936180  65% /mnt/games-ssd
/dev/mapper/vg0-var    82569904   6368676  72006924   9% /var
/dev/mapper/vg0-home  240361984 219289656   8862564  97% /home
/dev/sdc2             208063156 151132036  46445368  77% /mnt/games

The kicker is that sometimes, it works just fine for no apparent reason.  Any
ideas?

TIA

Offline

#2 2012-11-26 21:24:58

beaverusiv
Member
From: Taupo, New Zealand
Registered: 2011-07-09
Posts: 38

Re: GDM Password Prompt Does Not Appear

/home looks pretty full to me.

Offline

#3 2012-11-29 05:37:16

toadicus
Member
Registered: 2012-03-13
Posts: 7

Re: GDM Password Prompt Does Not Appear

Sure, 97% is fairly full, but it's got 8.5 GB free and is not low on inodes.  It shouldn't be returning a no space error.

Offline

#4 2012-11-29 11:10:19

ijanos
Member
From: Budapest, Hungary
Registered: 2008-03-30
Posts: 440

Offline

#5 2012-11-29 19:29:07

beaverusiv
Member
From: Taupo, New Zealand
Registered: 2011-07-09
Posts: 38

Re: GDM Password Prompt Does Not Appear

toadicus wrote:

Sure, 97% is fairly full, but it's got 8.5 GB free and is not low on inodes.  It shouldn't be returning a no space error.

Sorry, read it as 8MB free.

Offline

#6 2013-09-20 18:43:45

OssiL
Member
Registered: 2013-09-20
Posts: 10

Re: GDM Password Prompt Does Not Appear

heh, almost an year has passed and this is still happening with up to date Arch:

Sep 20 08:19:51 arssi gdm[194]: AccountsService: Failed to monitor logind session changes: No space left on device

Not good.

Since I'm new to Arch, should I post this to upstream or what? smile

Offline

#7 2013-09-20 18:51:41

karol
Archivist
Registered: 2009-05-06
Posts: 25,427

Re: GDM Password Prompt Does Not Appear

Offline

#8 2013-09-22 07:18:51

OssiL
Member
Registered: 2013-09-20
Posts: 10

Re: GDM Password Prompt Does Not Appear

[root@arssi gdm]# df -h
Filesystem      Size  Used Avail Use% Mounted on
/dev/sda1        28G   12G   15G  43% /
dev             2.0G     0  2.0G   0% /dev
run             2.0G  828K  2.0G   1% /run
tmpfs           2.0G  760K  2.0G   1% /dev/shm
tmpfs           2.0G     0  2.0G   0% /sys/fs/cgroup
tmpfs           2.0G  528K  2.0G   1% /tmp
/dev/sda6       304G  208G   81G  72% /home

And inodes:
[root@arssi gdm]# df -i
Filesystem       Inodes  IUsed    IFree IUse% Mounted on
/dev/sda1       1831424 219187  1612237   12% /
dev              505819    400   505419    1% /dev
run              506514    468   506046    1% /run
tmpfs            506514     15   506499    1% /dev/shm
tmpfs            506514     11   506503    1% /sys/fs/cgroup
tmpfs            506514     35   506479    1% /tmp
/dev/sda6      20209664 166212 20043452    1% /home

And btw, this doesn't happen every time.
Usually a reboot or two is enough.
It also may happen during session, if system has been idle for awhile (this hasn't happenned yet to me but for somebody else using this PC).

Last edited by OssiL (2013-09-22 07:27:45)

Offline

#9 2013-09-22 07:56:31

OssiL
Member
Registered: 2013-09-20
Posts: 10

Re: GDM Password Prompt Does Not Appear

And here is what happens:

Sep 22 09:42:07 arssi gdm[196]: AccountsService: Failed to monitor logind session changes: No space left on device
Sep 22 09:42:32 arssi gnome-session[318]: JS ERROR: !!!   Failed to start verification for user
Sep 22 09:42:32 arssi gnome-session[318]: JS ERROR: !!!     message = '"Timeout was reached"'
Sep 22 09:42:32 arssi gnome-session[318]: JS ERROR: !!!     fileName = '"/usr/share/gnome-shell/js/gdm/util.js"'
Sep 22 09:42:32 arssi gnome-session[318]: JS ERROR: !!!     lineNumber = '308'
Sep 22 09:42:32 arssi gnome-session[318]: JS ERROR: !!!     stack = '"0 anonymous()@/usr/share/gnome-shell/js/gdm/util.js:308
Sep 22 09:42:32 arssi gnome-session[318]: "'

ossi@arssi:~$ pacman -Q gdm
gdm 3.8.4-1

Offline

#10 2013-09-24 11:27:35

OssiL
Member
Registered: 2013-09-20
Posts: 10

Re: GDM Password Prompt Does Not Appear

I filed a bug report: https://bugzilla.gnome.org/show_bug.cgi?id=708670
Let's see how it goes.

Offline

#11 2013-09-25 20:38:33

thirdeye42
Member
Registered: 2013-09-25
Posts: 1

Re: GDM Password Prompt Does Not Appear

I don't run Arch, but had this same problem on a new Gentoo system with systemd and Gnome 3.8.  I figured out what was causing it for me.  I use Crashplan as a backup service and I forgot to increase the number of inotify watches in the kernel.  Crashplan uses them all up if they are left at the default of 8192.  Maybe all of your inotify watches are being used up.

I set this in /etc/sysctl.conf

fs.inotify.max_user_watches=1048576

and then reboot or you can just test it out temporarily with:

echo 1048576 > /proc/sys/fs/inotify/max_user_watches

I use 1048576 because that was the number recommended by Crashplan and it works for me.

Offline

#12 2013-09-30 17:09:50

OssiL
Member
Registered: 2013-09-20
Posts: 10

Re: GDM Password Prompt Does Not Appear

Thanks, thirdeye42!
Yes, indeed /etc/sysctl.conf was deprecated and I also use Crashplan.
After suggested steps for that file those issues are gone.
Should have remembered that Crashplan setting when I did update...

Offline

#13 2013-11-05 21:37:24

Siftah
Member
Registered: 2013-11-05
Posts: 1

Re: GDM Password Prompt Does Not Appear

thirdeye42 wrote:

I don't run Arch, but had this same problem on a new Gentoo system with systemd and Gnome 3.8.  I figured out what was causing it for me.  I use Crashplan as a backup service and I forgot to increase the number of inotify watches in the kernel.  Crashplan uses them all up if they are left at the default of 8192.  Maybe all of your inotify watches are being used up.

I set this in /etc/sysctl.conf

fs.inotify.max_user_watches=1048576

and then reboot or you can just test it out temporarily with:

echo 1048576 > /proc/sys/fs/inotify/max_user_watches

I use 1048576 because that was the number recommended by Crashplan and it works for me.

Thanks thirdeye42, this solved my issue with GDM on Fedora Core 19, I registered just to say thanks smile

(I'm also using CrashPlan)

Offline

Board footer

Powered by FluxBB