You are not logged in.

#1 2012-11-26 20:54:17

doug piston
Member
From: Seattle
Registered: 2011-09-11
Posts: 387
Website

[Solved] Conky displaying incorrect font (Using dzen2 and DWM)

I am attempting to us 'ohsnap' as a font in my conky config but I appear to be missing something, It works just fine within my  DWM config but not conky. I believe I have it setup correctly but will post specifics. If more info is needed please let me know.

DWM's config.h (The font portion)

/* See LICENSE file for copyright and license details. */

/* appearance */
static const char font[] = "-*-ohsnap-medium-*-normal-*-12-*-*-*-*-*-iso8859-*";
#define NUMCOLORS 13

How I start it(~/.xinitrc)

... snippet
# Test dzen2 and conky
(sleep 3s && conky | dzen2 -x '1000' -e '' -fg '#81a2be' -bg '#1d1f21' -w '800' -h '13' -ta r -fn "-*-ohsnap-medium-*-normal-*-12-*-*-*-*-*-iso8859-*" -p ) &

# add font paths
xset fp default
[[ -d /usr/share/fonts/local ]] && xset +fp /usr/share/fonts/local
[[ -d $HOME/.fonts ]] && xset +fp $HOME/.fonts
xset fp rehash

# Start WM
exec /home/jarvis/bin/dwm-start

Conky itself

background no
out_to_x no
out_to_console yes
update_interval 1
total_run_times 0
use_spacer none
double_buffer yes


TEXT
^i(/home/jarvis/.config/icons/cpu.xbm) ^fg(\#b3b3b3)${loadavg}^fg() \
^i(/home/jarvis/.config/icons/mem.xbm) ^fg(\#b3b3b3)${memperc}%^fg() \
^i(/home/jarvis/.config/icons/bat_full_01.xbm) ^fg(\#b3b3b3)${if_existing /sys/class/power_supply/AC0/online1}Ac${else}${battery_percent}%${endif}^fg() \
^i(/home/jarvis/.config/icons/wifi_01.xbm) ^fg(\#b3b3b3)${if_up wlan0}ON${else}NO${endif}^fg() \
^i(/home/jarvis/.config/icons/clock.xbm) ^fg(\#b3b3b3)${time %H:%M}^fg()

ohsnap is in my /usr/share/fonts/local (I installed it from the AUR)

[~] : ls /usr/share/fonts/local/
fonts.dir              ohsnap6x11b.pcf        ohsnap6x13b.icons.pcf  ohsnap6x13r.pcf        ohsnap7x12r.icons.pcf  ohsnap7x14b.pcf        ohsnapu6x11b.pcf  ohsnapu6x13r.pcf  ohsnapu7x14b.pcf
fonts.scale            ohsnap6x11r.icons.pcf  ohsnap6x13b.pcf        ohsnap7x12b.icons.pcf  ohsnap7x12r.pcf        ohsnap7x14r.icons.pcf  ohsnapu6x11r.pcf  ohsnapu7x12b.pcf  ohsnapu7x14r.pcf
ohsnap6x11b.icons.pcf  ohsnap6x11r.pcf        ohsnap6x13r.icons.pcf  ohsnap7x12b.pcf        ohsnap7x14b.icons.pcf  ohsnap7x14r.pcf        ohsnapu6x13b.pcf  ohsnapu7x12r.pcf

And finally a screenshot of the issue, I really don't know what font it is using... sad
tZ2dteQ

Cheers.


Edit.

Solved, see post 8.

Last edited by doug piston (2012-11-28 01:57:40)

Offline

#2 2012-11-27 01:08:11

doug piston
Member
From: Seattle
Registered: 2011-09-11
Posts: 387
Website

Re: [Solved] Conky displaying incorrect font (Using dzen2 and DWM)

Could it be that xorg is not loading my /user/share/fonts/local dir? I do not have an xorg.conf file, is it ok to create one and specify only the font path within it?



I ran 'cat /var/log/Xorg.0.log'

[    10.280]    Entry deleted from font path.
[    10.280] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[    10.280]    Entry deleted from font path.
[    10.280]    (Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[    10.280] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[    10.280]    Entry deleted from font path.
[    10.281]    (Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[    10.280]    (Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[    10.280] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[    10.280]    Entry deleted from font path.
[    10.281]    (Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[    10.281] (==) FontPath set to:
        /usr/share/fonts/misc/,
        /usr/share/fonts/TTF/,
        /usr/share/fonts/Type1/

Also dosen't show up with '$ fc-list : file' command but oddly I see it in

[~] : xset q
Keyboard Control:
  auto repeat:  on    key click percent:  0    LED mask:  00000002
  XKB indicators:
    00: Caps Lock:   off    01: Num Lock:    on     02: Scroll Lock: off
    03: Compose:     off    04: Kana:        off    05: Sleep:       off
    06: Suspend:     off    07: Mute:        off    08: Misc:        off
    09: Mail:        off    10: Charging:    off    11: Shift Lock:  off
    12: Group 2:     off    13: Mouse Keys:  off
  auto repeat delay:  660    repeat rate:  25
  auto repeating keys:  00ffffffdffffbbf
                        fadfffefffedffff
                        9fffffffffffffff
                        fff7ffffffffffff
  bell percent:  50    bell pitch:  400    bell duration:  100
Pointer Control:
  acceleration:  2/1    threshold:  4
Screen Saver:
  prefer blanking:  yes    allow exposures:  yes
  timeout:  600    cycle:  600
Colors:
  default colormap:  0x20    BlackPixel:  0x0    WhitePixel:  0xffffff
Font Path:
  /usr/share/fonts/local,/usr/share/fonts/misc/,/usr/share/fonts/TTF/,/usr/share/fonts/Type1/,built-ins
DPMS (Energy Star):
  Standby: 600    Suspend: 600    Off: 600
  DPMS is Enabled
  Monitor is On

Offline

#3 2012-11-27 09:24:44

moetunes
Member
From: A comfortable couch
Registered: 2010-10-09
Posts: 1,019

Re: [Solved] Conky displaying incorrect font (Using dzen2 and DWM)

To handle fonts in /usr/share/fonts/local I made a 20-fonts.conf file in /etc/X11/xorg.conf.d/ with

Section "Files"
    FontPath  "/usr/share/fonts/local"
EndSection

in it.
HTH


You're just jealous because the voices only talk to me.

Offline

#4 2012-11-27 15:23:21

stlarch
Member
From: hell
Registered: 2010-12-25
Posts: 1,250

Re: [Solved] Conky displaying incorrect font (Using dzen2 and DWM)

I haven't used dzen in a while and forgot what to do. I noticed you have the font in quotes and the rest in single quotes. I don't know if that matters but maybe try putting it in single quotes first? Or try what moetunes said. You can also define the dzen2 font in .Xresources:

dzen2.font:       -*-ohsnap-medium-r-*-*-12-*-*-*-*-*-*-*

.

Offline

#5 2012-11-27 15:39:28

ackt1c
Member
From: Visalia, California
Registered: 2012-10-10
Posts: 215

Re: [Solved] Conky displaying incorrect font (Using dzen2 and DWM)

Offline

#6 2012-11-27 16:12:19

stlarch
Member
From: hell
Registered: 2010-12-25
Posts: 1,250

Re: [Solved] Conky displaying incorrect font (Using dzen2 and DWM)

You can also maybe consider getting rid of dzen2 and just using conky for a little bit lighter of a solution. You can use stlarch_font in the aur for icons. You can define both fonts in your config.h:

static const char font[]            = "-*-stlarch-medium-r-*-*-10-*-*-*-*-*-*-*" "," "-*-ohsnap-medium-r-*-*-12-*-*-*-*-*-*-*";

You can echo the symbol you want to use in a terminal (echo -e '\uE019' for example) and paste it to your .conkyrc (something like this with the statuscolors format):

${execi 1800 echo -e \\x02} ${execi 1800 echo -e \\x01}${time %I:%M}

Last edited by stlarch (2012-11-27 17:27:28)

Offline

#7 2012-11-27 19:04:12

doug piston
Member
From: Seattle
Registered: 2011-09-11
Posts: 387
Website

Re: [Solved] Conky displaying incorrect font (Using dzen2 and DWM)

@stlarch
I tried setting the dzen font in my ~/.Xresources as well and it did not work. I decided to get rid of conky and Dzen in favor of using the default DWM statusbar and writing my own. It does use the correct font and I am selecting the icons in the manner you mentioned in your second post.

@ackt1c
Tried xfontsel and still same result.

@moetunes
I will try your method this evening.

Last edited by doug piston (2012-11-27 19:04:24)

Offline

#8 2012-11-28 01:56:42

doug piston
Member
From: Seattle
Registered: 2011-09-11
Posts: 387
Website

Re: [Solved] Conky displaying incorrect font (Using dzen2 and DWM)

Fixed my issue.

I removed

(sleep 3s && conky | dzen2 -x '1000' -e '' -fg '#81a2be' -bg '#1d1f21' -w '800' -h '13' -ta r -fn "-*-ohsnap-medium-*-normal-*-12-*-*-*-*-*-iso8859-*" -p ) &

and changed it to

# Test new conky
conky | while read -r; do xsetroot -name "$REPLY"; done &

It now respects my chosen font.

Offline

Board footer

Powered by FluxBB