You are not logged in.

#1 2012-11-28 15:26:08

Mocco
Member
Registered: 2012-07-12
Posts: 44

Vaio S13A doesn't work on battery

Hi to all, I'm running archLinux x64 on a brand new Vaio S13A. I switched to systemd and gnome 3.6 some time ago, I'm using my notebook mostly with ac power. The problem is that now I discovered the laptop is not working with battery anymore, if I unplug the cable the notebook shuts down. I don't know why but I think it's a problem with arch since the notebook is brand new.

Also, the led of the battery is always on, like the battery is always charging (???).

acpi -i
Battery 0: Charging, 76%, charging at zero rate - will never fully charge.
Battery 0: design capacity 4417 mAh, last full capacity 4417 mAh = 100%

Offline

#2 2012-11-29 20:42:33

cleberaraujo
Member
Registered: 2012-05-22
Posts: 10

Re: Vaio S13A doesn't work on battery

Hello Mocco,

Since you said your laptop is new, I believe the problem is in your battery. Perhaps there was an error in manufacturing battery.

As the battery is a hardware and ArchLinux is software, it can never be the cause of the problem. To be sure, try booting with a livecd distro and see if the same error happens.

As for the LED battery access is always normal, but it changes color when the battery is 100% charged.

Another error may be some bad contact in the socket of the battery or charger.

Make tests and when you can give us feedback.

Last edited by cleberaraujo (2012-11-29 20:43:39)

Offline

#3 2012-11-30 07:38:39

Mocco
Member
Registered: 2012-07-12
Posts: 44

Re: Vaio S13A doesn't work on battery

cleberaraujo wrote:

Hello Mocco,

Since you said your laptop is new, I believe the problem is in your battery. Perhaps there was an error in manufacturing battery.

I bought the laptop in July and everything just worked fine since now. I don't think there was an error in manufacturing the battery

cleberaraujo wrote:

As the battery is a hardware and ArchLinux is software, it can never be the cause of the problem. To be sure, try booting with a livecd distro and see if the same error happens.

Well, you know there is some relationship with the hardware and software. Just as an example, the laptop can be setted (through windows) to never charge up to 50% or 80% to extend battery's life (that's probably why acpi says it will never fully charge). In my case, I think it's not charging the battery at all, even if the led is red.

However, you're right, I should check with a livecd and let you know.


cleberaraujo wrote:

As for the LED battery access is always normal, but it changes color when the battery is 100% charged.

No. I know this notebook and when it reaches 80% the led shuts off. It has been doing like that since now.

cleberaraujo wrote:

Another error may be some bad contact in the socket of the battery or charger.

Make tests and when you can give us feedback.

It might be, I'll make tests and let you know.

Thank you for your help.

Offline

#4 2012-12-08 12:56:02

Mocco
Member
Registered: 2012-07-12
Posts: 44

Re: Vaio S13A doesn't work on battery

So, just to say, the problem was an harware problem, maybe with the connectors of the battery because I removed it and then putted it in again and now it's working.

I still don't know a method to modify the hw switch in order to tell to my battery to stop charging whe it reaches 50% or 80% but you know, I'll survive. smile

Thank you for your help.

Offline

Board footer

Powered by FluxBB