You are not logged in.

#1 2012-11-30 07:52:32

DSpider
Member
From: Romania
Registered: 2009-08-23
Posts: 2,273

[SOLVED] Redshift starts twice & keeps adding to ~/.config/autostart/

This is starting to piss me off... Rebooting the computer will get me a brand new "~/.config/autostart/gtk-redshift.desktop" file, which starts to conflict with the other instance from my autostart file (I'm using Openbox):

gtk-redshift -l 44.42:26.10 -b 1.0 -g 1.0 -t 6500:3800 -m vidmode &

The side effect of having two instances (both showing in the tray) is that the screen starts to flicker, even in broad daylight.

I'm thinking that maybe I should downgrade the redshift package.

Last edited by DSpider (2012-12-05 14:27:25)


"How to Succeed with Linux"

I have made a personal commitment not to reply in topics that start with a lowercase letter. Proper grammar and punctuation is a sign of respect, and if you do not show any, you will NOT receive any help (at least not from me).

Offline

#2 2012-11-30 09:58:58

bergersau
Member
Registered: 2012-01-19
Posts: 48

Re: [SOLVED] Redshift starts twice & keeps adding to ~/.config/autostart/

1: Remove or comment out the gtk-redshift command in ~/.config/openbox/autostart.sh
2: Set up your preferences in ~/.config/redshift.conf
3: Allow ~/.config/autostart/gtk-redshift.desktop to start redshift

That's what I do.

Offline

#3 2012-11-30 12:24:42

stqn
Member
Registered: 2010-03-19
Posts: 1,189
Website

Re: [SOLVED] Redshift starts twice & keeps adding to ~/.config/autostart/

I have redshift 1.7-5 installed and start it from .xinitrc and don’t have this problem, but I’m using Xfce. (I don’t start gtk-redshift but redshift.) No config file.

Offline

#4 2012-11-30 14:08:07

nomorewindows
Member
Registered: 2010-04-03
Posts: 2,978

Re: [SOLVED] Redshift starts twice & keeps adding to ~/.config/autostart/

If it's in your .config file/directory, that is open for whichever DE/WM will pick it up.  Redshift is kinda tricky to get it to behave right.  It needs some way of resetting itself and not reloading itself on the same X window, but if I want to run it on another X window at the same time it has to leave that option open.
How do you set up a redshift.conf file?  I don't see how the configuration file is supposed to be set up.

Last edited by nomorewindows (2012-11-30 14:12:09)


I may have to CONSOLE you about your usage of ridiculously easy graphical interfaces...
Look ma, no mouse.

Offline

#5 2012-12-03 09:24:55

bergersau
Member
Registered: 2012-01-19
Posts: 48

Re: [SOLVED] Redshift starts twice & keeps adding to ~/.config/autostart/

From http://jonls.dk/2010/10/redshift-1-6-released/

CONFIGURATION FILE
Redshift will look for a configuration file in “~/.config/redshift.conf” (or in XDG_CONFIG_HOME if that has been set). A different configuration file can be loaded with the command line option “-c”. Here is an example:

; Global settings
[redshift]
temp-day=5700
temp-night=3500
transition=1
gamma=0.8:0.7:0.8
location-provider=manual
adjustment-method=vidmode

; The location provider and adjustment method settings
; are in their own sections.
[manual]
lat=55.0
lon=12.0

; In this example screen 1 is adjusted by vidmode. Note
; that the numbering starts from 0, so this is actually
; the second screen.
[vidmode]
screen=1

Offline

#6 2012-12-05 14:31:22

DSpider
Member
From: Romania
Registered: 2009-08-23
Posts: 2,273

Re: [SOLVED] Redshift starts twice & keeps adding to ~/.config/autostart/

Thanks. I uncommented the entry from the Openbox autostart file and created a "~/.config/redshift.conf" file:

; Global settings
[redshift]
temp-day=6500
temp-night=3800
transition=1
gamma=1.0
location-provider=manual
adjustment-method=vidmode

; The location provider and adjustment method settings
; are in their own sections.
[manual]
lat=44.42
lon=26.10

; In this example screen 1 is adjusted by vidmode. Note
; that the numbering starts from 0, so this is actually
; the second screen.
[vidmode]
screen=0

Works ok now.

The only thing that bothers me is that even if I right click the tray icon and check or uncheck "Autostart", it still starts automatically from "~/.config/autostart". But that's probably a bug or something. Oh, well... Marking it as solved.

Last edited by DSpider (2012-12-05 14:34:51)


"How to Succeed with Linux"

I have made a personal commitment not to reply in topics that start with a lowercase letter. Proper grammar and punctuation is a sign of respect, and if you do not show any, you will NOT receive any help (at least not from me).

Offline

Board footer

Powered by FluxBB