You are not logged in.

#1 2012-11-30 09:53:16

jolivier
Member
Registered: 2012-05-30
Posts: 17

|SOLVED] Initial start of ArchLinux installation stops on Dell M6500

Hello everybody,

I'm switching my work station to a Dell Precision M6500. So I downloaded the 2012.11.01 installation media, verified checksum, dd it onto a usb key, boot on it and when I choose "Boot Arch Linux (either x86_64 or i686), the starting script stops after either
"Reached target Sound Card" or after "Started Login Service" which are printed in a random order in all startup attempts I made.

- Both these steps are marked as "[OK]".
- I don't see any failure message on any message printed before.
- When I run the Hardware Detection Tools, my sound card is found under the PCI devices as:
  Vendor: Intel Corporation
  Product: 5 Series/3400 Series Chipset High Definition

What else could I test/change to debug/fix this?

Since I need this workstation to be operational today I downloaded an arch linux image before the switch to systemd (this initialisation steps look to be systemd related since I never saw them on my 3 other stations having arch linux and I havent switched yet), and will start the install from this image soon to be able to work.

Regards,

Olivier

Last edited by jolivier (2012-11-30 10:29:28)

Offline

#2 2012-11-30 10:29:07

jolivier
Member
Registered: 2012-05-30
Posts: 17

Re: |SOLVED] Initial start of ArchLinux installation stops on Dell M6500

Ok I found the solution: there is an hardware switch on this laptop for the wireless card. When it is disabling the wireless card this block the step related to network interfaces in the initialisation. This was easier to spot with initscripts since initscripts was blocked in the "Initializing network interfaces step".In my humble opinion it would be great if systemd was displaying like initscripts the step it is trying to achieve since it is a lot easier to diagnose at blocked start this way.
Anyway, marking this as solved smile

Offline

#3 2012-11-30 15:45:43

chris_l
Member
Registered: 2010-12-01
Posts: 387

Re: |SOLVED] Initial start of ArchLinux installation stops on Dell M6500

jolivier wrote:

In my humble opinion it would be great if systemd was displaying like initscripts the step it is trying to achieve since it is a lot easier to diagnose at blocked start this way.

I think you can do that by removing "quiet" from the kernel line on grub


"open source is about choice"
No.
Open source is about opening the source code complying with this conditions, period. The ability to choose among several packages is just a nice side effect.

Offline

Board footer

Powered by FluxBB