You are not logged in.

#1 2012-11-14 08:58:06

calef13
Member
Registered: 2007-06-10
Posts: 117

Sound card conflicts

Hi,

I was having trouble with ALSA not selecting the sound card I wanted as default. After some searching I made a rule file in /etc/modprobe.d. This has been working great for a few weeks but recently about half the time when I boot Arch there are no sound devices and sound doesn't work anymore.

[root@bluenode calef13]# cat /proc/asound/cards  driver uvcvideo
0 [U0x46d0x809    ]: USB-Audio - USB Device 0x46d:0x809
                      USB Device 0x46d:0x809 at usb-0000:00:1d.0-1.2, high speed
[root@bluenode calef13]# aplay -l
**** List of PLAYBACK Hardware Devices ****
[root@bluenode calef13]#

I looked in dmesg and found the following error, which looks related:

[    9.252227] cannot find the slot for index 0 (range 0-0), error: -16
[    9.252359] hda-intel: Error creating card!
[    9.252473] snd_hda_intel: probe of 0000:00:1b.0 failed with error -16
[    9.252478] cannot find the slot for index 0 (range 0-0), error: -16
[    9.252598] hda-intel: Error creating card!
[    9.252711] snd_hda_intel: probe of 0000:01:00.1 failed with error -16
[    9.677196] usbcore: registered new interface driver snd-usb-audio

I googled a bit and found some advice telling me to change my rule file in /etc/modprobe.d/ to this:

alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
options snd-hda-intel id=PCH index=0
alias snd-card-1 snd-usb-audio
alias sound-slot-1 snd-usb-audio
options snd-usb-audio index=1

Before I only had the 3rd line above in the rule file. I'm reluctant to use this though as I got the impression that this rule file should be clear about which card I mean and therefore I shouldn't even have the problem I'm having. Can anyone advise me if I'm doing something wrong? I feel like there should be an easy, standard method for selecting a sound card as a default and ignoring all others, but I can't seem to find it.

Offline

#2 2012-11-15 07:56:58

PReP
Member
From: Sweden/Sala
Registered: 2010-06-13
Posts: 347
Website

Re: Sound card conflicts

For my setup (i have an intel-hda onboard, an nvidia-card-sound-hdmi-thingie, and the usb-headset i plug in at random times when already booted up,
i have a /etc/modprobe.d/sound.conf:

alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel

A difference from yours might be that i only make sure that my intel one is first, and do not mention the second or third one at all in the file.
and that option, have you tried without it (if it really is for your own card), try with only the first too lines perhaps.

What soundcards do you have, and which one do you want first/default?

So it works well here anyways, i perhaps should add.

- Good luck finding a decent solution in any case : )

Last edited by PReP (2012-12-02 20:29:00)


#1 Main: Intel Core i5 2500k (Sandy) @ 3.9 Ghz, 8 GB DDR2-XMP RAM @ 1600 Mhz, Geforce GTX 570 (Gainward Phantom) - Arch Linux 64-Bit
#2 Server: Intel C2D E8400 @ 3.6 Ghz, 3 GB DDR2-RAM @ 802mhz, XFX GF GTX260 XT -ArchLinux 64-bit.

<- Server Homepage: http://prep.mine.nu ->

Offline

#3 2012-12-02 01:39:27

guisacouto
Member
From: Portugal
Registered: 2009-06-27
Posts: 107

Re: Sound card conflicts

I am also experiencing this issue.. the first time it happened I ignored it since I thought my old sound card was just dying..
I have the same errors in dmesg.

Offline

Board footer

Powered by FluxBB