You are not logged in.

#1 2012-12-02 05:26:03

From: San Cristobal,Venezuela
Registered: 2011-02-22
Posts: 132

[SOLVED] ASUS N56VZ FN+FX Keys not working

I got this new laptop some time ago. I had WIndows 8 running on it, but since I need linux for college I decided to install Arch on it. I removed windows and created a new GUID Partition Table on the Hard drive.

sda1 512M EFI Parition
sda2 250G Windows Parition (is not installed yet)
sda3 512M Boot
sda4 30G Root
sda6 8G Swap
sda5 <Rest of space> Home

I've installed Arch_x86-64, with rEFInd as bootloader. I have KDE Running on my machine, everything is working fine except for the FN+FX Keys:

    F1   Sleep
    F2   WIreless ON/OFF
    F3   Keyboard lights intensity down
    F4   Keyboard lights intensity up
    F5   Screen brightness down
    F6   Screen brightness up
    F7   Screen brightness off
    F8   Proyector toggle
    F9   Touchpad ON\OFF
    F10 Volume off
    F11 Volume down
    F12 Volume up

The only keys that works correctly are FN+F{1,2,7,10,11,12}, but some of the most important keys (keyboard lights, screen brigthess) are not working at all.
I need help fixing this, I hope there's a workaround or something.

Edit: Solved the problem following the steps shown in here. I also confirm that the solution provided there works very well on the Asus N56VZ.

Last edited by AurosGamma (2012-12-02 06:00:38)


Board footer

Powered by FluxBB