You are not logged in.

#1 2012-11-30 09:05:35

Tegramon
Member
Registered: 2012-11-30
Posts: 4

VMware and Resolution Problem

Hello

I just installed Archlinux on VMware Workstation 9. I use it mostly for coding yet I encountered a problem that bugs meto hell.
I just plan to work in a console environment. However I have this problem.

In VMware I go to fullscreen and use View->Autostrech Guest.

After the bootup I get this screen. It looks good and I want to continue to code in it.

pic1.jpg

However after several seconds on the bootup the image gets distorted. I can still work on it, but I really hate it. It looks like this:

pic2.jpg

It does not look broken like that, it's just that I captured the moment when the resolution changed. However I want to use still the first resolution which the characters were bigger. My eyes hurt from the second one.
Any ideeas on what to do?

Offline

#2 2012-11-30 12:08:43

Tegramon
Member
Registered: 2012-11-30
Posts: 4

Re: VMware and Resolution Problem

Can anyone help?

Offline

#3 2012-11-30 12:59:20

illusionist
Member
From: localhost
Registered: 2012-04-03
Posts: 498

Re: VMware and Resolution Problem

It is not any resolution problem . The system just loads the proper graphics driver for that resolution. If the font is too small for your eyes you can adjust the font via "vconsole.conf" . See the wiki .


  Never argue with stupid people,They will drag you down to their level and then beat you with experience.--Mark Twain
@github

Offline

#4 2012-12-02 22:04:08

Tegramon
Member
Registered: 2012-11-30
Posts: 4

Re: VMware and Resolution Problem

Where is the vconsole.conf? It is not in /etc.
Can I just disable the driver from loading at all? I don't like it at all.

Offline

#5 2012-12-03 06:06:00

anonymous_user
Member
Registered: 2009-08-28
Posts: 3,058

Re: VMware and Resolution Problem

If vconsole.conf is not there, then just create it. Also if you want some info on setting the font:

https://wiki.archlinux.org/index.php/Fo … fault_font

Last edited by anonymous_user (2012-12-03 06:06:27)

Offline

#6 2012-12-03 06:24:58

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: VMware and Resolution Problem

I would assume you want to do it the wrong way, you could just disable kms.

Offline

#7 2012-12-03 11:17:16

Tegramon
Member
Registered: 2012-11-30
Posts: 4

Re: VMware and Resolution Problem

Ok, I disabled KMS by editing the syslinux.conf using the nomodeset.
However, it is still doing the same thing. Switches the font/resolution. It does appear to switch the resolution though.
Any ideas?

Ok, so what is the default console font of Archlinux? Before the video drivers kick in.

Last edited by Tegramon (2012-12-03 11:40:45)

Offline

Board footer

Powered by FluxBB