You are not logged in.

#1 2012-12-04 18:43:15

GoldenX
Member
Registered: 2012-12-04
Posts: 5

[Solved] Fonts mixing or damaged

Hello eveybody, sorry to ask for help like this.
I'm having a, IMHO, really weird problem with fonts, they suddenly get mixed, for example a "u" get's turned in a "[", or a space turns into a comma, it's totally random, and the mixing changes every reboot. It doesn't happen instantly, now for example is working perfectly.

I'm new with Arch (I'm loving it so far), so I don't know what info give you. The system is up to date, and the problem happens in LXDE and Unity (haven't tested gnome-shell).
Thank you, and sorry about my bad english.

Last edited by GoldenX (2012-12-05 14:39:16)

Offline

#2 2012-12-04 19:00:10

GoldenX
Member
Registered: 2012-12-04
Posts: 5

Re: [Solved] Fonts mixing or damaged

Well now is doing it.

Here's an example:
http://i.imgur.com/fuPGr.png

Offline

#3 2012-12-04 19:42:06

anonymous_user
Member
Registered: 2009-08-28
Posts: 3,058

Re: [Solved] Fonts mixing or damaged

Does it happen with any application? Any fonts (try both truetype and bitmap)?

Also what video graphics and driver do you have?

Offline

#4 2012-12-04 20:01:19

Gusar
Member
Registered: 2009-08-25
Posts: 3,454

Re: [Solved] Fonts mixing or damaged

Search the forums, there are several threads already about this.

Offline

#5 2012-12-04 20:16:18

GoldenX
Member
Registered: 2012-12-04
Posts: 5

Re: [Solved] Fonts mixing or damaged

Ok I will investigate trying other font types (I'm a noob with this, so if I don't find anything, can I ask here?).
My vga is a Nvidia 7600GT, currently I'm ussing the propietary 304xx drivers, I'll try to test with nouveau too.

I've searched, apparently is a problem with recent cairo versions, I've downgraded it to 1.10 and still have problems.

Offline

#6 2012-12-04 20:24:35

Gusar
Member
Registered: 2009-08-25
Posts: 3,454

Re: [Solved] Fonts mixing or damaged

It's not cairo, it's the pixman glyph cache. And the workaround is to downgrade xorg-server to 1.13.0-3, this version doesn't yet use the glyph cache.

Offline

#7 2012-12-04 21:15:43

bohoomil
Member
Registered: 2010-09-04
Posts: 2,376
Website

Re: [Solved] Fonts mixing or damaged

You can also rebuild the current version of xorg-server with disabled 'use-pixman-glyph-cache.patch'. The whole operation will take circa 10 minutes.


:: Registered Linux User No. 223384

:: github
:: infinality-bundle+fonts: good looking fonts made easy

Offline

#8 2012-12-04 21:35:06

GoldenX
Member
Registered: 2012-12-04
Posts: 5

Re: [Solved] Fonts mixing or damaged

Oh, sorry, bad seach parametters I guess.

Thank you, I'm currently in Windows, I'll test this as soon as I can (already downloaded the old version from ARM). Odd how it didn't happen during the installation and first days, it has been only 15 days since I started using Arch, and the current version of xorg-server is from the 8 of november.

Offline

#9 2012-12-04 22:36:17

mrawfull
Member
Registered: 2011-11-26
Posts: 24

Re: [Solved] Fonts mixing or damaged

Offline

#10 2012-12-04 22:37:12

GoldenX
Member
Registered: 2012-12-04
Posts: 5

Re: [Solved] Fonts mixing or damaged

Thank you so much!
So far is error free, stupid Unity is using it's own xorg-server, well the downgraded normal one works just fine.

Again thaks for your help. Now back to install Arch in an old notebook with no HDD, 256MB of RAM and just an 8GB pendrive xD.

Last edited by GoldenX (2012-12-04 22:39:06)

Offline

Board footer

Powered by FluxBB