You are not logged in.

#4576 2012-11-20 14:02:09

PLANTROON
Member
From: Slovakia
Registered: 2012-08-08
Posts: 61

Re: The AMD/ATI Bar & Grill

@pbCyanide @thyraios I have the same problem. But seriously, Gnome looks cool but look at its performance and compare it to much better looking XFCE. I like that applications menu and all the integration, the notifications and stuff like that. But there is just a solid black panel by default. So it's not worth the slowdown sad Gnome 2 was 100 times better. IMO it was the best DE ever.

Offline

#4577 2012-11-20 16:17:31

fede1587
Member
Registered: 2012-08-26
Posts: 17

Re: The AMD/ATI Bar & Grill

Vi0L0 wrote:
ChemBro wrote:

If you want to feel better: Source games don't work with Catalyst legacy 12.6. (And no, I don't have a key and even if I had one, I couldn't play it, because <---).

Ha, nice try but that didn't actually make me feel better. It's ridiculous that amd isn't updating legacy drvrs, hah... AMD wake up!

C5OK5Y wrote:

Launch steam with steam steam://open/games. I have managed to play World of Goo. For the Valve games (L4D2 and TF2) you actually need to have a beta account.

Thanks for shading light on this case.


Sooo... do we really need an update if there's no man with a beta key?



@fede1587:
maybe there's something in ~/.xsession-errors ?

@Vi0L0
I check, but there i'snt...If I open glx_gears the graphics crash. I see the pointer but the colors and figures are "broken" and I can't do anything...

I check better Xorg.0.log and I found:
[   290.629] (II) fglrx(0): Shutdown CMMQS
[   290.629] (II) fglrx(0): [uki] removed 1 reserved context for kernel
[   290.629] (II) fglrx(0): [uki] unmapping 8192 bytes of SAREA 0x2000 at 0x7faa1bf06000
[   290.630] (II) fglrx(0): Interrupt handler Shutdown.
[   290.633] (WW) xf86CloseConsole: KDSETMODE failed: Input/output error
[   290.633] (WW) xf86CloseConsole: VT_GETMODE failed: Input/output error
[   290.633]
Fatal server error:
[   290.633] xf86CloseConsole: VT_ACTIVATE failed: Input/output error
[   290.633]
[   290.633]
Please consult the The X.Org Foundation support
     at http://wiki.x.org
for help.
[   290.633] Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[   290.633]
[   290.633]
[   290.633] Backtrace:

Can be this the cause of the crash? Thanks a lot!

Last edited by fede1587 (2012-11-20 16:20:08)

Offline

#4578 2012-11-20 16:42:12

Sagorn
Member
Registered: 2012-04-22
Posts: 6

Re: The AMD/ATI Bar & Grill

I recently did a big upgrade on my arch system (it had been about a month since I'd last had the chance to update), and am now unable to get X to start.
The most relevant seeming lines in my Xorg.0.log are:

(II) [KMS] drm report modesetting isn't supported.
(EE) Screen 0 deleted because of no matching config section.
(II) UnloadModule: "radeon"
(EE) Device(s) detected, but none match those in the config file.
Fatal server error: no screens found

After this, x shuts down and I get dropped to the terminal.
From what I've been able to gather, errors like this crop up when you have video driver or multiple monitor issues, but none of the suggestions I've seen have helped.
I'm running an HD4850 with open source drivers and a single monitor.
I've tried downgrading all of the likely looking packages that were upgraded (xf86-video-ati, xorg-server, xorg-server-common, libgl, ati-dri, gnome-desktop, gnome-shell, gdm, etc.), but it has not made any difference.
Also commonly discussed with errors like this was fiddling with xorg.conf.  However, my old, previously working configuration doesn't work, a newly generated configuration doesn't work, and having no configuration doesn't work.

At this point I get the impression I'm missing something obvious, but cannot for the life of me figure out what it is.
Does anyone have any ideas as to what else I could try?

Offline

#4579 2012-11-20 16:47:00

snack
Member
From: Italy
Registered: 2009-01-13
Posts: 672

Re: The AMD/ATI Bar & Grill

@Sagorn: try to move /etc/X11/xorg.conf in another folder and let xorg-server detect your hardware. It may work. Otherwise I think that the best place to ask is the radeon open driver forum, not the catalyst one:

https://bbs.archlinux.org/viewtopic.php?id=79509

Offline

#4580 2012-11-20 18:24:40

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,301
Website

Re: The AMD/ATI Bar & Grill

@Sagorn: linux-firmware ?

edit: just the fyi:
two days ago i downloaded Steam/Team Fortress 2 and even started it, saw valve logo, source engine logo, loading screen with progress bar and... that's all, crash, seg fault, on both beta and beta8 drivers.
Yesterday's steam update is causing segmentation fault even before drawing steam's main window - here i'm only guessing that steam update crashed it... I didn't have time to investigate it, though reinstalling steam, removing ~/Steam and ~/.steam* didn't help smile

edit2: woohoo! success! :>
turns out that early crash was caused by beta8...
downgrade to 12.11 beta let me to run the steam
then to fix in-game crash you will have to add -nojoy in Properties -> Set Launch Options... (you can pick up Properties after RMB click on Team Fortress 2 in Library)

BTW: it's working fine here, no lags or slowdowns thought i'm not the fan of tf2
edit3: played more now and i can see that there are a little slow downs, especially when there's a lot of players in one place... disabling compositing helped here a lot
Tested on fullhd, all maxed out, 8xMSAA, and tear-free enabled, though lowering settings isn't helping for those little slow downs. Anyhow playable


plus update to beta8 is not a good idea at all

Last edited by Vi0L0 (2012-11-22 21:35:51)

Offline

#4581 2012-11-22 17:35:11

fede1587
Member
Registered: 2012-08-26
Posts: 17

Re: The AMD/ATI Bar & Grill

fede1587 wrote:
Vi0L0 wrote:
ChemBro wrote:

If you want to feel better: Source games don't work with Catalyst legacy 12.6. (And no, I don't have a key and even if I had one, I couldn't play it, because <---).

Ha, nice try but that didn't actually make me feel better. It's ridiculous that amd isn't updating legacy drvrs, hah... AMD wake up!

C5OK5Y wrote:

Launch steam with steam steam://open/games. I have managed to play World of Goo. For the Valve games (L4D2 and TF2) you actually need to have a beta account.

Thanks for shading light on this case.


Sooo... do we really need an update if there's no man with a beta key?



@fede1587:
maybe there's something in ~/.xsession-errors ?

@Vi0L0
I check, but there i'snt...If I open glx_gears the graphics crash. I see the pointer but the colors and figures are "broken" and I can't do anything...

I check better Xorg.0.log and I found:
[   290.629] (II) fglrx(0): Shutdown CMMQS
[   290.629] (II) fglrx(0): [uki] removed 1 reserved context for kernel
[   290.629] (II) fglrx(0): [uki] unmapping 8192 bytes of SAREA 0x2000 at 0x7faa1bf06000
[   290.630] (II) fglrx(0): Interrupt handler Shutdown.
[   290.633] (WW) xf86CloseConsole: KDSETMODE failed: Input/output error
[   290.633] (WW) xf86CloseConsole: VT_GETMODE failed: Input/output error
[   290.633]
Fatal server error:
[   290.633] xf86CloseConsole: VT_ACTIVATE failed: Input/output error
[   290.633]
[   290.633]
Please consult the The X.Org Foundation support
     at http://wiki.x.org
for help.
[   290.633] Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[   290.633]
[   290.633]
[   290.633] Backtrace:

Can be this the cause of the crash? Thanks a lot!

Nodooby has an idea? sad

Offline

#4582 2012-11-23 22:04:06

pYrO1v1aniac
Member
Registered: 2011-11-03
Posts: 46

Re: The AMD/ATI Bar & Grill

Hey guys, just installed catalyst 12.11-1 from Community-Testing and it's fixed an issue with TF2 black screening. Unfortunately, now just being in the games' menu causes the fans to run full speed, and eventually overheating and shutting down. This doesn't happen in Windows and it didn't happen in Wine.

Also, the new drivers have a watermark, unsupported hardware, and aticonfig --initial also says no supported adapters detected. I have a Radeon 5470 mobile card, so it should still be supported.

Offline

#4583 2012-11-25 16:23:15

nob.dir
Member
Registered: 2011-10-08
Posts: 16

Re: The AMD/ATI Bar & Grill

Found a strange bug with Wine since catalyst 12.9: http://bugs.winehq.org/show_bug.cgi?id=32282. Anyone would have an idea? (except praying AMD to make the things better...).

Offline

#4584 2012-11-27 01:42:12

fede1587
Member
Registered: 2012-08-26
Posts: 17

Re: The AMD/ATI Bar & Grill

fede1587 wrote:
Vi0L0 wrote:
ChemBro wrote:

If you want to feel better: Source games don't work with Catalyst legacy 12.6. (And no, I don't have a key and even if I had one, I couldn't play it, because <---).

Ha, nice try but that didn't actually make me feel better. It's ridiculous that amd isn't updating legacy drvrs, hah... AMD wake up!

C5OK5Y wrote:

Launch steam with steam steam://open/games. I have managed to play World of Goo. For the Valve games (L4D2 and TF2) you actually need to have a beta account.

Thanks for shading light on this case.


Sooo... do we really need an update if there's no man with a beta key?



@fede1587:
maybe there's something in ~/.xsession-errors ?

@Vi0L0
I check, but there i'snt...If I open glx_gears the graphics crash. I see the pointer but the colors and figures are "broken" and I can't do anything...

I check better Xorg.0.log and I found:
[   290.629] (II) fglrx(0): Shutdown CMMQS
[   290.629] (II) fglrx(0): [uki] removed 1 reserved context for kernel
[   290.629] (II) fglrx(0): [uki] unmapping 8192 bytes of SAREA 0x2000 at 0x7faa1bf06000
[   290.630] (II) fglrx(0): Interrupt handler Shutdown.
[   290.633] (WW) xf86CloseConsole: KDSETMODE failed: Input/output error
[   290.633] (WW) xf86CloseConsole: VT_GETMODE failed: Input/output error
[   290.633]
Fatal server error:
[   290.633] xf86CloseConsole: VT_ACTIVATE failed: Input/output error
[   290.633]
[   290.633]
Please consult the The X.Org Foundation support
     at http://wiki.x.org
for help.
[   290.633] Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[   290.633]
[   290.633]
[   290.633] Backtrace:

Can be this the cause of the crash? Thanks a lot!

Hey guys, I'm still trying to solve my proble. I found that the crash in Elightment appear a lot of times when I launch VitualBox and I found some new lines in Xorg.0.log:

[   201.128] (II) fglrx(0): Restoring Recent Mode via PCS is not supported in RANDR 1.2 capable environments
[   214.192] (II) fglrx(0): Cannot get EDID information for LVDS
[   816.350] (II) AIGLX: Suspending AIGLX clients for VT switch
[   816.353] (II) fglrx(0): Backup framebuffer data.
[   816.478] (II) fglrx(0): Backup complete.
[   822.883] (II) AIGLX: Resuming AIGLX clients after VT switch
[   825.884] (II) AIGLX: Suspending AIGLX clients for VT switch
[   825.885] (II) fglrx(0): Backup framebuffer data.
[   826.008] (II) fglrx(0): Backup complete.

Do you have any idea? sad
Thanks a lot!

Offline

#4585 2012-11-28 17:00:49

mum1989
Member
From: france
Registered: 2009-09-19
Posts: 48

Re: The AMD/ATI Bar & Grill

pYrO1v1aniac wrote:

Hey guys, just installed catalyst 12.11-1 from Community-Testing and it's fixed an issue with TF2 black screening. Unfortunately, now just being in the games' menu causes the fans to run full speed, and eventually overheating and shutting down. This doesn't happen in Windows and it didn't happen in Wine.

Also, the new drivers have a watermark, unsupported hardware, and aticonfig --initial also says no supported adapters detected. I have a Radeon 5470 mobile card, so it should still be supported.

On  Team Fortress 2(steam beta) my performance are poor with HD5870 with catalyst 12.11 whereas under Windows 7 Game run fine with Full setting. (Cpu AMD Phenom II X6 1055T@3.5ghz and 8go Ram)

Last edited by mum1989 (2012-11-29 09:50:40)

Offline

#4586 2012-11-28 19:32:00

cabutan
Member
Registered: 2012-07-18
Posts: 31

Re: The AMD/ATI Bar & Grill

My AMD Radeon HD 6620G does not work with the new catalyst. There is one that partially works and that is catalyst-dkms one but some applications get bad rendering. I am so fed up with the whole catalyst/open source software. It seems that with each system upgrade, catalysts will stop working and same with the open source one. I was happy to see how the open source one was performing under xf86-6.14 and now with the 7 version it just doesnt work..

Offline

#4587 2012-11-30 22:47:46

Commander
Member
Registered: 2011-02-12
Posts: 36

Re: The AMD/ATI Bar & Grill

nob.dir wrote:

Found a strange bug with Wine since catalyst 12.9: http://bugs.winehq.org/show_bug.cgi?id=32282. Anyone would have an idea? (except praying AMD to make the things better...).

Iwe had freezings with wine and fglrx since i started trying to play games with fglrx. Random xorg crashes / infinte loops because of faulty drivers, no one else can fix this but AMD. But since AMD does not invest into Linux Desktop that wont get fixed anytime soon, seems like Catalyst got more and more regressions in the latest drivers that are not even fixed in the next versions. The texture bug that i had on the 12.9 beta and was reported to AMD devs at that time still exist in the current drivers/betas.

I have now tossed the white towel and I am running GTX260 backup card instead of my 6970 that i will sell and buy GTX670 when the price falls during the new year here.

Offline

#4588 2012-12-03 17:22:34

fede1587
Member
Registered: 2012-08-26
Posts: 17

Re: The AMD/ATI Bar & Grill

Hi guys!

I'm working on my problem: Every time I launch virtualbox, Xorg freeze (crash).

I try all possible thing. I'm starting to think that there is an incompatibility between kernel, virtualbox, xorg or fglrx. I have the legacy driver and so, xorg 1.12.

My packet list:
linux 3.6.8-1
xorg-server 1.12.4.1
xorg-server-common 1.13.0-3
xorg-server-utils 7.6-3
virtualbox 4.2.4-2
catalyst-total-hd234k 12.6-5

Do you know if there is some incompatibility between this packet? Are all up-to-date except catalyst and xorg-server...

Thanks a lot! I'm lost days of work but I can't find a solution.... sad

Last edited by fede1587 (2012-12-03 17:22:48)

Offline

#4589 2012-12-04 07:40:46

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,301
Website

Re: The AMD/ATI Bar & Grill

@fede1587:
i rly think you should downgrade xorg-server-common, eventually also xf86-input-* packages - compare what you have got with [xorg112] repo.
Easier way will be to add this repo into pacman.conf above all other repos (it's important) and then run `pacman -Sy && pacman -Suu`


catalyst 12.11 beta 11
i didn't test it yet, but it's probably fixing beta8 bugs. Will check it out later and let you know

Edit: ok, here's some results:
- just like beta8 it's rendering glitches on smplayer when using xv video output;
- steam is able to run, but once i started tf2 it was working slower than with repo's beta, then it crushed and now im unable to load tf2 level any more (it's hanging on loading screen no matter if i choose multi or practice), steam's file validation utility is telling everythings allright... guess i will have to download tf2 once again, heh... lesson: next time do more backups fool ;P...
- it's unstable, during tests i catched a couple of freezes ie. while trying to run amdcccle when smplayer was playing a clip
...

in other words i would like to not to update [catalyst] repo or AUR with THIS.


Some people are saying that steam's games are working better with THIS, and maybe THIS will work better on your hardware so here you can download IT's PKGBUILD with kern 3.7 patch and stuff

Last edited by Vi0L0 (2012-12-04 17:37:01)

Offline

#4590 2012-12-04 23:55:44

fede1587
Member
Registered: 2012-08-26
Posts: 17

Re: The AMD/ATI Bar & Grill

@Vi0l0
Thanks a lot for the reply! I try to downgrade the xorg-server-common packet and all the others as you suggest, but nothing has changed sad
I compared the packet I have with the repository [xorg112]. All the version of the packet are the same, but I have only one packet of the xf86-input-* family: xf86-input-evdev 2.7.3.1 and nothing else.

The packet present in [xorg112] that I have installed are:
xf86-input-evdev 2.7.3-1
xorg-server 1.12.4-1
xorg-server-common 1.12.4-1
xorg-server-utils 7.6-3

Do you notice some important packet missing? Thanks a lot!

Offline

#4591 2012-12-05 08:12:28

omeringen
Member
Registered: 2012-05-28
Posts: 109

Re: The AMD/ATI Bar & Grill

Hi,
Will AMD release new legacy drivers ? Any news about it ?

Offline

#4592 2012-12-05 09:48:09

ChemBro
Member
Registered: 2008-10-22
Posts: 675

Re: The AMD/ATI Bar & Grill

omeringen wrote:

Hi,
Will AMD release new legacy drivers ? Any news about it ?

No news.

Offline

#4593 2012-12-06 09:48:57

ungaminga
Member
Registered: 2012-10-25
Posts: 20

Re: The AMD/ATI Bar & Grill

fede1587 wrote:

@Vi0l0
Thanks a lot for the reply! I try to downgrade the xorg-server-common packet and all the others as you suggest, but nothing has changed sad
I compared the packet I have with the repository [xorg112]. All the version of the packet are the same, but I have only one packet of the xf86-input-* family: xf86-input-evdev 2.7.3.1 and nothing else.

The packet present in [xorg112] that I have installed are:
xf86-input-evdev 2.7.3-1
xorg-server 1.12.4-1
xorg-server-common 1.12.4-1
xorg-server-utils 7.6-3

Do you notice some important packet missing? Thanks a lot!

warning: intel-dri: ignoring package upgrade (8.0.4-3 => 9.0.1-1)
warning: libgl: ignoring package upgrade (8.0.4-3 => 9.0.1-1)
warning: xf86-input-evdev: ignoring package upgrade (2.7.3-1 => 2.7.3-2)
warning: xf86-input-synaptics: ignoring package upgrade (1.6.2-1 => 1.6.2-2)
warning: xf86-video-intel: ignoring package upgrade (2.20.2-2 => 2.20.14-1)
warning: xorg-server: ignoring package upgrade (1.12.4-1 => 1.13.0-4)

used for me.

Offline

#4594 2012-12-06 20:49:31

omeringen
Member
Registered: 2012-05-28
Posts: 109

Re: The AMD/ATI Bar & Grill

Hi,
After i switched to catalyst-legacy i am getting an error while trying to open Bastion game. It was fine with open source drivers, i was using bastionmesa to join.
Found this but still same.

Unhandled Exception: System.Exception: Shader error
  at Microsoft.Xna.Framework.Graphics.Effect.CompileShaderFromSource (System.String source, ShaderType shaderType) [0x00000] in <filename unknown>:0 
  at Microsoft.Xna.Framework.Graphics.Effect.CreateFragmentShaderFromSource (System.String source) [0x00000] in <filename unknown>:0 
  at Microsoft.Xna.Framework.Graphics.SpriteEffect..ctor (Microsoft.Xna.Framework.Graphics.GraphicsDevice graphicsDevice) [0x00000] in <filename unknown>:0 
  at Microsoft.Xna.Framework.Graphics.SpriteBatch..ctor (Microsoft.Xna.Framework.Graphics.GraphicsDevice graphicsDevice) [0x00000] in <filename unknown>:0 
  at GSGE.ExceptionGame.LoadContent () [0x00000] in <filename unknown>:0 
  at Microsoft.Xna.Framework.Game.Initialize () [0x00000] in <filename unknown>:0 
  at Microsoft.Xna.Framework.Game.Run (GameRunBehavior runBehavior) [0x00000] in <filename unknown>:0 
  at Microsoft.Xna.Framework.Game.Run () [0x00000] in <filename unknown>:0 
  at GSGE.App.Run[App] () [0x00000] in <filename unknown>:0 
  at GSGE.App.Main (System.String[] args) [0x00000] in <filename unknown>:0 
[ERROR] FATAL UNHANDLED EXCEPTION: System.Exception: Shader error
  at Microsoft.Xna.Framework.Graphics.Effect.CompileShaderFromSource (System.String source, ShaderType shaderType) [0x00000] in <filename unknown>:0 
  at Microsoft.Xna.Framework.Graphics.Effect.CreateFragmentShaderFromSource (System.String source) [0x00000] in <filename unknown>:0 
  at Microsoft.Xna.Framework.Graphics.SpriteEffect..ctor (Microsoft.Xna.Framework.Graphics.GraphicsDevice graphicsDevice) [0x00000] in <filename unknown>:0 
  at Microsoft.Xna.Framework.Graphics.SpriteBatch..ctor (Microsoft.Xna.Framework.Graphics.GraphicsDevice graphicsDevice) [0x00000] in <filename unknown>:0 
  at GSGE.ExceptionGame.LoadContent () [0x00000] in <filename unknown>:0 
  at Microsoft.Xna.Framework.Game.Initialize () [0x00000] in <filename unknown>:0 
  at Microsoft.Xna.Framework.Game.Run (GameRunBehavior runBehavior) [0x00000] in <filename unknown>:0 
  at Microsoft.Xna.Framework.Game.Run () [0x00000] in <filename unknown>:0 
  at GSGE.App.Run[App] () [0x00000] in <filename unknown>:0 
  at GSGE.App.Main (System.String[] args) [0x00000] in <filename unknown>:0 

Last edited by omeringen (2012-12-06 21:29:14)

Offline

#4595 2012-12-07 01:39:35

Anders H
Member
From: Reno, NV
Registered: 2011-07-31
Posts: 43
Website

Re: The AMD/ATI Bar & Grill

Hello Everyone,

For some time now I have been unable to access my TTY's via CTL-ALT-F1-6. While this does not affect my day to day use of the Awesome WM and my box, it is kind of annoying and it makes me nervous what would happen if I had a major break (like what I cause every now and again) and could not access the TTY's to fix it. I am currently using this repo for Catalyst

http://catalyst.apocalypsus.net/repo/catalyst/$arch/

Because everything else is fine I really don't know where to start to fix this and any help would be appropriated.

Thanks,

Anders

Offline

#4596 2012-12-09 21:15:52

DeepThought
Member
Registered: 2010-12-15
Posts: 8

Re: The AMD/ATI Bar & Grill

Just a thought and maybe a stupid question Anders, but: did you forget to add "nomodeset" to your new config file when/if you upgraded to GRUB2 from legacy? I know I did, and from what I can remember I also had problems with the TTY's.

Offline

#4597 2012-12-10 01:12:40

Anders H
Member
From: Reno, NV
Registered: 2011-07-31
Posts: 43
Website

Re: The AMD/ATI Bar & Grill

No, not a dumb question but I have put "nomodeset" in /etc/default/grub already. I can try rebuilding grub.cfg just in case.

Last edited by Anders H (2012-12-10 01:12:56)

Offline

#4598 2012-12-10 21:56:16

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,301
Website

Re: The AMD/ATI Bar & Grill

^^ i remember that quiet kernel option was making me some troubles with systemd...


Still ineterested in in catalyst 12.11 beta 11 and Team Fortress 2?
I finally get it working well by changing /etc/ati/atiogl.xml file (profile file), specifically by changing hl2_linux to hl3_linux line, iirc (thx to Kano for the tip).
Still i'm not going to put it into repo as i'm still concerned about it's stability

Offline

#4599 2012-12-10 22:30:45

Juan
Member
Registered: 2011-12-10
Posts: 9

Re: The AMD/ATI Bar & Grill

Is it any faster than the first beta for other games? I'm still holding onto 12.10 since I reverted.

Offline

#4600 2012-12-11 06:15:02

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,301
Website

Re: The AMD/ATI Bar & Grill

Didn't notice - i mean i haven't compared actuall results, just run ogl apps and games with fps counter and didn't noticed differences.
Though TF2 works better with beta 11 and hl3 hack, it's smooth.

Offline

Board footer

Powered by FluxBB