You are not logged in.

#1 2012-11-30 12:53:10

mkkot
Member
From: Poland
Registered: 2009-12-20
Posts: 196
Website

[Solved] NVIDIA artefacts on text while browsing web

Hey,

I have nVidia 7300GT card with nvidia-304xx drivers and some webpages look like this:

screen182.png

Before I used noveau drivers but had problems with flashplayer so I changed to proprietary again. My card is marked as legacy since Valve's cooperation with nvidia. Any ideas?

Last edited by mkkot (2012-12-02 16:48:58)

Offline

#2 2012-11-30 15:46:22

berbae
Member
From: France
Registered: 2007-02-12
Posts: 1,129

Re: [Solved] NVIDIA artefacts on text while browsing web

You need to use:
xorg-server 1.13.0-3
xorg-server-common 1.13.0-3

instead of the 1.13.0-4 in the repositories
until a patch to use the pixman glyph cache is either removed or that bug is corrected in the nvidia driver.
Look at https://bugs.archlinux.org/task/32612 where it is described

Last edited by berbae (2012-11-30 15:46:49)

Offline

#3 2012-11-30 18:17:33

mkkot
Member
From: Poland
Registered: 2009-12-20
Posts: 196
Website

Re: [Solved] NVIDIA artefacts on text while browsing web

Thanks for the info! smile
Unfortunately I have done pacman's cache cleaning so I'll wait for 1.13.1 which should(?) fix it.

Offline

#4 2012-12-01 22:47:15

558 jakobsson
Member
From: Sweden
Registered: 2010-01-19
Posts: 15

Re: [Solved] NVIDIA artefacts on text while browsing web

mkkot wrote:

Thanks for the info! smile
Unfortunately I have done pacman's cache cleaning so I'll wait for 1.13.1 which should(?) fix it.

You will find the old version in the ARM. Use the link to read more. If you read more about this bug, it is not for sure that this will be fixed in the next coming version.
You can check out Arch Rollback Machine

Offline

#5 2012-12-02 10:55:19

mkkot
Member
From: Poland
Registered: 2009-12-20
Posts: 196
Website

Re: [Solved] NVIDIA artefacts on text while browsing web

As you can see, I'm using this forum since 3 years, but still suprised with quality of the answers. Thanks! smile

Offline

#6 2012-12-05 21:39:33

loathingkernel
Member
Registered: 2012-01-14
Posts: 2

Re: [Solved] NVIDIA artefacts on text while browsing web

Or you can rebuild the xorg-server package after commenting out the line where the patch is applied in the PKGBUILD.  On a related issue, with the rebuild server, there are no performance issues in firefox or thunderbird either.

Offline

Board footer

Powered by FluxBB