You are not logged in.

#1 2012-12-05 21:30:13

Invie
Member
From: Carnage, Destruction USA
Registered: 2012-09-08
Posts: 70

[SOLVED]Starting a Daemon

When installing the new update for teamviewer, (teamviewer 8) I get this message that tells me that the TeamViewer Daemon is not running, and to start it, and restart teamviewer. As we all know, Arch is build with systemd, or at least the default Arch install...

... How do I go about running the daemon?

I've tried:

Failed to issue method call: No such file or directory
[ ~ ] > systemctl enable teamviewerd
Failed to issue method call: No such file or directory

This:

[ ~ ] > systemctl start teamviewer
Failed to issue method call: Unit teamviewer.service failed to load: No such file or directory. See system logs and 'systemctl status teamviewer.service' for details.

As well as numerous different kinds of spellings for each word amongst these. I have no idea what I'm doing wrong here thus far.

Last edited by Invie (2012-12-06 18:13:38)


Just living is not enough... one must have sunshine, freedom, and a little flower.  ~Hans Christian Andersen

Offline

#2 2012-12-05 21:42:39

UnsolvedCypher
Member
Registered: 2012-04-28
Posts: 198

Re: [SOLVED]Starting a Daemon

Try looking at systemctl list-unit-files, as this should list every .service file available.

Offline

#3 2012-12-06 17:37:28

Xyne
Moderator/TU
Registered: 2008-08-03
Posts: 5,633
Website

Re: [SOLVED]Starting a Daemon

You could also use serman. It will create a checklist menu for all services on the system.

Offline

#4 2012-12-06 18:09:16

Invie
Member
From: Carnage, Destruction USA
Registered: 2012-09-08
Posts: 70

Re: [SOLVED]Starting a Daemon

I'll take a look, thanks.


Just living is not enough... one must have sunshine, freedom, and a little flower.  ~Hans Christian Andersen

Offline

#5 2013-04-27 23:24:48

WFV
Member
From: Fresno, CA
Registered: 2013-04-23
Posts: 125

Re: [SOLVED]Starting a Daemon

open a terminal, log in as root and type this from the # prompt

# systemctl enable teamviewerd.service  <ENTER>

you should get a response like this:

ln -s '/usr/lib/systemd/system/teamviewerd.service' '/etc/systemd/system/graphical.target.wants/teamviewerd.service'

then type in:
# systemctl start teamviewerd.service <ENTER>

if no errors it will return to the # prompt. Pardon my use of old dos (windows) nomenclature but e.g. <ENTER> for hitting the Enter key... I'm new here, and don't know how you get the actual terminal view added here, can use some help, thank you!

Last edited by WFV (2013-05-12 20:47:01)


Asus M5A88-M // AMD FX8350 // Asus Radeon R7-240 // 32GB (4x8) G.Skill Ripjaws-1600 // (1) SSD, (3) HDDs // Arch-Xfce

Offline

#6 2013-04-28 08:58:43

Raynman
Member
Registered: 2011-10-22
Posts: 1,074

Re: [SOLVED]Starting a Daemon

After installing the package, you can also run

pacman -Ql teamviewer | grep \\.service

and by adapting/removing the grep part you can use this strategy to learn about binaries/documentation/....

Last edited by Raynman (2013-04-28 09:00:01)

Online

#7 2013-04-28 09:00:37

HalosGhost
Member
From: Twin Cities, MN
Registered: 2012-06-22
Posts: 1,485
Website

Re: [SOLVED]Starting a Daemon

WFV wrote:
# systemctl enable teamviewerd.service 
ln -s '/usr/lib/systemd/system/teamviewerd.service' '/etc/systemd/system/graphical.target.wants/teamviewerd.service'
# systemctl start teamviewerd.service

Please use code tags, like above.

All the best,

-HG

Last edited by HalosGhost (2013-04-28 09:00:56)


"All errors are ᴘᴇʙᴋᴀᴄ errors—It's just a matter of narrowing down which keyboard and chair." -Trilby
\ldots

Offline

Board footer

Powered by FluxBB