You are not logged in.

#1 2012-12-06 22:34:06

Raiden616
Member
Registered: 2012-11-13
Posts: 28

Weird Skype Microphone Problem

Hi all, got a strange problem using Skype.

I have a Microsoft LifeCam Cinema HD. Alsamixer recognises it fine, but if I load Skype and attempt to access the Sound Devices section in the menu then Skype just crashes. If I unplug the Webcam and use my headset plugged into the front mike jack, there are no problems AT ALL.

Here's the weird part - if I unplug the webcam, load skype and wait for skype to login (which it would do smoothly) and THEN plug the webcam in, I can select it from the audio menu and it work's PERFECTLY.

I imagine it is something to do with conflicting sound devices, but I don't know much about it. Can anyone offer any input?

I should mention that if I run up Skype in the terminal with the webcam plugged in, when I attempt to access the audio options Skype crashes and I get the following error in the terminal:

ALSA lib pcm_dmix.c:1018:(snd_pcm_dmix_open) unable to open slave

Thanks in advance!

Last edited by Raiden616 (2012-12-06 22:40:54)

Offline

#2 2012-12-07 17:34:23

Raiden616
Member
Registered: 2012-11-13
Posts: 28

Re: Weird Skype Microphone Problem

No one got any ideas? sad

Offline

#3 2012-12-07 18:27:06

Arctus
Member
Registered: 2012-07-14
Posts: 85

Re: Weird Skype Microphone Problem

Checked the Skype log?

Offline

#4 2012-12-10 01:38:47

Raiden616
Member
Registered: 2012-11-13
Posts: 28

Re: Weird Skype Microphone Problem

How do I check the Skype log?

Any suggestions would be very welcome - I am completely at a loss here.

Offline

#5 2012-12-21 17:26:47

drrossum
Member
From: Chicago
Registered: 2009-02-24
Posts: 69

Re: Weird Skype Microphone Problem

Same problem here.  Using the same workaround too (unplug usb camera before starting skype).  I noticed the usb webcam can become the primary audio device (in alsamixer) and then Skype doesn't start properly.  Raiden616, does that happen to you too?

I don't know how to prevent the usb webcam from becoming the primary sound device.  Perhaps, one needs some kind of udev rule for this.  Anyone?

Offline

#6 2012-12-23 11:59:22

PReP
Member
From: Sweden/Sala
Registered: 2010-06-13
Posts: 347
Website

Re: Weird Skype Microphone Problem

I am also struck by odd problems like this the latest versions of skype.

What happens is that even if i have my headset selected as in/out in the audio-device-settings
- skype always default to outputting the sound on my speakers.

What i do for a quick non-fix is to press "test sound settings" each time i start skype, and the sound get's set to what it should.


#1 Main: Intel Core i5 2500k (Sandy) @ 3.9 Ghz, 8 GB DDR2-XMP RAM @ 1600 Mhz, Geforce GTX 570 (Gainward Phantom) - Arch Linux 64-Bit
#2 Server: Intel C2D E8400 @ 3.6 Ghz, 3 GB DDR2-RAM @ 802mhz, XFX GF GTX260 XT -ArchLinux 64-bit.

<- Server Homepage: http://prep.mine.nu ->

Offline

Board footer

Powered by FluxBB