You are not logged in.

#1 2005-10-25 06:15:09

rocknice
Member
Registered: 2005-04-01
Posts: 10

new kernel prevents computer from booting

i installed kernel26-scsi 2.6.13.4-1 by means of pacman about a week ago, ran lilo, rebooted to find that before lilo loaded the screen had a bunch of "99"s printing across the screen. Once they stopped printing the processor hung. Every time i restart this happens. I booted to knoppix and installed the same kernel again but it still wouldn't boot. so I booted to knoppix again copied the contents of my scsi that i was trying to boot from to my ide and wiped my scsi. I put in the arch 0.7 cd and did an ftp install on the scsi drive. I installed kernel24-scsi since i had trouble with doing a fresh install with udev, lilo, and the kernel26-scsi, hoping that when i got it running i would be able to put kernel 2.6 on it. it still boots to a bunch of "99"s printed accross the screen and stalls the cpu. Is this some kind of hardware issue with the new kernel or can anyone help me solve this problem?

Offline

#2 2005-10-25 19:20:37

phrakture
Arch Overlord
From: behind you
Registered: 2003-10-29
Posts: 7,879
Website

Re: new kernel prevents computer from booting

did you read the message printed when a new kernel was installed?  You need to remove devfs naming schemes from everything - please post your lilo.conf here, and search the forums... there's alot of people having the same issue

Offline

#3 2005-10-25 19:32:01

Moo-Crumpus
Member
From: Hessen / Germany
Registered: 2003-12-01
Posts: 1,442

Re: new kernel prevents computer from booting

phrakture, you are a hero. Location: behind you is a vov, isn't it. Always there, answering the question again and again. My respects.


Frumpus addict
[mu'.krum.pus], [frum.pus]

Offline

#4 2005-10-25 23:30:37

rocknice
Member
Registered: 2005-04-01
Posts: 10

Re: new kernel prevents computer from booting

yes i did read the message about devfs and the new kernel. yes i did change my lilo config and delete devfs about a month ago and it booted fine, yes i know other people are having the devfs problem, and yes i have read a lot of other forums before i posted this one. gosh Moo-Crumpus.

here is my lilo config i was using before it crashed

-----------------------

#
# /etc/lilo.conf
#

boot=/dev/sda1
#boot=/dev/discs/disc1/disc

# This line often fixes L40 errors on bootup
# disk=/dev/discs/disc0/disc bios=0x80

default=arch
timeout=50
lba32
prompt

image=/boot/vmlinuz26
        label=arch
    root=/dev/sda3
#        root=/dev/discs/disc1/part3
        read-only

#other=/dev/discs/disc1/part1
#        label=dos
# End of file

append="devfs=nomount"

--------------------------

Offline

#5 2005-10-26 08:11:04

Moo-Crumpus
Member
From: Hessen / Germany
Registered: 2003-12-01
Posts: 1,442

Re: new kernel prevents computer from booting

rocknice wrote:

gosh Moo-Crumpus.

What do you blame me for? I payed deference to phrakture for not giving up. Unlike him, I am tired of asking again and again if one has read this or that. He is constantly helpful, isn't he, while I tend to be snubbed.

As you have not told us you where prepared for udev/devfs - and 80% of help calls here and in irc have been udev related - phrakture had to guess - he did a quick shot and missed. So what?

Let's see if we can help you.

Unfortunately, I don't use or kn ow lilo very well. As far as I know, lilo has some strange issues if beeing used in a dual boot to windows or linux scenario, and some other strange behaviours. Furthermore, 99 99 99 99 99 99 99 99 etc seemes to be a lilo message that should tell you lilo can't get further then stage one. This can be a damaged mbr, for example, or if windows has repaired the mbr and destroyed lilo, or a physically damaged hard disk. Have you rerun "lilo" or "liloconf"? They will reinstall LILO to the drive and make the second stage loader look in the right spot...which apparently it is not, hence the L 99 99 99 99 ...

As you tried a reinstall using ftp, I think you could try cd based install, to be sure. I would recommend to use grub instead of lilo.


Frumpus addict
[mu'.krum.pus], [frum.pus]

Offline

Board footer

Powered by FluxBB