You are not logged in.

#1 2012-12-09 05:38:50

vwyodajl
Member
Registered: 2012-01-21
Posts: 183

[SOLVED] Pacmanager error after uuid update

I have been using pacmanager for awhile and have had no issues with updates to its dependencies. Today an update to uuid came and I started getting errors when trying to start pacmanager. So I went to the AUR page noticed someone previously had the same issue and they solved by rebuilding the AUR packages that were dependencies. I went through that and did not getting any further in the solving of the problem, also tried rebuilding all the dependencies as well as the main package after they were rebuilt still to no avail. Can anyone shed some light on what I am missing here, I feel like it should be obvious but for some reason is evading me.

Can't locate OSSP/uuid.pm in @INC (@INC contains: /usr/share/pacmanager/lib /usr/share/pacmanager/lib/ex /usr/share/pacmanager/lib/edit /usr/lib/perl5/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/core_perl /usr/share/perl5/core_perl .) at /usr/share/pacmanager/lib/PACMain.pm line 39.
BEGIN failed--compilation aborted at /usr/share/pacmanager/lib/PACMain.pm line 39.
Compilation failed in require at /usr/bin/pac line 35.
BEGIN failed--compilation aborted at /usr/bin/pac line 35.

So as you see it seems to not being able to find something from uuid. Thanks for any help or smacking me to realize what I am missing here. Also I did verify what it is looking for does not exist on my system.

EDIT:
While trying to still sort this out I have run into something that seems "weird" to me I was looking over the uuid package just a moment ago, and the AUR page stats it was uploaded first today, yet it has been installed on my box before today? I know the package I maintain on AUR actually shows when it was first submitted normally. How could this have been used as a dependency before this but was initially submitted the 8th yesterday? It may be nothing just seems strange to me, also if it was submitted on the 8th its all ready been orphaned.

EDIT2:
Well after lots of tinkering around I cloned the AUR repo to get the -8 version of uuid to see if I could notice what had changed through the update. I noticed that configure was missing the --with-perl call which is why I was missing the file that I was. But the part that I still do not get is how can an unmaintained packaged get updated, and with major changes. It got a new patch and a new PKGBUILD between -8 and -9. I am trying to sort through what the actual differences are with the patches as time permits for me, if I can confidently say why the changes took place I will take over the package as well, but honestly at this point I am at a loss for why the changes that were done took place on the 8th.

Last edited by vwyodajl (2012-12-09 20:28:22)

Offline

#2 2012-12-10 12:59:46

Mektub
Member
From: Lisbon /Portugal
Registered: 2008-01-02
Posts: 647

Re: [SOLVED] Pacmanager error after uuid update

vwyodajl wrote:

But the part that I still do not get is how can an unmaintained packaged get updated, and with major changes.

Thats quite surprising. I would also like to know how that happens.
Are there ghosts on the AUR ?

Mektub


Follow me on twitter: https://twitter.com/johnbina

Offline

#3 2012-12-10 13:07:26

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 4,160

Re: [SOLVED] Pacmanager error after uuid update

Maybe uuid was moved from [community] to aur on that day ?


Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#4 2012-12-10 18:12:12

vwyodajl
Member
Registered: 2012-01-21
Posts: 183

Re: [SOLVED] Pacmanager error after uuid update

Not really sure what is/was up with that. I took over maintaining the package in the AUR though. I fixed it for pacmanager to build the perl parts properly. We will see how it goes.

It is possible though that is what happened is it went from [community] to AUR. Just always thought it was an AUR package to being with, I could be wrong though.

Offline

Board footer

Powered by FluxBB