You are not logged in.

#1 2012-12-09 06:25:14

chaddad
Member
Registered: 2012-03-05
Posts: 6

[SOLVED] Having Problems with locale

I have installed the latest arch Linux install version 2012.12.01 and i first want to know why the whole install has changed what happened to the blue and grey interface, now it is just a root login with a terminal? second of all doing all this even more manual then before has just caused me many errors installing, first one i am getting after i installed the whole thing is:

"-bash: UTF-8: command not found" this happens as soon as i login as root or my own user, this is only error i have left, and i have configured my local.conf to en_AU etc and ran locale.gen...

but now when i run "locale" everything says LANGUAGE="C" LANGUAGE="C" etc...

I am not sure what is going on here? Please Help

Last edited by chaddad (2012-12-09 10:56:49)

Offline

#2 2012-12-09 06:29:39

jasonwryan
Forum & Wiki Admin
From: .nz
Registered: 2009-05-09
Posts: 19,077
Website

Re: [SOLVED] Having Problems with locale

1. The old installer was no longer maintained; the new one is cleaner and more consistent with the Arch Way.

2. Have you set up your locale in /etc/locale.gen and then run locale-gen as per the wiki?


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

#3 2012-12-09 07:04:24

chaddad
Member
Registered: 2012-03-05
Posts: 6

Re: [SOLVED] Having Problems with locale

Yes i have, set my local.conf file to the correct encoding, i have ran locale.gen, i followed the beginners guide which told me to do all this already, but it just is not working...

Offline

#4 2012-12-09 07:07:59

jasonwryan
Forum & Wiki Admin
From: .nz
Registered: 2009-05-09
Posts: 19,077
Website

Re: [SOLVED] Having Problems with locale

Please pastebin both files. Also, please edit your first post and change the title to one that accurately reflects your issue: https://wiki.archlinux.org/index.php/Fo … ow_to_Post


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

#5 2012-12-09 07:29:59

chaddad
Member
Registered: 2012-03-05
Posts: 6

Re: [SOLVED] Having Problems with locale

I cannot actually paste them because i am using a windows desktop to speak to you on the forums, and  my linux machine which is only half way through setting up i cannot access internet to paste them. but i can tell you that i un commented my language that i wanted to use in my /etc/locale.gen and then i echoed it out to /etc/local.conf, i then exported it, then when i typed locale... they all said example="en_AU.UTF-8" then when i reboot my machine they all revert to ="C"?

Offline

#6 2012-12-09 07:42:32

jasonwryan
Forum & Wiki Admin
From: .nz
Registered: 2009-05-09
Posts: 19,077
Website

Re: [SOLVED] Having Problems with locale

Without looking at the files I can't really offer any more help. In you first post, you said the error was related to bash choking on a UTF-8 command, and then you said that your locale is defaulting to C. The first error sounds like a misconfiguration, the second like you weren't in the chroot, but that is just guessing based on your recollection of the errors; you need to chroot in and check the files, pasting them here if you want better assistance.


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

#7 2012-12-09 08:56:52

skunktrader
Member
From: Brisbane, Australia
Registered: 2010-02-14
Posts: 1,320

Re: [SOLVED] Having Problems with locale

You keep mentioning /etc/local.conf but the correct filename is /etc/locale.conf
On my machine I have the following

$ cat /etc/locale.conf 
LANG=en_AU.UTF-8

Online

#8 2012-12-09 10:56:32

chaddad
Member
Registered: 2012-03-05
Posts: 6

Re: [SOLVED] Having Problems with locale

Oh wow worst mistake i ever made, thanks so much for pointing that out, it worked.

Offline

Board footer

Powered by FluxBB